aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 01:47:41 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 01:56:58 +0000
commit1a529efe79abc368221009c7efc292ace02a3f47 (patch)
tree09ec28c258f4ec2666076e9d8f1ab7ae33d5ead6
parentbaaac2f12e68b5a9bf4cf6c7a005b766c60b7f6b (diff)
downloadports-1a529efe79abc368221009c7efc292ace02a3f47.tar.gz
ports-1a529efe79abc368221009c7efc292ace02a3f47.zip
math/fxt: Update to 2023.10.26
-rw-r--r--math/fxt/Makefile3
-rw-r--r--math/fxt/distinfo6
-rw-r--r--math/fxt/files/patch-makefile40
3 files changed, 13 insertions, 36 deletions
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
index e11e9d6b2eb3..c41765821dc9 100644
--- a/math/fxt/Makefile
+++ b/math/fxt/Makefile
@@ -1,5 +1,5 @@
PORTNAME= fxt
-PORTVERSION= 2023.06.27
+PORTVERSION= 2023.10.26
CATEGORIES= math
MASTER_SITES= https://www.jjj.de/fxt/
@@ -14,6 +14,7 @@ USES= compiler:c++11-lang gmake
MAKE_ENV= FXT_INSTALL="${INSTALL_DATA}"
MAKEFILE= makefile
+USE_CXXSTD= c++11
WRKSRC= ${WRKDIR}/fxt
OPTIONS_DEFINE= EXAMPLES
diff --git a/math/fxt/distinfo b/math/fxt/distinfo
index f1186027ba85..82e1d0586c81 100644
--- a/math/fxt/distinfo
+++ b/math/fxt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1688166066
-SHA256 (fxt-2023.06.27.tar.gz) = 2a63ea4d4d01d64177b11edde699ce9348cf8ad923f2c4a0111dd9b1395d4df7
-SIZE (fxt-2023.06.27.tar.gz) = 1854788
+TIMESTAMP = 1698340927
+SHA256 (fxt-2023.10.26.tar.gz) = 121a54fdab9fd68ef75de811ba20740431979532fc551c2dd72e3f45f60e6bfa
+SIZE (fxt-2023.10.26.tar.gz) = 1854920
diff --git a/math/fxt/files/patch-makefile b/math/fxt/files/patch-makefile
index ed412ac3f861..54801d4c0521 100644
--- a/math/fxt/files/patch-makefile
+++ b/math/fxt/files/patch-makefile
@@ -1,4 +1,4 @@
---- makefile.orig 2021-04-06 13:42:27 UTC
+--- makefile.orig 2023-10-20 14:17:07 UTC
+++ makefile
@@ -8,22 +8,22 @@ PROJ=fxt
include flags.mk
@@ -15,7 +15,8 @@
-FXT_CXXFLAGS += $(OFLAGS) # uncomment for OPTIMIZATION
+#FXT_CXXFLAGS += $(OFLAGS) # uncomment for OPTIMIZATION
#FXT_CXXFLAGS += -O3 # test -O3
- #FXT_CXXFLAGS += $(GFLAGS) # uncomment for DEBUGGING
+-FXT_CXXFLAGS += $(GFLAGS) # uncomment for DEBUGGING
++#FXT_CXXFLAGS += $(GFLAGS) # uncomment for DEBUGGING
#FXT_CXXFLAGS += $(PFLAGS) # uncomment for PROFILING
#
-FXT_CXXFLAGS += $(WFLAGS) # uncomment for WARNINGS
@@ -29,9 +30,12 @@
#FXT_CXXFLAGS += $(CLANG_FLAGS) ## for clang++
-@@ -200,27 +200,27 @@ install: lib
+@@ -199,15 +199,15 @@ INCDIR=$(PREFIX)/include/fxt
+ .PHONY: install ## install to $(PREFIX)/lib/ and $(PREFIX)/include/fxt/
+ install: lib
: '[$@]'
- @echo 'PREFIX=$(PREFIX) LIBDIR=$(LIBDIR) INCDIR=$(INCDIR)'
+- @echo 'PREFIX=$(PREFIX) LIBDIR=$(LIBDIR) INCDIR=$(INCDIR)'
++ @echo 'PREFIX=$(PREFIX) LIBDIR=$(LIBDIR) INCDIR=$(DESTDIR)$(INCDIR)'
@:
- @test -d $(INCDIR) || mkdir $(INCDIR)
- @$(FXT_INSTALL) $(FXTIDIR)/*.h $(INCDIR)/
@@ -49,31 +53,3 @@
: '[$@ OK]'
.PHONY: chk-install ##x print whether installed header files are up to date
- chk-install:
- @(cd src && find . -maxdepth 2 -name \*.h | sort) > tmp-hdr1
-- @(cd $(INCDIR)/ && find . -name \*.h | sort) > tmp-hdr2
-+ @(cd $(DESTDIR)$(INCDIR)/ && find . -name \*.h | sort) > tmp-hdr2
- @-diff tmp-hdr1 tmp-hdr2
- @rm tmp-hdr1 tmp-hdr2
-
--.PHONY: uninstall ## uninstall headers and lib, but leave directory $(INCDIR)
-+.PHONY: uninstall ## uninstall headers and lib, but leave directory $(DESTDIR)$(INCDIR)
- uninstall:
-- : '[$@]' ## note: we do not remove $(INCDIR)
-- rm -rf $(INCDIR)/*
-- rm -f $(LIBDIR)/$(FXTLIB)
-+ : '[$@]' ## note: we do not remove $(DESTDIR)$(INCDIR)
-+ rm -rf $(DESTDIR)$(INCDIR)/*
-+ rm -f $(DESTDIR)$(LIBDIR)/$(FXTLIB)
-
- .PHONY: reinstall ## uninstall and install
- reinstall: # uninstall install
-@@ -785,7 +785,7 @@ showsrc:
- # @for h in */*.h; do \
- # grep -L $$h depend.mk &>/dev/null || echo $$h ; done
- #
--## @for h in $$(ls -1 $(INCDIR) ); do \
-+## @for h in $$(ls -1 $(DESTDIR)$(INCDIR) ); do \
-
- #.PHONY: shownotes ##x show comments that contain the string "note"
- #shownotes: