aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-08-26 02:59:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-08-26 03:00:23 +0000
commit1aac3a8eca580ac591eeef6fe726ff803683373c (patch)
tree12492ef9743c32bc5a05ab0fa28ce3a1e9b2e3ce
parent0633b30f8fca4b7609fe985b8220da1a4c564004 (diff)
downloadports-1aac3a8eca580ac591eeef6fe726ff803683373c.tar.gz
ports-1aac3a8eca580ac591eeef6fe726ff803683373c.zip
audio/py-soxr: Add workaround to fix wrong version variable
-rw-r--r--audio/py-soxr/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/audio/py-soxr/Makefile b/audio/py-soxr/Makefile
index 2be504c02354..c1013fb15b8d 100644
--- a/audio/py-soxr/Makefile
+++ b/audio/py-soxr/Makefile
@@ -1,5 +1,6 @@
PORTNAME= soxr
DISTVERSION= 0.3.6
+PORTREVISION= 1
CATEGORIES= audio python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +14,8 @@ LICENSE_COMB= multi
BROKEN_i386= fails to compile: ...requires target feature 'sse', but would be inlined into function 'h8' that is compiled without support for 'sse'
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
${PYNUMPY} \
${PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYNUMPY}
@@ -24,6 +26,9 @@ USE_PYTHON= pep517 cython autoplist pytest
TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
post-install:
+ # strip binary
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/soxr/cysoxr${PYTHON_EXT_SUFFIX}.so
+ # correct version as a workaround for https://github.com/dofuuz/python-soxr/issues/21
+ @${REINPLACE_CMD} -i '' -e 's|^version |__version__ |' ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/soxr/_version.py
.include <bsd.port.mk>