aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2022-09-11 12:00:11 +0000
committerFelix Palmen <zirias@FreeBSD.org>2022-09-11 14:38:12 +0000
commit1b674b6287a245d620ee4d80e48b2f2ae47ff2cb (patch)
tree2836879fe73481fa2c7c9c537dab82e74e481fa7
parentc01895784b65bdbaa47e5de17bc9c377db66c37d (diff)
downloadports-1b674b6287a245d620ee4d80e48b2f2ae47ff2cb.tar.gz
ports-1b674b6287a245d620ee4d80e48b2f2ae47ff2cb.zip
Mk/Uses/qt.mk: Fix metaports after USE_QT change
devel/qt5 and devel/qt6 use a generated USE_QT that wasn't caught by commit ddae4e92d8313a1461145e3b4f0232fe463feaee: Mk/Uses: always use colon for build/run suffix Fix it manually. Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D36524
-rw-r--r--devel/qt5/Makefile2
-rw-r--r--devel/qt6/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/devel/qt5/Makefile b/devel/qt5/Makefile
index e970fb458457..b3f005def417 100644
--- a/devel/qt5/Makefile
+++ b/devel/qt5/Makefile
@@ -10,7 +10,7 @@ WWW= https://www.qt.io/
# * phonon4 is not part of Qt itself.
# * we don't want to pull in wayland just yet.
# XXX(rene) exclude webengine
-USE_QT= ${_USE_QT_ALL:Nphonon4:Ndeclarative:Nwayland:Nwebengine:S/$/_run/}
+USE_QT= ${_USE_QT_ALL:Nphonon4:Ndeclarative:Nwayland:Nwebengine:S/$/:run/}
USES= metaport qt:5
.include <bsd.port.mk>
diff --git a/devel/qt6/Makefile b/devel/qt6/Makefile
index e37618e2bf64..c4e795320e42 100644
--- a/devel/qt6/Makefile
+++ b/devel/qt6/Makefile
@@ -7,6 +7,6 @@ COMMENT= Cross-platform application and UI framework (metaport)
WWW= https://www.qt.io/
USES= metaport qt:6
-USE_QT= ${_USE_QT_ALL:S/$/_run/}
+USE_QT= ${_USE_QT_ALL:S/$/:run/}
.include <bsd.port.mk>