aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2023-11-29 09:38:54 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-11-29 09:43:09 +0000
commit1bb647d1af0170fd4e65e3cca0442262ab6825ca (patch)
tree63ca42b8ca4c70f543a7a9169a94c3e8314b1e36
parent8a00b2d38036e69517cd6e282702cada6ee0a2ea (diff)
downloadports-1bb647d1af0170fd4e65e3cca0442262ab6825ca.tar.gz
ports-1bb647d1af0170fd4e65e3cca0442262ab6825ca.zip
games/py-mnemosyne: Add missing run depend
Add QT sqldriver-sqlite missing run depend needed for browsing cards. PR: 274972 Reported by: Andreas Kempe MFH: 2023Q4
-rw-r--r--games/py-mnemosyne/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/py-mnemosyne/Makefile b/games/py-mnemosyne/Makefile
index 587fc7262cc7..8ef0f66e1c4c 100644
--- a/games/py-mnemosyne/Makefile
+++ b/games/py-mnemosyne/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mnemosyne
PORTVERSION= 2.10.1
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= games education python
MASTER_SITES= SF/mnemosyne-proj/${PORTNAME}/${PORTNAME}-${DISTVERSION}
@@ -24,9 +24,10 @@ RUN_DEPENDS= ${PY_PILLOW} \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}webob>=1.4:www/py-webob@${PY_FLAVOR}
-USES= pyqt:6 python shebangfix
+USES= pyqt:6 python qt:6 shebangfix
USE_PYQT= pyqt6:run sip:run webengine:run
USE_PYTHON= autoplist concurrent distutils
+USE_QT= sqldriver-sqlite:run
SHEBANG_FILES= mnemosyne/pyqt_ui/mnemosyne