aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-12-25 18:14:47 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-12-25 18:14:47 +0000
commit1bbed6b25b379cbc6640ee449eb3fa4c3c500b43 (patch)
treedc6163f4f67fa5bd6ed66fd1edc110349bcf4fb2
parentb20d752dbcd02980bf063edc4d1771d6a197e39e (diff)
downloadports-1bbed6b25b379cbc6640ee449eb3fa4c3c500b43.tar.gz
ports-1bbed6b25b379cbc6640ee449eb3fa4c3c500b43.zip
- WITH_APACHE2 is deprecated
Notes
Notes: svn path=/head/; revision=246614
-rw-r--r--www/p5-Apache-AuthenCache/Makefile9
-rw-r--r--www/p5-Apache-Gallery/Makefile13
2 files changed, 11 insertions, 11 deletions
diff --git a/www/p5-Apache-AuthenCache/Makefile b/www/p5-Apache-AuthenCache/Makefile
index 4f163ac8b203..106af489e91b 100644
--- a/www/p5-Apache-AuthenCache/Makefile
+++ b/www/p5-Apache-AuthenCache/Makefile
@@ -16,16 +16,13 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module that implements authentication caching
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/Object.pm:${PORTSDIR}/devel/p5-Time-Object \
- ${SITE_PERL}/IPC/Cache.pm:${PORTSDIR}/devel/p5-IPC-Cache
+ ${SITE_PERL}/IPC/Cache.pm:${PORTSDIR}/devel/p5-IPC-Cache \
+ ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
RUN_DEPENDS= ${BUILD_DEPENDS}
MAKE_JOBS_SAFE= yes
-.if defined(WITH_APACHE2)
-IGNORE= this module is only for www/mod_perl
-.else
-BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
-.endif
+USE_APACHE= 1.3
PERL_CONFIGURE= yes
diff --git a/www/p5-Apache-Gallery/Makefile b/www/p5-Apache-Gallery/Makefile
index 274208ed2e66..e8d0d3f5991c 100644
--- a/www/p5-Apache-Gallery/Makefile
+++ b/www/p5-Apache-Gallery/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Apache-Gallery
PORTVERSION= 1.0.r3
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= www perl5
MASTER_SITES= http://apachegallery.dk/download/ \
@@ -26,10 +26,13 @@ BUILD_DEPENDS= ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
RUN_DEPENDS= ${BUILD_DEPENDS}
-.if defined(WITH_APACHE2)
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Request.pm:${PORTSDIR}/www/p5-libapreq2
-.else
+USE_APACHE= 1.3+
+
+.include <bsd.port.pre.mk>
+.if ${APACHE_VERSION} == 13
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Request.pm:${PORTSDIR}/www/p5-libapreq2
.endif
PERL_CONFIGURE= yes
@@ -61,4 +64,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>