aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTrond Endrestol <Trond.Endrestol@ximalas.info>2023-07-27 06:48:20 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-07-28 06:32:51 +0000
commit1bd91c34660f630db4d1414a2d64b47162a5baad (patch)
tree7a9da8de328244c42186c89769abbaf25ba8590f
parentc85caa3933d08274a9ba9b1be16ee8af5583b99a (diff)
downloadports-1bd91c34660f630db4d1414a2d64b47162a5baad.tar.gz
ports-1bd91c34660f630db4d1414a2d64b47162a5baad.zip
x11-wm/blackbox: switch from std::mem_fun to std::mem_fn
The former is deprecated. PR: 272660 Reported by: Trond.Endrestol@ximalas.info Approved by: A.J.Caines@halplant.com (maintainer)
-rw-r--r--x11-wm/blackbox/Makefile2
-rw-r--r--x11-wm/blackbox/files/patch-src_Screen.cc24
-rw-r--r--x11-wm/blackbox/files/patch-src_blackbox.cc25
3 files changed, 50 insertions, 1 deletions
diff --git a/x11-wm/blackbox/Makefile b/x11-wm/blackbox/Makefile
index c4097601a3f0..73b775d435b8 100644
--- a/x11-wm/blackbox/Makefile
+++ b/x11-wm/blackbox/Makefile
@@ -1,6 +1,6 @@
PORTNAME= blackbox
PORTVERSION= 0.70.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-wm
MASTER_SITES= SF/${PORTNAME}wm/${PORTNAME}wm/Blackbox%20${PORTVERSION}
diff --git a/x11-wm/blackbox/files/patch-src_Screen.cc b/x11-wm/blackbox/files/patch-src_Screen.cc
index 4bb2df4678be..edab37f53e0b 100644
--- a/x11-wm/blackbox/files/patch-src_Screen.cc
+++ b/x11-wm/blackbox/files/patch-src_Screen.cc
@@ -17,3 +17,27 @@
removeLastWorkspace();
}
} else if (event->message_type == _blackbox->ewmh().desktopNames()) {
+@@ -1927,12 +1928,12 @@ void BScreen::toggleFocusModel(FocusModel model) {
+
+ void BScreen::toggleFocusModel(FocusModel model) {
+ std::for_each(windowList.begin(), windowList.end(),
+- std::mem_fun(&BlackboxWindow::ungrabButtons));
++ std::mem_fn(&BlackboxWindow::ungrabButtons));
+
+ _blackbox->resource().setFocusModel(model);
+
+ std::for_each(windowList.begin(), windowList.end(),
+- std::mem_fun(&BlackboxWindow::grabButtons));
++ std::mem_fn(&BlackboxWindow::grabButtons));
+ }
+
+
+@@ -1976,7 +1977,7 @@ void BScreen::updateClientListHint(void) const {
+ bt::EWMH::WindowList clientList(windowList.size());
+
+ std::transform(windowList.begin(), windowList.end(), clientList.begin(),
+- std::mem_fun(&BlackboxWindow::clientWindow));
++ std::mem_fn(&BlackboxWindow::clientWindow));
+
+ _blackbox->ewmh().setClientList(screen_info.rootWindow(), clientList);
+ }
diff --git a/x11-wm/blackbox/files/patch-src_blackbox.cc b/x11-wm/blackbox/files/patch-src_blackbox.cc
index 0fbb12cbe04c..7821c234a12c 100644
--- a/x11-wm/blackbox/files/patch-src_blackbox.cc
+++ b/x11-wm/blackbox/files/patch-src_blackbox.cc
@@ -17,6 +17,24 @@
#include <unistd.h>
// #define FOCUS_DEBUG
+@@ -113,7 +116,7 @@ void Blackbox::shutdown(void) {
+ XSetInputFocus(XDisplay(), PointerRoot, RevertToPointerRoot, XTime());
+
+ std::for_each(screen_list, screen_list + screen_list_count,
+- std::mem_fun(&BScreen::shutdown));
++ std::mem_fn(&BScreen::shutdown));
+
+ XSync(XDisplay(), false);
+
+@@ -367,7 +370,7 @@ void Blackbox::timeout(bt::Timer *) {
+ menuTimestamps.clear();
+
+ std::for_each(screen_list, screen_list + screen_list_count,
+- std::mem_fun(&BScreen::reconfigure));
++ std::mem_fn(&BScreen::reconfigure));
+
+ bt::Font::clearCache();
+ bt::PixmapCache::clearCache();
@@ -422,7 +425,7 @@ Blackbox::Blackbox(char **m_argv, const char *dpy_name
if (managed == 0) {
fprintf(stderr, "%s: no managable screens found, exiting...\n",
@@ -26,3 +44,10 @@
}
screen_list_count = managed;
+@@ -620,5 +623,5 @@ void Blackbox::rereadMenu(void) {
+ menuTimestamps.clear();
+
+ std::for_each(screen_list, screen_list + screen_list_count,
+- std::mem_fun(&BScreen::rereadMenu));
++ std::mem_fn(&BScreen::rereadMenu));
+ }