aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2013-03-26 14:48:17 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2013-03-26 14:48:17 +0000
commit1c67c8e0e43734373f9a76b66b31d8a1757e1450 (patch)
tree82fc8fdf71e394a06e07c95932bcc0e023fccd1e
parenteb34d6cd681a927f3a68fd90986ba981da01950d (diff)
downloadports-1c67c8e0e43734373f9a76b66b31d8a1757e1450.tar.gz
ports-1c67c8e0e43734373f9a76b66b31d8a1757e1450.zip
Convert to options ng
PR: ports/177209 Submitted by: William Grzybowski <william88@gmail.com>
Notes
Notes: svn path=/head/; revision=315304
-rw-r--r--emulators/mtools/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/emulators/mtools/Makefile b/emulators/mtools/Makefile
index 7869aeca636d..7caf6b3e65ea 100644
--- a/emulators/mtools/Makefile
+++ b/emulators/mtools/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mtools
-# Date created: 5 October 1994
-# Whom: jmz
-#
+# Created by: jmz
# $FreeBSD$
-#
PORTNAME= mtools
PORTVERSION= 4.0.10
@@ -33,22 +29,27 @@ MAN1= mattrib.1 mbadblocks.1 mcat.1 mcd.1 mclasserase.1 mcopy.1 \
MAN5= mtools.5
INFO= mtools
-.if defined(WITHOUT_ICONV)
-CONFIGURE_ENV+= ac_cv_header_iconv_h=no
-.else
+OPTIONS_DEFINE= ICONV X11
+OPTIONS_DEFAULT=ICONV X11
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MICONV}
USE_ICONV= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -liconv
+.else
+CONFIGURE_ENV+= ac_cv_header_iconv_h=no
.endif
-.if defined(WITHOUT_X11)
-CONFIGURE_ARGS+= --without-x
-PLIST_SUB= X11="@comment "
-MAKE_ENV+= WITHOUT_X11=${WITHOUT_X11}
-.else
+.if ${PORT_OPTIONS:MX11}
USE_XORG= x11 sm ice xau
PLIST_SUB= X11=""
MAN1+= floppyd.1 floppyd_installtest.1
+.else
+CONFIGURE_ARGS+= --without-x
+PLIST_SUB= X11="@comment "
+MAKE_ENV+= WITHOUT_X11=${WITHOUT_X11}
.endif
post-patch: