aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2019-12-08 15:14:42 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2019-12-08 15:14:42 +0000
commit1cbb20734f2bf707b4f8b4e3feb814e32aa16665 (patch)
tree9b7e3b9acf4158890f653bb3dc57b88c7349b62e
parent522767f54ae753c5845804722ea9cebf4f2c65f6 (diff)
downloadports-1cbb20734f2bf707b4f8b4e3feb814e32aa16665.tar.gz
ports-1cbb20734f2bf707b4f8b4e3feb814e32aa16665.zip
- Update to 2.0.10
- Pass maintainership to submitter Submitted by: voidanix@420blaze.it Differential Revision: https://reviews.freebsd.org/D21057
Notes
Notes: svn path=/head/; revision=519308
-rw-r--r--games/jinput/Makefile49
-rw-r--r--games/jinput/distinfo5
-rw-r--r--games/jinput/files/patch-openjdk710
-rw-r--r--games/jinput/pkg-descr2
4 files changed, 31 insertions, 35 deletions
diff --git a/games/jinput/Makefile b/games/jinput/Makefile
index 8360011aeefd..c9a5d517339d 100644
--- a/games/jinput/Makefile
+++ b/games/jinput/Makefile
@@ -1,40 +1,45 @@
-# Created by: loader <loader@freebsdmall.com>
# $FreeBSD$
PORTNAME= jinput
-DISTVERSION= 20110801.r247
+DISTVERSION= 2.0.10
+PORTEPOCH= 1
CATEGORIES= games java
-MASTER_SITES= LOCAL/loader
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= voidanix@420blaze.it
COMMENT= Java Game Controller API
-BUILD_DEPENDS= ${JAVALIBDIR}/jutils/jutils.jar:games/jutils
-RUN_DEPENDS= ${JAVALIBDIR}/jutils/jutils.jar:games/jutils
+LICENSE= BSD2CLAUSE
-BROKEN_armv6= fails to compile: build.xml: compilation failed
-BROKEN_armv7= fails to compile: build.xml: compilation failed
+BROKEN_armv6= fails to compile
+BROKEN_armv7= fails to compile
-USES= tar:bzip2
-USE_JAVA= yes
-JAVA_OS= native
-JAVA_VENDOR= openjdk
-USE_ANT= yes
-ALL_TARGET= simple_linux
-NO_ARCH= yes
+BUILD_DEPENDS= ${JAVAJARDIR}/jutils/jutils.jar:games/jutils \
+ mvn:devel/maven
+RUN_DEPENDS= ${JAVAJARDIR}/jutils/jutils.jar:games/jutils
-PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}/${PORTNAME}.jar
+# Using a fork because of maven dependencies
+USE_GITLAB= yes
+GL_ACCOUNT= voidanix
+GL_COMMIT= bf22dd975bbba31f01895332255b63df376894e6
-post-patch:
- @${LN} -sf ${JAVALIBDIR}/jutils/jutils.jar ${WRKSRC}/lib/
+USE_JAVA= 8+
+
+PLIST_FILES= ${JAVAJARDIR}/${PORTNAME}/${PORTNAME}.jar
+PLIST_DIRS= ${JAVAJARDIR}/${PORTNAME}
+
+MAVEN_ARGS= -Dmaven.antrun.skip -Dmaven.javadoc.skip -Dmaven.source.skip -Dmaven.test.skip -DskipTests -DskipITs
+MAVEN_REPO= -Dmaven.repo.local=${WRKSRC}/repository
+
+pre-build:
+ ${CP} ${JAVAJARDIR}/jutils/jutils.jar ${WRKSRC}/repository/net/java/jutils/jutils/1/jutils-1.jar
do-build:
- @(cd ${BUILD_WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ${ANT} ${ALL_TARGET})
+ cd ${WRKSRC}; \
+ ${SETENV} mvn -P windows,linux,osx,wintab ${MAVEN_REPO} ${MAVEN_ARGS} --offline package
do-install:
@${MKDIR} ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}.jar \
- ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}/
+ ${INSTALL_DATA} ${WRKSRC}/uberjar/target/${PORTNAME}-${PORTVERSION}-SNAPSHOT.jar \
+ ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}/${PORTNAME}.jar
.include <bsd.port.mk>
diff --git a/games/jinput/distinfo b/games/jinput/distinfo
index 67cd2f8e1b45..ecfbe9b3a129 100644
--- a/games/jinput/distinfo
+++ b/games/jinput/distinfo
@@ -1,2 +1,3 @@
-SHA256 (jinput-20110801.r247.tar.bz2) = 2275512294a1ed8ca739d60653ff12a4beb775dd43e929433488884e7d4691f7
-SIZE (jinput-20110801.r247.tar.bz2) = 1565811
+TIMESTAMP = 1575771995
+SHA256 (voidanix-jinput-bf22dd975bbba31f01895332255b63df376894e6_GL0.tar.gz) = 33b9c7c07c0a27c54df9fd89ba9431b9ce5f6b6a0f2498f6f855ee533ad09570
+SIZE (voidanix-jinput-bf22dd975bbba31f01895332255b63df376894e6_GL0.tar.gz) = 33104752
diff --git a/games/jinput/files/patch-openjdk7 b/games/jinput/files/patch-openjdk7
deleted file mode 100644
index a054a387c89d..000000000000
--- a/games/jinput/files/patch-openjdk7
+++ /dev/null
@@ -1,10 +0,0 @@
---- plugins/linux/build.xml.orig
-+++ plugins/linux/build.xml
-@@ -56,6 +56,7 @@
- <javah destdir="src/native">
- <classpath>
- <pathelement location="classes"/>
-+ <pathelement location="../../coreAPI/bin/jinput-core.jar"/>
- </classpath>
- <class name="net.java.games.input.LinuxEventDevice"/>
- <class name="net.java.games.input.LinuxJoystickDevice"/>
diff --git a/games/jinput/pkg-descr b/games/jinput/pkg-descr
index a7031c770074..61216694b56c 100644
--- a/games/jinput/pkg-descr
+++ b/games/jinput/pkg-descr
@@ -1,3 +1,3 @@
Java Game Controller API
-WWW: https://svn.java.net/svn/jinput~svn/trunk
+WWW: https://github.com/jinput/jinput