aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-24 17:19:18 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-24 17:19:18 +0000
commit1cc5f5584961bf8145db1a96bd57c05ce81fb44b (patch)
tree4774c6aaa1e350e33eb201019c32ded97406008e
parent78e1cfad10b5ba81294758e6a0507684a0c1b155 (diff)
downloadports-1cc5f5584961bf8145db1a96bd57c05ce81fb44b.tar.gz
ports-1cc5f5584961bf8145db1a96bd57c05ce81fb44b.zip
graphics/geeqie: don't try to get number of cpu cores from /proc
-rw-r--r--graphics/geeqie/Makefile2
-rw-r--r--graphics/geeqie/files/patch-src_misc.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/graphics/geeqie/Makefile b/graphics/geeqie/Makefile
index a0067dfe9dcd..9ccc20bf80a1 100644
--- a/graphics/geeqie/Makefile
+++ b/graphics/geeqie/Makefile
@@ -2,7 +2,7 @@
PORTNAME= geeqie
PORTVERSION= 1.6
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= graphics
MASTER_SITES= http://www.geeqie.org/
diff --git a/graphics/geeqie/files/patch-src_misc.c b/graphics/geeqie/files/patch-src_misc.c
new file mode 100644
index 000000000000..568a23247350
--- /dev/null
+++ b/graphics/geeqie/files/patch-src_misc.c
@@ -0,0 +1,10 @@
+--- src/misc.c.orig 2020-11-20 21:36:33 UTC
++++ src/misc.c
+@@ -378,6 +378,7 @@ gchar *get_symbolic_link(const gchar *path_utf8)
+
+ gint get_cpu_cores(void)
+ {
++ return 1;
+ FILE *cpuinfo = fopen("/proc/cpuinfo", "rb");
+ char *arg = 0;
+ size_t size = 0;