aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1998-08-19 06:15:08 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1998-08-19 06:15:08 +0000
commit1cda1ec091f98531cc5b0eee5da2a52a7494318a (patch)
tree44d9fe6828458011b7ddf95ea609389a0bacb756
parent9d9878ff7fc6081156046e578a3391b43509a25c (diff)
downloadports-1cda1ec091f98531cc5b0eee5da2a52a7494318a.tar.gz
ports-1cda1ec091f98531cc5b0eee5da2a52a7494318a.zip
ORBit is a high-performance CORBA ORB with support for the C language.
It is used by the GNOME Project. PR: ports/7654 Submitted by: Chia-liang Kao <clkao@cirx.org>
Notes
Notes: svn path=/head/; revision=12636
-rw-r--r--devel/ORBit/Makefile26
-rw-r--r--devel/ORBit/distinfo1
-rw-r--r--devel/ORBit/files/patch-ab11
-rw-r--r--devel/ORBit/files/patch-ac10
-rw-r--r--devel/ORBit/pkg-comment1
-rw-r--r--devel/ORBit/pkg-descr3
-rw-r--r--devel/ORBit/pkg-plist69
-rw-r--r--devel/ORBit2/Makefile26
-rw-r--r--devel/ORBit2/distinfo1
-rw-r--r--devel/ORBit2/files/patch-ab11
-rw-r--r--devel/ORBit2/files/patch-ac10
-rw-r--r--devel/ORBit2/pkg-comment1
-rw-r--r--devel/ORBit2/pkg-descr3
-rw-r--r--devel/ORBit2/pkg-plist69
14 files changed, 242 insertions, 0 deletions
diff --git a/devel/ORBit/Makefile b/devel/ORBit/Makefile
new file mode 100644
index 000000000000..fd59f2f29157
--- /dev/null
+++ b/devel/ORBit/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: orbit
+# Version required: 0.2.1
+# Date Created: 16 Aug 1998
+# Whom: Chia-liang Kao <clkao@CirX.ORG>
+#
+# $Id$
+#
+
+DISTNAME= ORBit-0.2.1
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.gnome.org/pub/ORBit/
+
+MAINTAINER= clkao@CirX.ORG
+
+LIB_DEPENDS= glib11\\.0\\.:${PORTSDIR}/devel/glib
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ENV= INSTALL='$${INSTALL} -c'
+CONFIGURE_ARGS= --disable-indent
+
+post-install:
+ ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/devel/ORBit/distinfo b/devel/ORBit/distinfo
new file mode 100644
index 000000000000..684cd75daaa7
--- /dev/null
+++ b/devel/ORBit/distinfo
@@ -0,0 +1 @@
+MD5 (ORBit-0.2.1.tar.gz) = 0cb385f17dc6cf80b450bf0fb2256aeb
diff --git a/devel/ORBit/files/patch-ab b/devel/ORBit/files/patch-ab
new file mode 100644
index 000000000000..a0c49f88c975
--- /dev/null
+++ b/devel/ORBit/files/patch-ab
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sat Aug 8 23:10:55 1998
++++ Makefile.in Sat Aug 8 23:11:08 1998
+@@ -86,7 +86,7 @@
+ VERSION = @VERSION@
+ YACC = @YACC@
+
+-SUBDIRS=libIDL src test
++SUBDIRS=libIDL src
+
+ bin_SCRIPTS=orbit-config
+
diff --git a/devel/ORBit/files/patch-ac b/devel/ORBit/files/patch-ac
new file mode 100644
index 000000000000..b74728f9eb91
--- /dev/null
+++ b/devel/ORBit/files/patch-ac
@@ -0,0 +1,10 @@
+--- src/ORBitutil/machine_endian.h.orig Tue Aug 18 20:29:55 1998
++++ src/ORBitutil/machine_endian.h Tue Aug 18 20:30:59 1998
+@@ -1,6 +1,7 @@
+ #ifndef machine_endian_h_
+ #define machine_endian_h_
+ #include <machine/endian.h>
++#include <sys/types.h>
+ #include <machine/types.h>
+ #if BYTE_ORDER == LITTLE_ENDIAN
+ # define MACHINE_IS_LITTLE_ENDIAN
diff --git a/devel/ORBit/pkg-comment b/devel/ORBit/pkg-comment
new file mode 100644
index 000000000000..2940a9f1f17f
--- /dev/null
+++ b/devel/ORBit/pkg-comment
@@ -0,0 +1 @@
+high-performance CORBA ORB with support for the C language
diff --git a/devel/ORBit/pkg-descr b/devel/ORBit/pkg-descr
new file mode 100644
index 000000000000..8336574a1661
--- /dev/null
+++ b/devel/ORBit/pkg-descr
@@ -0,0 +1,3 @@
+ORBit is a high-performance CORBA ORB with support for the C language.
+It allows programs to send requests and receive replies from other
+programs, regardless of the locations of the two programs.
diff --git a/devel/ORBit/pkg-plist b/devel/ORBit/pkg-plist
new file mode 100644
index 000000000000..5ba6341ca0d5
--- /dev/null
+++ b/devel/ORBit/pkg-plist
@@ -0,0 +1,69 @@
+bin/orbit-config
+bin/orbit-idl
+include/IIOP/IIOP-config.h
+include/IIOP/IIOP-types.h
+include/IIOP/IIOP.h
+include/IIOP/giop-msg-buffer.h
+include/IIOP/iiop-encoders.h
+include/IIOP/iiop-endian.h
+include/ORBitutil/basic_types.h
+include/ORBitutil/compat.h
+include/ORBitutil/machine_endian.h
+include/ORBitutil/thread-safety.h
+include/ORBitutil/trace.h
+include/ORBitutil/util.h
+include/libIDL/IDL.h
+include/orb/allocator-defs.h
+include/orb/allocators.h
+include/orb/boa.h
+include/orb/cdr.h
+include/orb/corba_any.h
+include/orb/corba_any_type.h
+include/orb/corba_basic_sequences_type.h
+include/orb/corba_env.h
+include/orb/corba_env_type.h
+include/orb/corba_ir.h
+include/orb/corba_object.h
+include/orb/corba_object_type.h
+include/orb/corba_orb.h
+include/orb/corba_orb_type.h
+include/orb/corba_portableserver.h
+include/orb/corba_portableserver_type.h
+include/orb/corba_sequences.h
+include/orb/corba_sequences_type.h
+include/orb/corba_typecode.h
+include/orb/corba_typecode_type.h
+include/orb/dii.h
+include/orb/dynany.h
+include/orb/env.h
+include/orb/iop.h
+include/orb/ir.h
+include/orb/options.h
+include/orb/orb.h
+include/orb/orbit.h
+include/orb/orbit_config.h
+include/orb/orbit_object.h
+include/orb/orbit_object_type.h
+include/orb/orbit_poa.h
+include/orb/orbit_poa_type.h
+include/orb/orbit_types.h
+include/orb/poa.h
+include/orb/sequences.h
+include/orb/typecode.h
+lib/libIDL.a
+lib/libIIOP.a
+lib/libIIOP.la
+lib/libIIOP.so
+lib/libIIOP.so.2.1
+lib/libORBit.a
+lib/libORBit.la
+lib/libORBit.so
+lib/libORBit.so.2.1
+lib/libORBitutil.a
+lib/libORBitutil.la
+lib/libORBitutil.so
+lib/libORBitutil.so.2.1
+@dirrm include/IIOP
+@dirrm include/ORBitutil
+@dirrm include/libIDL
+@dirrm include/orb
diff --git a/devel/ORBit2/Makefile b/devel/ORBit2/Makefile
new file mode 100644
index 000000000000..fd59f2f29157
--- /dev/null
+++ b/devel/ORBit2/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: orbit
+# Version required: 0.2.1
+# Date Created: 16 Aug 1998
+# Whom: Chia-liang Kao <clkao@CirX.ORG>
+#
+# $Id$
+#
+
+DISTNAME= ORBit-0.2.1
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.gnome.org/pub/ORBit/
+
+MAINTAINER= clkao@CirX.ORG
+
+LIB_DEPENDS= glib11\\.0\\.:${PORTSDIR}/devel/glib
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ENV= INSTALL='$${INSTALL} -c'
+CONFIGURE_ARGS= --disable-indent
+
+post-install:
+ ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/devel/ORBit2/distinfo b/devel/ORBit2/distinfo
new file mode 100644
index 000000000000..684cd75daaa7
--- /dev/null
+++ b/devel/ORBit2/distinfo
@@ -0,0 +1 @@
+MD5 (ORBit-0.2.1.tar.gz) = 0cb385f17dc6cf80b450bf0fb2256aeb
diff --git a/devel/ORBit2/files/patch-ab b/devel/ORBit2/files/patch-ab
new file mode 100644
index 000000000000..a0c49f88c975
--- /dev/null
+++ b/devel/ORBit2/files/patch-ab
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sat Aug 8 23:10:55 1998
++++ Makefile.in Sat Aug 8 23:11:08 1998
+@@ -86,7 +86,7 @@
+ VERSION = @VERSION@
+ YACC = @YACC@
+
+-SUBDIRS=libIDL src test
++SUBDIRS=libIDL src
+
+ bin_SCRIPTS=orbit-config
+
diff --git a/devel/ORBit2/files/patch-ac b/devel/ORBit2/files/patch-ac
new file mode 100644
index 000000000000..b74728f9eb91
--- /dev/null
+++ b/devel/ORBit2/files/patch-ac
@@ -0,0 +1,10 @@
+--- src/ORBitutil/machine_endian.h.orig Tue Aug 18 20:29:55 1998
++++ src/ORBitutil/machine_endian.h Tue Aug 18 20:30:59 1998
+@@ -1,6 +1,7 @@
+ #ifndef machine_endian_h_
+ #define machine_endian_h_
+ #include <machine/endian.h>
++#include <sys/types.h>
+ #include <machine/types.h>
+ #if BYTE_ORDER == LITTLE_ENDIAN
+ # define MACHINE_IS_LITTLE_ENDIAN
diff --git a/devel/ORBit2/pkg-comment b/devel/ORBit2/pkg-comment
new file mode 100644
index 000000000000..2940a9f1f17f
--- /dev/null
+++ b/devel/ORBit2/pkg-comment
@@ -0,0 +1 @@
+high-performance CORBA ORB with support for the C language
diff --git a/devel/ORBit2/pkg-descr b/devel/ORBit2/pkg-descr
new file mode 100644
index 000000000000..8336574a1661
--- /dev/null
+++ b/devel/ORBit2/pkg-descr
@@ -0,0 +1,3 @@
+ORBit is a high-performance CORBA ORB with support for the C language.
+It allows programs to send requests and receive replies from other
+programs, regardless of the locations of the two programs.
diff --git a/devel/ORBit2/pkg-plist b/devel/ORBit2/pkg-plist
new file mode 100644
index 000000000000..5ba6341ca0d5
--- /dev/null
+++ b/devel/ORBit2/pkg-plist
@@ -0,0 +1,69 @@
+bin/orbit-config
+bin/orbit-idl
+include/IIOP/IIOP-config.h
+include/IIOP/IIOP-types.h
+include/IIOP/IIOP.h
+include/IIOP/giop-msg-buffer.h
+include/IIOP/iiop-encoders.h
+include/IIOP/iiop-endian.h
+include/ORBitutil/basic_types.h
+include/ORBitutil/compat.h
+include/ORBitutil/machine_endian.h
+include/ORBitutil/thread-safety.h
+include/ORBitutil/trace.h
+include/ORBitutil/util.h
+include/libIDL/IDL.h
+include/orb/allocator-defs.h
+include/orb/allocators.h
+include/orb/boa.h
+include/orb/cdr.h
+include/orb/corba_any.h
+include/orb/corba_any_type.h
+include/orb/corba_basic_sequences_type.h
+include/orb/corba_env.h
+include/orb/corba_env_type.h
+include/orb/corba_ir.h
+include/orb/corba_object.h
+include/orb/corba_object_type.h
+include/orb/corba_orb.h
+include/orb/corba_orb_type.h
+include/orb/corba_portableserver.h
+include/orb/corba_portableserver_type.h
+include/orb/corba_sequences.h
+include/orb/corba_sequences_type.h
+include/orb/corba_typecode.h
+include/orb/corba_typecode_type.h
+include/orb/dii.h
+include/orb/dynany.h
+include/orb/env.h
+include/orb/iop.h
+include/orb/ir.h
+include/orb/options.h
+include/orb/orb.h
+include/orb/orbit.h
+include/orb/orbit_config.h
+include/orb/orbit_object.h
+include/orb/orbit_object_type.h
+include/orb/orbit_poa.h
+include/orb/orbit_poa_type.h
+include/orb/orbit_types.h
+include/orb/poa.h
+include/orb/sequences.h
+include/orb/typecode.h
+lib/libIDL.a
+lib/libIIOP.a
+lib/libIIOP.la
+lib/libIIOP.so
+lib/libIIOP.so.2.1
+lib/libORBit.a
+lib/libORBit.la
+lib/libORBit.so
+lib/libORBit.so.2.1
+lib/libORBitutil.a
+lib/libORBitutil.la
+lib/libORBitutil.so
+lib/libORBitutil.so.2.1
+@dirrm include/IIOP
+@dirrm include/ORBitutil
+@dirrm include/libIDL
+@dirrm include/orb