aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-10-08 11:54:31 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-10-08 11:54:31 +0000
commit1cecd1dcd2a649c056cd054231f31d1b45498588 (patch)
tree380d05b6e916b3cc77ae58b165f31b465193cddc
parent2264b99e33d259b01e579698479b38aa69815375 (diff)
downloadports-1cecd1dcd2a649c056cd054231f31d1b45498588.tar.gz
ports-1cecd1dcd2a649c056cd054231f31d1b45498588.zip
www/aria2: Update WWW
- Cosmetic change
-rw-r--r--www/aria2/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/www/aria2/Makefile b/www/aria2/Makefile
index cd7faf6f6bf3..47cf4e1ca461 100644
--- a/www/aria2/Makefile
+++ b/www/aria2/Makefile
@@ -7,7 +7,8 @@ MASTER_SITES= https://github.com/aria2/aria2/releases/download/release-${PORTVER
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Yet another download tool
-WWW= https://aria2.github.io/
+WWW= https://aria2.github.io/ \
+ https://github.com/aria2/aria2
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -15,10 +16,21 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= compiler:c++11-lib cpe libtool pathfix pkgconfig ssl tar:xz
CONFIGURE_ARGS= --disable-epoll \
- --enable-bittorrent --enable-libaria2 --enable-metalink --enable-shared --enable-ssl --enable-threads=posix --enable-websocket \
+ --enable-bittorrent \
+ --enable-libaria2 \
+ --enable-metalink \
+ --enable-shared \
+ --enable-ssl \
+ --enable-threads=posix \
+ --enable-websocket \
--with-disk-cache=${ARIA2_DISK_CACHE} \
- --with-libz --with-openssl \
- --without-appletls --without-gnutls --without-libgcrypt --without-libgmp --without-libnettle
+ --with-libz \
+ --with-openssl \
+ --without-appletls \
+ --without-gnutls \
+ --without-libgcrypt \
+ --without-libgmp \
+ --without-libnettle
CONFIGURE_ENV= OPENSSL_CFLAGS=-I${OPENSSLINC} \
OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl" \
ac_cv_path_RST2HTML=no