aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2013-08-01 22:04:01 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2013-08-01 22:04:01 +0000
commit1d0998fe999d648e0f53d04c66cc2a235e3c50da (patch)
tree17e9fe81c442463e41980a396240162709c2c892
parent9ab6ddbd028cd223956c9c126491301b17dd6d15 (diff)
downloadports-1d0998fe999d648e0f53d04c66cc2a235e3c50da.tar.gz
ports-1d0998fe999d648e0f53d04c66cc2a235e3c50da.zip
Convert all my perl-using ports to USES+=perl5
While here: - add USES+=shebangfix to ports-mgmt/p5-FreeBSD-Portindex - set $PERL in CONFIGURE_ENV to achieve equivalent to shebangfix for www/rt40 - upgrade to 0.17 and fix pkg-plist for www/p5-RT-Authen-ExternalAuth - trim Makefile header for www/p5-RTx-Calendar
Notes
Notes: svn path=/head/; revision=324134
-rw-r--r--databases/mytop/Makefile3
-rw-r--r--misc/p5-Business-Hours/Makefile3
-rw-r--r--ports-mgmt/p5-FreeBSD-Portindex/Makefile3
-rw-r--r--www/p5-RT-Authen-ExternalAuth/Makefile10
-rw-r--r--www/p5-RT-Authen-ExternalAuth/distinfo4
-rw-r--r--www/p5-RT-Extension-LDAPImport/Makefile3
-rw-r--r--www/p5-RT-Extension-SLA/Makefile3
-rw-r--r--www/p5-RTx-Calendar/Makefile9
-rw-r--r--www/rt40/Makefile4
9 files changed, 25 insertions, 17 deletions
diff --git a/databases/mytop/Makefile b/databases/mytop/Makefile
index 09cf372acca3..eb4a04ac9c8e 100644
--- a/databases/mytop/Makefile
+++ b/databases/mytop/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS= p5-DBD-mysql>1.0:${PORTSDIR}/databases/p5-DBD-mysql \
CONFLICTS= mariadb-scripts-[0-9]*
-PERL_CONFIGURE= yes
+USES+= perl5
+USE_PERL5= configure
MAN1= mytop.1
diff --git a/misc/p5-Business-Hours/Makefile b/misc/p5-Business-Hours/Makefile
index 9ec10a86f424..4921f631f31f 100644
--- a/misc/p5-Business-Hours/Makefile
+++ b/misc/p5-Business-Hours/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>-1.0:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_CONFIGURE= yes
+USES+= perl5
+USE_PERL5= configure
MAN3= Business::Hours.3
diff --git a/ports-mgmt/p5-FreeBSD-Portindex/Makefile b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
index 81e4f0aff511..750c341c1ea8 100644
--- a/ports-mgmt/p5-FreeBSD-Portindex/Makefile
+++ b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
@@ -27,8 +27,9 @@ GRAPHVIS_DESCR= Add GraphViz run-time dependency
RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
.endif
+USES+= perl5
USE_XZ= yes
-PERL_CONFIGURE= yes
+USE_PERL5= configure
CACHE_DIR?= /var/db/portindex
CACHE_OWNER?= root
diff --git a/www/p5-RT-Authen-ExternalAuth/Makefile b/www/p5-RT-Authen-ExternalAuth/Makefile
index e892006c7984..ac12a6c8a2c0 100644
--- a/www/p5-RT-Authen-ExternalAuth/Makefile
+++ b/www/p5-RT-Authen-ExternalAuth/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= RT-Authen-ExternalAuth
-DISTVERSION= 0.13
+DISTVERSION= 0.17
CATEGORIES= www net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-perl-ldap>0:${PORTSDIR}/net/p5-perl-ldap \
p5-Net-SSLeay>0:${PORTSDIR}/security/p5-Net-SSLeay
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES+= perl5
+USE_PERL5= configure
OPTIONS_DEFINE= RT38
RT38_DESC= Install for rt-3.8.x (default rt-4.0.x)
@@ -34,8 +35,11 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/rt:${PORTSDIR}/www/rt${RT_VER}
RUN_DEPENDS+= ${LOCALBASE}/bin/rt:${PORTSDIR}/www/rt${RT_VER}
MAN3PREFIX= ${PREFIX}
+MAN3= RT::Authen::ExternalAuth.3 \
+ RT::Authen::ExternalAuth::DBI.3 \
+ RT::Authen::ExternalAuth::DBI::Cookie.3 \
+ RT::Authen::ExternalAuth::LDAP.3
-MAN3= RT::Authen::ExternalAuth.3
PLIST_SUB+= RTHOME=share/rt${RT_VER}
# Note: You can install using an arbitrary $PREFIX but only if it
diff --git a/www/p5-RT-Authen-ExternalAuth/distinfo b/www/p5-RT-Authen-ExternalAuth/distinfo
index 5ea13082a32e..6f527fab3096 100644
--- a/www/p5-RT-Authen-ExternalAuth/distinfo
+++ b/www/p5-RT-Authen-ExternalAuth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (RT-Authen-ExternalAuth-0.13.tar.gz) = 21be722f1ac87238375325092e661f8e714b219c9d286cea3d1cfe415ef768d0
-SIZE (RT-Authen-ExternalAuth-0.13.tar.gz) = 64892
+SHA256 (RT-Authen-ExternalAuth-0.17.tar.gz) = cd12c0c223c4cd4588feb5de76eb234ab62c6cbc865f3f82249f0023c21f5aca
+SIZE (RT-Authen-ExternalAuth-0.17.tar.gz) = 68960
diff --git a/www/p5-RT-Extension-LDAPImport/Makefile b/www/p5-RT-Extension-LDAPImport/Makefile
index 4968636f3bb2..951a17372566 100644
--- a/www/p5-RT-Extension-LDAPImport/Makefile
+++ b/www/p5-RT-Extension-LDAPImport/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-perl-ldap>0:${PORTSDIR}/net/p5-perl-ldap \
p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES+= perl5
+USE_PERL5= configure
OPTIONS_DEFINE= RT38
RT38_DESC= Install for rt-3.8.x (default rt-4.0.x)
diff --git a/www/p5-RT-Extension-SLA/Makefile b/www/p5-RT-Extension-SLA/Makefile
index 007ddc954778..77a149b3f341 100644
--- a/www/p5-RT-Extension-SLA/Makefile
+++ b/www/p5-RT-Extension-SLA/Makefile
@@ -17,7 +17,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
LICENSE= GPLv2
-PERL_CONFIGURE= yes
+USES+= perl5
+USE_PERL5= configure
OPTIONS_DEFINE= RT38
RT38_DESC= Install for rt-3.8.x (default rt-4.0.x)
diff --git a/www/p5-RTx-Calendar/Makefile b/www/p5-RTx-Calendar/Makefile
index 30f514c0d237..da5cfbb1fc76 100644
--- a/www/p5-RTx-Calendar/Makefile
+++ b/www/p5-RTx-Calendar/Makefile
@@ -1,9 +1,5 @@
-# New ports collection Makefile for: RTx-Calendar
-# Date created: 16 August 2008
-# Whom: Matthew Seaman <m.seaman@infracaninophile.co.uk>
-#
+# Created by: Matthew Seaman <m.seaman@infracaninophile.co.uk>
# $FreeBSD$
-#
PORTNAME= RTx-Calendar
PORTVERSION= 0.15
@@ -22,7 +18,8 @@ BUILD_DEPENDS= p5-Date-ICal>0:${PORTSDIR}/devel/p5-Date-ICal \
p5-DateTime-Set>0:${PORTSDIR}/devel/p5-DateTime-Set
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES+= perl5
+USE_PERL5= configure
OPTIONS_DEFINE= RT38
RT38_DESC= Install for rt-3.8.x (default rt-4.0.x)
diff --git a/www/rt40/Makefile b/www/rt40/Makefile
index 5371db325698..ed6cab4f65ab 100644
--- a/www/rt40/Makefile
+++ b/www/rt40/Makefile
@@ -66,7 +66,7 @@ BUILD_DEPENDS+= ${CORE_DEPS} \
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PERL5= yes
+USES+= perl5
USE_AUTOTOOLS= autoconf
.include <bsd.port.options.mk>
@@ -191,6 +191,8 @@ CONFIGURE_ARGS+= --enable-layout=${RT_LAYOUT} \
--with-db-database=${DB_DATABASE} \
--with-db-dba=${DB_DBA_USER}
+CONFIGURE_ENV+= PERL=${LOCALBASE}/bin/perl
+
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
SUB_LIST= RT_ETC_PATH=${RT_ETC_PATH}