aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-06-29 16:08:51 +0000
committerStefan Eßer <se@FreeBSD.org>2022-06-29 16:08:51 +0000
commit1d3149ef6ef4928d4138ad4511c3e7c48aadd57a (patch)
tree7becf80ebb38084440fc4b800621d6797727ffc7
parentda00957fbe1f79c12851e0958ee7e4c8276a5527 (diff)
downloadports-1d3149ef6ef4928d4138ad4511c3e7c48aadd57a.tar.gz
ports-1d3149ef6ef4928d4138ad4511c3e7c48aadd57a.zip
Fix CONFLICTS_INSTALL in the deskutils category
Approved by: portmgr (implicit)
-rw-r--r--deskutils/deforaos-todo/Makefile2
-rw-r--r--deskutils/dfshow/Makefile2
-rw-r--r--deskutils/howm/Makefile2
-rw-r--r--deskutils/notification-daemon/Makefile2
-rw-r--r--deskutils/notify-osd/Makefile2
-rw-r--r--deskutils/presage/Makefile2
6 files changed, 10 insertions, 2 deletions
diff --git a/deskutils/deforaos-todo/Makefile b/deskutils/deforaos-todo/Makefile
index fed638510b31..aacde88b24d4 100644
--- a/deskutils/deforaos-todo/Makefile
+++ b/deskutils/deforaos-todo/Makefile
@@ -23,7 +23,7 @@ MAKE_ARGS+= PREFIX=${PREFIX}
MAKE_ENV= MANDIR=${STAGEDIR}${MANPREFIX}/man
-CONFLICTS_INSTALL= devtodo todo
+CONFLICTS_INSTALL= devtodo # man/man1/todo.1.gz
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
diff --git a/deskutils/dfshow/Makefile b/deskutils/dfshow/Makefile
index 5fb13e196b12..72aef70bf4dc 100644
--- a/deskutils/dfshow/Makefile
+++ b/deskutils/dfshow/Makefile
@@ -18,6 +18,8 @@ GH_ACCOUNT= roberthawdon
GNU_CONFIGURE= yes
+CONFLICTS_INSTALL= ja-mh mmh nmh nmh-devel # man/man1/show.1.gz
+
post-patch:
@${REINPLACE_CMD} 's/-lncursesw/${NCURSESLIBS}/g' ${WRKSRC}/Makefile.am
diff --git a/deskutils/howm/Makefile b/deskutils/howm/Makefile
index 6c90f331d16f..586f16b60036 100644
--- a/deskutils/howm/Makefile
+++ b/deskutils/howm/Makefile
@@ -19,6 +19,8 @@ USES= emacs
GNU_CONFIGURE= yes
+CONFLICTS_INSTALL= howm howm-emacs_* # share/doc/howm/README-j.html
+
PORTDOCS= *.html *.png
PORTEXAMPLES= en/0000-00-00-000000.txt ja/0000-00-00-000000.txt
diff --git a/deskutils/notification-daemon/Makefile b/deskutils/notification-daemon/Makefile
index c3cbe2736336..2b0428a4e231 100644
--- a/deskutils/notification-daemon/Makefile
+++ b/deskutils/notification-daemon/Makefile
@@ -20,6 +20,8 @@ USE_GNOME= cairo gnomeprefix gtk30
USE_XORG= x11
GNU_CONFIGURE= yes
+CONFLICTS_INSTALL= notify-osd # share/dbus-1/services/org.freedesktop.Notifications.service
+
PORTSCOUT= limitw:1,even
SUB_FILES= org.freedesktop.Notifications.service
diff --git a/deskutils/notify-osd/Makefile b/deskutils/notify-osd/Makefile
index 618396f83fbb..c26069658a92 100644
--- a/deskutils/notify-osd/Makefile
+++ b/deskutils/notify-osd/Makefile
@@ -28,7 +28,7 @@ USE_XORG= pixman x11
GNU_CONFIGURE= yes
GLIB_SCHEMAS= com.canonical.NotifyOSD.gschema.xml
-CONFLICTS= xfce4-notification-daemon
+CONFLICTS_INSTALL= notification-daemon # share/dbus-1/services/org.freedesktop.Notifications.service
post-patch:
@${REINPLACE_CMD} '/SUBDIRS =/s/tests//' ${WRKSRC}/Makefile.in
diff --git a/deskutils/presage/Makefile b/deskutils/presage/Makefile
index 5174de910d62..c8bb9e363af3 100644
--- a/deskutils/presage/Makefile
+++ b/deskutils/presage/Makefile
@@ -34,4 +34,6 @@ CONFIGURE_ARGS= --disable-documentation \
--disable-static
INSTALL_TARGET= install-strip
+CONFLICTS_INSTALL= soothsayer # man/man1/text2ngram.1.gz
+
.include <bsd.port.mk>