aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2022-11-07 06:49:32 +0000
committerGleb Popov <arrowd@FreeBSD.org>2022-11-07 07:46:00 +0000
commit1d804e3dd48a18ce94317fe9374b06f8f27d267e (patch)
treead2ac0d05a86e71c6da3ef8074f764b16f2a889c
parent1801e6d529b6251bec1eea687b1b25740414db93 (diff)
downloadports-1d804e3dd48a18ce94317fe9374b06f8f27d267e.tar.gz
ports-1d804e3dd48a18ce94317fe9374b06f8f27d267e.zip
devel/efl: Fix formatting and some build options.
-rw-r--r--devel/efl/Makefile201
1 files changed, 94 insertions, 107 deletions
diff --git a/devel/efl/Makefile b/devel/efl/Makefile
index f33afca5f671..edb01a0d3c71 100644
--- a/devel/efl/Makefile
+++ b/devel/efl/Makefile
@@ -19,14 +19,15 @@ LIB_DEPENDS= libgif.so:graphics/giflib \
libfontconfig.so:x11-fonts/fontconfig \
libdbus-1.so:devel/dbus \
libcurl.so:ftp/curl \
- libsndfile.so:audio/libsndfile
+ libsndfile.so:audio/libsndfile \
+ libunwind.so:devel/libunwind
# lib/libeio.so.1
CONFLICTS_INSTALL= libeio
USES= compiler:c++14-lang gettext-tools gnome iconv \
- jpeg libtool meson ninja ssl pathfix pkgconfig python:3.5+ shared-mime-info \
- shebangfix tar:xz xorg
+ jpeg libtool localbase:ldflags meson ninja ssl pathfix pkgconfig \
+ python:3.5+ shared-mime-info shebangfix tar:xz xorg
SHEBANG_FILES= src/tests/elementary/spec/generator.py \
src/bin/exactness/exactness_play.in \
src/bin/exactness/exactness_record.in
@@ -36,9 +37,6 @@ USE_LDCONFIG= yes
MESON_ARGS= -Dsystemd=false -Deeze=false -Dinput=false
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
PLIST_SUB= BRANCHVERSION=${PORTVERSION:R} PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= AVAHI FRIBIDI HARFBUZZ NLS PHYSICS PULSEAUDIO SDL VNC EFLONE ELUA EXAMPLES DOXYGEN WAYLAND
@@ -84,128 +82,131 @@ FRIBIDI_MESON_TRUE= fribidi
HARFBUZZ_LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
HARFBUZZ_MESON_TRUE= harfbuzz
-NLS_USES= gettext-runtime
-NLS_MESON_TRUE= nls
+NLS_USES= gettext-runtime
+NLS_MESON_TRUE= nls
-PHYSICS_LIB_DEPENDS= libBulletDynamics.so:devel/bullet
-PHYSICS_MESON_TRUE= physics
+PHYSICS_LIB_DEPENDS= libBulletDynamics.so:devel/bullet
+PHYSICS_MESON_TRUE= physics
-PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
-PULSEAUDIO_MESON_TRUE= pulseaudio
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+PULSEAUDIO_MESON_TRUE= pulseaudio
-EFLONE_BROKEN_i386= EFLONE option is broken on i386 by the upstream bug: https://phab.enlightenment.org/T8870
-EFLONE_MESON_TRUE= efl-one
+EFLONE_BROKEN_i386= EFLONE option is broken on i386 by the upstream bug: https://phab.enlightenment.org/T8870
+EFLONE_MESON_TRUE= efl-one
-ELUA_MESON_TRUE= elua
+ELUA_MESON_TRUE= elua
-EXAMPLES_MESON_TRUE= build-examples
+EXAMPLES_MESON_TRUE= build-examples
-DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
-VNC_MESON_TRUE= vnc-server
-VNC_LIB_DEPENDS= libvncserver.so:net/libvncserver
+VNC_MESON_TRUE= vnc-server
+VNC_LIB_DEPENDS= libvncserver.so:net/libvncserver
-LUA_IMPLIES= ELUA
-LUA_VARS= lua_binding=lua
-CXX_VARS= cxx_binding=cxx
+LUA_IMPLIES= ELUA
+LUA_VARS= lua_binding=lua
+CXX_VARS= cxx_binding=cxx
-WAYLAND_BUILD_DEPENDS= wayland-protocols>=1.7:graphics/wayland-protocols
-WAYLAND_LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
- libxkbcommon.so:x11/libxkbcommon \
- libwayland-client.so:graphics/wayland \
- libwayland-cursor.so:graphics/wayland
-WAYLAND_CFLAGS= -I${LOCALBASE}/include/libepoll-shim
-WAYLAND_LDFLAGS= -lepoll-shim
-WAYLAND_MESON_TRUE= wl
-WAYLAND_BROKEN= Wayland bits compile but don't yet work at runtime
+WAYLAND_BUILD_DEPENDS= wayland-protocols>=1.7:graphics/wayland-protocols
+WAYLAND_LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
+ libxkbcommon.so:x11/libxkbcommon \
+ libwayland-client.so:graphics/wayland \
+ libwayland-cursor.so:graphics/wayland
+WAYLAND_CFLAGS= -I${LOCALBASE}/include/libepoll-shim
+WAYLAND_LDFLAGS= -lepoll-shim
+WAYLAND_MESON_TRUE= wl
+WAYLAND_BROKEN= Wayland bits compile but don't yet work at runtime
-GSTREAMER_USES= gstreamer
-GSTREAMER_USE= GSTREAMER=core
-GSTREAMER_MESON_TRUE= gstreamer
+GSTREAMER_USES= gstreamer
+GSTREAMER_USE= GSTREAMER=core
+GSTREAMER_MESON_TRUE= gstreamer
-V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
-V4L_MESON_TRUE= v4l2
+V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
+V4L_MESON_TRUE= v4l2
-IBUS_LIB_DEPENDS= libibus-1.0.so:textproc/ibus
-IBUS_USES= gnome
-IBUS_USE= GNOME=glib20
-IBUS_MESON_TRUE= glib
-IBUS_VARS_OFF= ibus_disabler=ibus
+IBUS_LIB_DEPENDS= libibus-1.0.so:textproc/ibus
+IBUS_USES= gnome
+IBUS_USE= GNOME=glib20
+IBUS_MESON_TRUE= glib
+IBUS_VARS_OFF= ibus_disabler=ibus
-SCIM_LIB_DEPENDS= libscim-1.0.so:textproc/scim
-SCIM_VARS_OFF= scim_disabler=scim
+SCIM_LIB_DEPENDS= libscim-1.0.so:textproc/scim
+SCIM_VARS_OFF= scim_disabler=scim
-XIM_VARS_OFF= xim_disabler=xim
+XIM_VARS_OFF= xim_disabler=xim
-OPENJPEG_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg
-OPENJPEG_VARS_OFF= openjpeg_disabler=jp2k
+OPENJPEG_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg
+OPENJPEG_VARS_OFF= openjpeg_disabler=jp2k
-GNUTLS_LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
- libgnutls.so:security/gnutls
-GNUTLS_MESON_ON= -Dcrypto=gnutls
-GNUTLS_MESON_OFF= -Dcrypto=openssl
-GNUTLS_CFLAGS= -I${LOCALBASE}/include/gnutls/
-GNUTLS_BROKEN= GNUTLS option is broken by the upstream bug: https://phab.enlightenment.org/T8807
+GNUTLS_LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
+ libgnutls.so:security/gnutls
+GNUTLS_MESON_ON= -Dcrypto=gnutls
+GNUTLS_MESON_OFF= -Dcrypto=openssl
+GNUTLS_CFLAGS= -I${LOCALBASE}/include/gnutls/
+GNUTLS_BROKEN= GNUTLS option is broken by the upstream bug: https://phab.enlightenment.org/T8807
-PDF_LIB_DEPENDS= libpoppler.so:graphics/poppler
-PDF_VARS_OFF= pdf_disabler=pdf
+PDF_LIB_DEPENDS= libpoppler.so:graphics/poppler
+PDF_VARS_OFF= pdf_disabler=pdf
-PS_LIB_DEPENDS= libspectre.so:print/libspectre
-PS_VARS_OFF= ps_disabler=ps
+PS_LIB_DEPENDS= libspectre.so:print/libspectre
+PS_VARS_OFF= ps_disabler=ps
-RAW_LIB_DEPENDS= libraw.so:graphics/libraw
-RAW_VARS_OFF= raw_disabler=raw
+RAW_LIB_DEPENDS= libraw.so:graphics/libraw
+RAW_VARS_OFF= raw_disabler=raw
-SVG_USES= gnome
-SVG_USE= GNOME=cairo GNOME=librsvg2
-SVG_VARS_OFF= svg_disabler=rsvg
+SVG_USES= gnome
+SVG_USE= GNOME=cairo GNOME=librsvg2
+SVG_VARS_OFF= svg_disabler=rsvg
-AVIF_LIB_DEPENDS= libavif.so:graphics/libavif
-AVIF_VARS_OFF= avif_disabler=avif
+AVIF_LIB_DEPENDS= libavif.so:graphics/libavif
+AVIF_VARS_OFF= avif_disabler=avif
-HEIF_LIB_DEPENDS= libheif.so:graphics/libheif
-HEIF_VARS_OFF= heif_disabler=heif
+HEIF_LIB_DEPENDS= libheif.so:graphics/libheif
+HEIF_VARS_OFF= heif_disabler=heif
-WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
-WEBP_VARS_OFF= webp_disabler=webp
+WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
+WEBP_VARS_OFF= webp_disabler=webp
-XCF_VARS_OFF= xcf_disabler=xcf
+XCF_VARS_OFF= xcf_disabler=xcf
-LUAJIT_USES= luajit
-LUAJIT_MESON_ON= -Dlua-interpreter=luajit
-LUAJIT_PREVENTS= LUALANG
+LUAJIT_USES= luajit
+LUAJIT_MESON_ON= -Dlua-interpreter=luajit
+LUAJIT_PREVENTS= LUALANG
-LUALANG_USES= lua:51,build,run
-LUALANG_MESON_ON= -Dlua-interpreter=lua
-LUALANG_PREVENTS= LUAJIT
+LUALANG_USES= lua:51,build,run
+LUALANG_MESON_ON= -Dlua-interpreter=lua
+LUALANG_PREVENTS= LUAJIT
-OPENGL_USES= gl
-OPENGL_USE= GL=gl
-OPENGL_MESON_ON= -Dopengl=full
-OPENGL_PREVENTS= OPENGLES NONE
+OPENGL_USES= gl
+OPENGL_USE= GL=gl
+OPENGL_MESON_ON= -Dopengl=full
-OPENGLES_USES= gl
-OPENGLES_USE= GL=glesv2
-OPENGLES_MESON_ON= -Dopengl=es-egl
-OPENGLES_PREVENTS= OPENGL NONE
+OPENGLES_USES= gl
+OPENGLES_USE= GL=glesv2
+OPENGLES_MESON_ON= -Dopengl=es-egl
-NONE_MESON_ON= -Dopengl=none
-NONE_PREVENTS= OPENGL OPENGLES
+NONE_MESON_ON= -Dopengl=none
-SDL_USES= sdl
-SDL_USE= SDL=sdl2
-SDL_MESON_TRUE= sdl
+SDL_USES= sdl
+SDL_USE= SDL=sdl2
+SDL_MESON_TRUE= sdl
-.include <bsd.port.options.mk>
+IMF_DISABLERS= ${IBUS_DISABLER} ${SCIM_DISABLER} ${XIM_DISABLER}
+
+MESON_ARGS+= -Decore-imf-loaders-disabler="${IMF_DISABLERS:ts,}"
-IMF_DISABLERS= ${IBUS_DISABLER} ${SCIM_DISABLER} ${XIM_DISABLER}
+EVAS_DISABLERS= json ${OPENJPEG_DISABLER} ${PDF_DISABLER} \
+ ${PS_DISABLER} ${RAW_DISABLER} ${SVG_DISABLER} \
+ ${AVIF_DISABLER} ${HEIF_DISABLER} ${WEBP_DISABLER} \
+ ${XCF_DISABLER}
-MESON_ARGS+= -Decore-imf-loaders-disabler="${IMF_DISABLERS:ts,}"
+MESON_ARGS+= -Devas-loaders-disabler="${EVAS_DISABLERS:ts,}"
-JSON_DISABLER=json
-EVAS_DISABLERS= ${JSON_DISABLER} ${OPENJPEG_DISABLER} ${PDF_DISABLER} ${PS_DISABLER} ${RAW_DISABLER} ${SVG_DISABLER} ${AVIF_DISABLER} ${HEIF_DISABLER} ${WEBP_DISABLER} ${XCF_DISABLER}
+EFL_BINDINGS= ${LUA_BINDING} ${CXX_BINDING}
-MESON_ARGS+= -Devas-loaders-disabler="${EVAS_DISABLERS:ts,}"
+MESON_ARGS+= -Dbindings="${EFL_BINDINGS:ts,}"
+
+.include <bsd.port.options.mk>
# Work-around build failure, which is caused by subtle problem in lld and -as-needed flag
.if ${ARCH} == i386
@@ -217,20 +218,6 @@ BUILD_DEPENDS+= as:devel/binutils
CFLAGS+= -no-integrated-as
.endif
-EFL_BINDINGS= ${LUA_BINDING} ${CXX_BINDING}
-
-MESON_ARGS+= -Dbindings="${EFL_BINDINGS:ts,}"
-
-.if ${PORT_OPTIONS:MOPENGLES} && ${PORT_OPTIONS:MWAYLAND}
-LIB_DEPENDS+= libwayland-egl.so:graphics/wayland
-MESON_ARGS+= -Degl=true
-USE_GL= egl
-.endif
-
-.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == armv7 || ${ARCH} == i386 || ${ARCH} == powerpc64 || ${ARCH} == powerpc64le
-LIB_DEPENDS+= libunwind.so:devel/libunwind
-.endif
-
post-install:
#@${RM} -r ${STAGEDIR}${PREFIX}/share/gdb
@for i in `${FIND} ${STAGEDIR}${PREFIX}/bin ${STAGEDIR}${PREFIX}/lib -type f`; do \