aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-04-11 01:18:25 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-04-11 23:02:44 +0000
commit1d834b477266c24eeee5c6debeaf93829336b0bf (patch)
treeb576618de8fd05aca391b2f401f2f91817b74c20
parentb2f6d7df7e53395ff56d4c0eeb087a51d9035f19 (diff)
downloadports-1d834b477266c24eeee5c6debeaf93829336b0bf.tar.gz
ports-1d834b477266c24eeee5c6debeaf93829336b0bf.zip
net/gq: fix build with -fno-common
Remove two unused variables defined in headers. This fixes the build on FreeBSD 13+. While we are at it, add missing LIB_DEPENDS and USE_GNOME entries as indicated by stage-qa.
-rw-r--r--net/gq/Makefile16
-rw-r--r--net/gq/files/patch-src_dt__entry.h11
-rw-r--r--net/gq/files/patch-src_gq-browser-node-reference.h11
3 files changed, 31 insertions, 7 deletions
diff --git a/net/gq/Makefile b/net/gq/Makefile
index 547e4780c24b..de2fb2905d37 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gq
PORTVERSION= 1.3.4
-PORTREVISION= 18
+PORTREVISION= 19
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}client/GQ%20Unstable/${PORTVERSION}
@@ -13,14 +13,16 @@ LICENSE= GPLv2+ LGPL21+ # some source files are under lgpl
LICENSE_COMB= multi
LICENSE_FILE_GPLv2+ = ${WRKSRC}/COPYING
-BROKEN_FreeBSD_13= ld: error: duplicate symbol: dt_entry_handler
-BROKEN_FreeBSD_14= ld: error: duplicate symbol: dt_entry_handler
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libgcrypt.so:security/libgcrypt \
+ libgnome-keyring.so:security/libgnome-keyring \
+ libgpg-error.so:security/libgpg-error \
+ libharfbuzz.so:print/harfbuzz
-LIB_DEPENDS= libgnome-keyring.so:security/libgnome-keyring
-
-USES= desktop-file-utils gettext gmake gnome ldap pkgconfig \
+USES= desktop-file-utils gettext gmake gnome iconv ldap pkgconfig \
shared-mime-info ssl
-USE_GNOME= intltool libglade2
+USE_GNOME= cairo intltool gdkpixbuf2 libglade2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ldap-prefix=${LOCALBASE} --disable-update-mimedb
diff --git a/net/gq/files/patch-src_dt__entry.h b/net/gq/files/patch-src_dt__entry.h
new file mode 100644
index 000000000000..07c6bfa7a5e3
--- /dev/null
+++ b/net/gq/files/patch-src_dt__entry.h
@@ -0,0 +1,11 @@
+--- src/dt_entry.h.orig 2023-04-11 01:15:28 UTC
++++ src/dt_entry.h
+@@ -44,7 +44,7 @@ struct _dt_entry_handler {
+
+ GByteArray* (*encode)(const char *val, int len);
+ GByteArray* (*decode)(const char *val, int len);
+-} dt_entry_handler;
++};
+
+ /* Methods, only to be used by subclasses */
+ GtkWidget *dt_entry_get_widget(int error_context,
diff --git a/net/gq/files/patch-src_gq-browser-node-reference.h b/net/gq/files/patch-src_gq-browser-node-reference.h
new file mode 100644
index 000000000000..6e8de26f4be8
--- /dev/null
+++ b/net/gq/files/patch-src_gq-browser-node-reference.h
@@ -0,0 +1,11 @@
+--- src/gq-browser-node-reference.h.orig 2023-04-11 01:15:02 UTC
++++ src/gq-browser-node-reference.h
+@@ -51,7 +51,7 @@ struct _GqBrowserNodeReference {
+ char *uri;
+ GqServer *server;
+ gboolean expanded;
+-} ref_browse_entry;
++};
+
+ G_END_DECLS
+