aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2024-01-19 14:10:35 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2024-01-19 14:10:35 +0000
commit1dc0204a6f14541b977f9c8a30458c466c6db7ac (patch)
treef2b1df99aa514cf1c39f7349683d776c13ece8cf
parent1890e08180ff2b4d942cd5056a349b06ac812521 (diff)
downloadports-1dc0204a6f14541b977f9c8a30458c466c6db7ac.tar.gz
ports-1dc0204a6f14541b977f9c8a30458c466c6db7ac.zip
graphics/p5-Image-Imlib2: Fix build with graphics/imlib2 1.12.1
Add minimal support to `pkg-config imlib2`; imlib2-config has been dropped since imlib2-1.7.5. PR: 276439 Approved by: portmgr (buildfix blanket)
-rw-r--r--graphics/p5-Image-Imlib2/Makefile2
-rw-r--r--graphics/p5-Image-Imlib2/files/patch-Build.PL34
2 files changed, 35 insertions, 1 deletions
diff --git a/graphics/p5-Image-Imlib2/Makefile b/graphics/p5-Image-Imlib2/Makefile
index 71c58a340ed8..e07fd1ef8e4c 100644
--- a/graphics/p5-Image-Imlib2/Makefile
+++ b/graphics/p5-Image-Imlib2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= Image-Imlib2
PORTVERSION= 2.03
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/graphics/p5-Image-Imlib2/files/patch-Build.PL b/graphics/p5-Image-Imlib2/files/patch-Build.PL
new file mode 100644
index 000000000000..da69af69896f
--- /dev/null
+++ b/graphics/p5-Image-Imlib2/files/patch-Build.PL
@@ -0,0 +1,34 @@
+Add minimal support to `pkg-config imlib2`; imlib2-config has been
+dropped since imlib2-1.7.5.
+
+--- Build.PL.orig 2009-11-24 21:41:36 UTC
++++ Build.PL
+@@ -1,26 +1,8 @@ use strict;
+ use Module::Build;
+ use strict;
+
+-# We need to find imlib2-config
+-my $CONFIG = "imlib2-config";
+-
+-my $version = `$CONFIG --version`;
+-if (!$version) {
+- warn 'You must install the imlib2 library before you can install
+-Image::Imlib2. You can obtain imlib2 from
+-http://sourceforge.net/projects/enlightenment/
+-
+-Alternatively, if you have downloaded and installed imlib2 and this
+-still will not work, modify the $CONFIG variable inside Build.PL to
+-point to the imlib2-config program that provides.
+-';
+- exit 0;
+-} else {
+- print "Found imlib2 $version";
+-}
+-
+-my $libs = `$CONFIG --libs`;
+-my $cflags = "-DX_DISPLAY_MISSING " . `$CONFIG --cflags`;
++my $libs = `pkg-config --libs imlib2`;
++my $cflags = "-DX_DISPLAY_MISSING " . `pkg-config --cflags imlib2`;
+
+ my $build = Module::Build->new(
+ c_source => './lib/Image',