aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-04-07 07:43:37 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-04-07 07:43:37 +0000
commit1e817d5e1a74d55cfa93c599fa22f8e3108ecfa2 (patch)
treed33310fe438d775921ae7c22f6f3ed3f9961291e
parent6e8cbd63d37c0699bb8397e8345a2d151bb16ac1 (diff)
downloadports-1e817d5e1a74d55cfa93c599fa22f8e3108ecfa2.tar.gz
ports-1e817d5e1a74d55cfa93c599fa22f8e3108ecfa2.zip
Deprecate ports broken for more than 6 months
Notes
Notes: svn path=/head/; revision=498264
-rw-r--r--cad/brlcad/Makefile2
-rw-r--r--cad/elmerfem/Makefile2
-rw-r--r--databases/ruby-odbc/Makefile2
-rw-r--r--databases/rubygem-dbd-odbc/Makefile4
-rw-r--r--devel/dlangui/Makefile2
-rw-r--r--editors/dlangide/Makefile2
-rw-r--r--emulators/desmume/Makefile2
-rw-r--r--emulators/yabause/Makefile2
-rw-r--r--emulators/yape/Makefile2
-rw-r--r--games/armagetron/Makefile2
-rw-r--r--games/boswars/Makefile2
-rw-r--r--games/ceferino/Makefile2
-rw-r--r--games/chanta/Makefile2
-rw-r--r--games/d2x-xl/Makefile2
-rw-r--r--games/drcreep/Makefile2
-rw-r--r--games/frobtads/Makefile2
-rw-r--r--games/jaggedalliance2/Makefile2
-rw-r--r--games/paintown/Makefile2
-rw-r--r--games/pykawari/Makefile2
-rw-r--r--games/stepmania-devel/Makefile2
-rw-r--r--games/tinymux/Makefile2
-rw-r--r--games/voxelands/Makefile2
-rw-r--r--games/warsow/Makefile2
-rw-r--r--graphics/appleseed/Makefile2
-rw-r--r--graphics/apvlv/Makefile2
-rw-r--r--graphics/qslim/Makefile2
-rw-r--r--graphics/rawstudio/Makefile2
-rw-r--r--graphics/tulip/Makefile2
-rw-r--r--lang/dmd2/Makefile2
-rw-r--r--lang/qore/Makefile2
-rw-r--r--lang/swift/Makefile2
-rw-r--r--mail/milter-manager/Makefile2
-rw-r--r--math/goblin/Makefile2
-rw-r--r--math/mosesdecoder/Makefile2
-rw-r--r--multimedia/asdcplib/Makefile2
-rw-r--r--net/crtmpserver/Makefile2
-rw-r--r--net/openafs/Makefile2
-rw-r--r--security/kr/Makefile2
-rw-r--r--security/quantis/Makefile2
-rw-r--r--sysutils/bbcp/Makefile2
-rw-r--r--sysutils/boxbackup/Makefile2
-rw-r--r--sysutils/grub2-efi/Makefile4
-rw-r--r--sysutils/grub2-pcbsd/Makefile2
-rw-r--r--sysutils/mdcp/Makefile2
-rw-r--r--sysutils/openhpi/Makefile2
-rw-r--r--sysutils/sbsigntool/Makefile2
-rw-r--r--textproc/scim-bridge/Makefile2
-rw-r--r--textproc/sphinxsearch-devel/Makefile2
48 files changed, 100 insertions, 0 deletions
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index bee662a69c98..32f119505f70 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN= fails to build
BROKEN_sparc64= does not compile: invokes i386 assembler
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs \
${LOCALBASE}/include/tnt/jama_lu.h:math/jama \
diff --git a/cad/elmerfem/Makefile b/cad/elmerfem/Makefile
index 240e41b1b6a3..bb1861bf5bde 100644
--- a/cad/elmerfem/Makefile
+++ b/cad/elmerfem/Makefile
@@ -12,6 +12,8 @@ COMMENT= ELMER FEM package
LICENSE= GPLv2
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libparpack.so:math/arpack-ng \
libmpich.so:net/mpich
diff --git a/databases/ruby-odbc/Makefile b/databases/ruby-odbc/Makefile
index 05597f67108f..7dc518652a3e 100644
--- a/databases/ruby-odbc/Makefile
+++ b/databases/ruby-odbc/Makefile
@@ -15,6 +15,8 @@ COMMENT= Ruby extension library to use ODBC data sources
BROKEN_RUBY24= yes
BROKEN_RUBY25= yes
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/databases/rubygem-dbd-odbc/Makefile b/databases/rubygem-dbd-odbc/Makefile
index 4d3c94361292..51f1578def79 100644
--- a/databases/rubygem-dbd-odbc/Makefile
+++ b/databases/rubygem-dbd-odbc/Makefile
@@ -10,6 +10,10 @@ COMMENT= ODBC driver for DBI-for-Ruby
LICENSE= BSD3CLAUSE
+BROKEN= depends on broken ruby-odbc
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
+
RUN_DEPENDS= rubygem-dbi>=0:databases/rubygem-dbi \
${RUBY_SITEARCHLIBDIR}/odbc.so:databases/ruby-odbc
diff --git a/devel/dlangui/Makefile b/devel/dlangui/Makefile
index 15efa9014de1..f7c712cd87ad 100644
--- a/devel/dlangui/Makefile
+++ b/devel/dlangui/Makefile
@@ -13,6 +13,8 @@ COMMENT= Cross Platform GUI for D programming language
LICENSE= BSL
BROKEN= does not compile with latest version of ldc
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
BUILD_DEPENDS= ldmd2:lang/ldc \
dub:devel/dub \
diff --git a/editors/dlangide/Makefile b/editors/dlangide/Makefile
index 3aaba197e370..0f4a4357e0c7 100644
--- a/editors/dlangide/Makefile
+++ b/editors/dlangide/Makefile
@@ -13,6 +13,8 @@ COMMENT= D language IDE based on DlangUI
LICENSE= BSL
BROKEN= does not compile with latest version of ldc
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
BUILD_DEPENDS= ldmd2:lang/ldc \
dub:devel/dub \
diff --git a/emulators/desmume/Makefile b/emulators/desmume/Makefile
index 6d9992ee45b0..b726bbbf1614 100644
--- a/emulators/desmume/Makefile
+++ b/emulators/desmume/Makefile
@@ -13,6 +13,8 @@ COMMENT= Nintendo DS emulator
LICENSE= GPLv2
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
libSoundTouch.so:audio/soundtouch
diff --git a/emulators/yabause/Makefile b/emulators/yabause/Makefile
index 26253d9790e9..d1ef9d3cb883 100644
--- a/emulators/yabause/Makefile
+++ b/emulators/yabause/Makefile
@@ -43,6 +43,8 @@ SDL2_USE_OFF= sdl=sdl
.if ${PORT_OPTIONS:MQT5}
BROKEN= does not compile
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
.endif
post-patch:
diff --git a/emulators/yape/Makefile b/emulators/yape/Makefile
index a987d6a359b3..67dbfaa9bdb6 100644
--- a/emulators/yape/Makefile
+++ b/emulators/yape/Makefile
@@ -12,6 +12,8 @@ MAINTAINER= jmohacsi@bsd.hu
COMMENT= Yet Another Commodore +4 Emulator
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
USE_SDL= sdl
USES= compiler:features gmake
diff --git a/games/armagetron/Makefile b/games/armagetron/Makefile
index a1d97dde773d..7ffd3e93c38f 100644
--- a/games/armagetron/Makefile
+++ b/games/armagetron/Makefile
@@ -16,6 +16,8 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN= network/nNetObject.cpp:1533:46: error: ordered comparison between pointer and zero ('const nSocket *' and 'int')
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
USES= gmake jpeg
GNU_CONFIGURE= yes
diff --git a/games/boswars/Makefile b/games/boswars/Makefile
index 291441ace5c1..6c72169e3b2d 100644
--- a/games/boswars/Makefile
+++ b/games/boswars/Makefile
@@ -15,6 +15,8 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libpng.so:graphics/png \
libtheora.so:multimedia/libtheora \
diff --git a/games/ceferino/Makefile b/games/ceferino/Makefile
index ef5d82d47148..d427e13a1116 100644
--- a/games/ceferino/Makefile
+++ b/games/ceferino/Makefile
@@ -13,6 +13,8 @@ COMMENT= Game similar to Super Pang
LICENSE= GPLv2
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
USE_SDL= sdl mixer image
GNU_CONFIGURE= yes
diff --git a/games/chanta/Makefile b/games/chanta/Makefile
index f307a878d3c5..6533a8d00722 100644
--- a/games/chanta/Makefile
+++ b/games/chanta/Makefile
@@ -14,6 +14,8 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
USES= gmake
USE_SDL= sdl image mixer
diff --git a/games/d2x-xl/Makefile b/games/d2x-xl/Makefile
index 817ad08b3b98..6731ca5afcf4 100644
--- a/games/d2x-xl/Makefile
+++ b/games/d2x-xl/Makefile
@@ -16,6 +16,8 @@ MAINTAINER= aragon@phat.za.net
COMMENT= Community Unix port of Descent 2 Game
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
EXTRACT_DEPENDS= unrar:archivers/unrar
RUN_DEPENDS= unrar:archivers/unrar
diff --git a/games/drcreep/Makefile b/games/drcreep/Makefile
index cd1efa37611b..25fc68c17bcd 100644
--- a/games/drcreep/Makefile
+++ b/games/drcreep/Makefile
@@ -13,6 +13,8 @@ COMMENT= Castles of Dr. Creep
LICENSE= GPLv3
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
USE_SDL= sdl
diff --git a/games/frobtads/Makefile b/games/frobtads/Makefile
index fb0db08c3f67..10f40744a3e5 100644
--- a/games/frobtads/Makefile
+++ b/games/frobtads/Makefile
@@ -12,6 +12,8 @@ MAINTAINER= kaiwang27@gmail.com
COMMENT= TADS interpreter and the compilers for both TADS 2 and 3
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libcurl.so:ftp/curl
diff --git a/games/jaggedalliance2/Makefile b/games/jaggedalliance2/Makefile
index 1a1e4832af73..0c8b4f8b767a 100644
--- a/games/jaggedalliance2/Makefile
+++ b/games/jaggedalliance2/Makefile
@@ -12,6 +12,8 @@ MAINTAINER= lme@FreeBSD.org
COMMENT= Port of "Jagged Alliance 2" using SDL
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
# Ignore this if you feel adventurous
ONLY_FOR_ARCHS= aarch64 amd64 arm armv6 armv7 i386
ONLY_FOR_ARCHS_REASON= Needs a little endian environment
diff --git a/games/paintown/Makefile b/games/paintown/Makefile
index 77a2ebdcee15..cf2bb48f1b0b 100644
--- a/games/paintown/Makefile
+++ b/games/paintown/Makefile
@@ -14,6 +14,8 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= liballeg.so:devel/allegro \
libpng.so:graphics/png \
diff --git a/games/pykawari/Makefile b/games/pykawari/Makefile
index 4a93edc683dd..49ec71e2377b 100644
--- a/games/pykawari/Makefile
+++ b/games/pykawari/Makefile
@@ -15,6 +15,8 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/license.txt
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
RUN_DEPENDS= ninix:games/ninix-aya
diff --git a/games/stepmania-devel/Makefile b/games/stepmania-devel/Makefile
index 65b913b5224b..f5188450067b 100644
--- a/games/stepmania-devel/Makefile
+++ b/games/stepmania-devel/Makefile
@@ -16,6 +16,8 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/Docs/Licenses.txt
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libpcre.so:devel/pcre \
libpng.so:graphics/png
diff --git a/games/tinymux/Makefile b/games/tinymux/Makefile
index 6a449a757e21..3b6e10086961 100644
--- a/games/tinymux/Makefile
+++ b/games/tinymux/Makefile
@@ -14,6 +14,8 @@ LICENSE= ART10
LICENSE_FILE= ${WRKSRC}/copyright.h
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
WRKSRC= ${WRKDIR}/mux2.10/src
diff --git a/games/voxelands/Makefile b/games/voxelands/Makefile
index c3bfe6b864bf..424d9e83800a 100644
--- a/games/voxelands/Makefile
+++ b/games/voxelands/Makefile
@@ -14,6 +14,8 @@ LICENSE= GPLv3+
BROKEN= fails to build
BROKEN_powerpc64= fails to link: sibling call optimization does not allow automatic multiple TOCs
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libIrrlicht.so:x11-toolkits/irrlicht \
libfreetype.so:print/freetype2
diff --git a/games/warsow/Makefile b/games/warsow/Makefile
index 742bbf405180..ccf8f2525f52 100644
--- a/games/warsow/Makefile
+++ b/games/warsow/Makefile
@@ -15,6 +15,8 @@ COMMENT= Futuristic, fast-paced first person shooter
LICENSE= GPLv2
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libcurl.so:ftp/curl
RUN_DEPENDS= ${LOCALBASE}/${DATADIR_REL}/basewsw/data1_15.pk3:games/warsow-data
diff --git a/graphics/appleseed/Makefile b/graphics/appleseed/Makefile
index 7e81dfc4c195..921e5015aba0 100644
--- a/graphics/appleseed/Makefile
+++ b/graphics/appleseed/Makefile
@@ -13,6 +13,8 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libpng.so:graphics/png \
diff --git a/graphics/apvlv/Makefile b/graphics/apvlv/Makefile
index fd06cf41c142..6abff0748bbf 100644
--- a/graphics/apvlv/Makefile
+++ b/graphics/apvlv/Makefile
@@ -14,6 +14,8 @@ COMMENT= PDF/DJVU Viewer that behaves like Vim
LICENSE= GPLv2
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib
diff --git a/graphics/qslim/Makefile b/graphics/qslim/Makefile
index 7663e3d40cdc..a20e5c941873 100644
--- a/graphics/qslim/Makefile
+++ b/graphics/qslim/Makefile
@@ -13,6 +13,8 @@ COMMENT= SlimKit surface modeling tools
LICENSE= GPLv2
BROKEN= fails to link
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff \
diff --git a/graphics/rawstudio/Makefile b/graphics/rawstudio/Makefile
index 9e524f61a086..76f845de5e89 100644
--- a/graphics/rawstudio/Makefile
+++ b/graphics/rawstudio/Makefile
@@ -13,6 +13,8 @@ COMMENT= Open-source program to read and manipulate RAW photo images
LICENSE= GPLv2
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libpng.so:graphics/png \
liblcms.so:graphics/lcms \
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index c4e8fb7dd115..b42c3bc28cdc 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -14,6 +14,8 @@ COMMENT= System dedicated to the visualization of huge graphs
LICENSE= LGPL3
BROKEN= Missing libquazip.so:archivers/quazip@qt4
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libpng.so:graphics/png \
libOGDF.so:math/ogdf \
libfreetype.so:print/freetype2
diff --git a/lang/dmd2/Makefile b/lang/dmd2/Makefile
index a7f7128271d5..a95677cd50ea 100644
--- a/lang/dmd2/Makefile
+++ b/lang/dmd2/Makefile
@@ -24,6 +24,8 @@ BROKEN_powerpc64= fails to build: can't mangle function with unknown linkage (vo
BROKEN_sparc64= fails to install: divide-by-zero error
BROKEN_FreeBSD_12= stack corruption in generated dmd tool caused by inode64 resulting in segfault
BROKEN_FreeBSD_13= stack corruption in generated dmd tool caused by inode64 resulting in segfault
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
NOT_FOR_ARCHS= aarch64
NOT_FOR_ARCHS_REASON= no cpu specified, assuming X86
diff --git a/lang/qore/Makefile b/lang/qore/Makefile
index 36f403a091c6..ca1421d5488f 100644
--- a/lang/qore/Makefile
+++ b/lang/qore/Makefile
@@ -15,6 +15,8 @@ BROKEN_mips= fails to link: single-compilation-unit.cpp:(.text+0xdfc): relocati
BROKEN_mips64= fails to link: single-compilation-unit.cpp:(.text+0xdfc): relocation truncated to fit: R_MIPS_CALL16 against '__ltdf2@@FBSDprivate_1.0'
BROKEN_powerpc= fails to build
BROKEN_powerpc64= fails to compile: unsupported relocation against r1
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libpcre.so:devel/pcre \
libmpfr.so:math/mpfr
diff --git a/lang/swift/Makefile b/lang/swift/Makefile
index fd91b30dc018..77befee33a63 100644
--- a/lang/swift/Makefile
+++ b/lang/swift/Makefile
@@ -14,6 +14,8 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/swift/LICENSE.txt
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
BUILD_DEPENDS= cmake:devel/cmake \
bash:shells/bash \
diff --git a/mail/milter-manager/Makefile b/mail/milter-manager/Makefile
index 276d149b1400..bc1b1ea7db47 100644
--- a/mail/milter-manager/Makefile
+++ b/mail/milter-manager/Makefile
@@ -13,6 +13,8 @@ LICENSE= AGPLv3 GFDL GPLv3 LGPL3
LICENSE_COMB= multi
BROKEN_RUBY24= Build succeeds, but using binary results in segmentation fault
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
BUILD_DEPENDS= rubygem-glib2>0:devel/rubygem-glib2
LIB_DEPENDS= libev.so:devel/libev
diff --git a/math/goblin/Makefile b/math/goblin/Makefile
index c3dd3e805fe0..d23e155ba80f 100644
--- a/math/goblin/Makefile
+++ b/math/goblin/Makefile
@@ -16,6 +16,8 @@ LICENSE_COMB= multi
LICENSE_FILE_LGPL21= ${WRKSRC}/tcl/LGPL
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
CONFLICTS= glpk-[0-9]*
USES= gmake tk tar:tgz
diff --git a/math/mosesdecoder/Makefile b/math/mosesdecoder/Makefile
index f73b79f0153d..f1d7ce8d1340 100644
--- a/math/mosesdecoder/Makefile
+++ b/math/mosesdecoder/Makefile
@@ -11,6 +11,8 @@ MAINTAINER= demon@FreeBSD.org
COMMENT= Statistical machine translation system
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
BUILD_DEPENDS= bash:shells/bash \
bjam:devel/boost-jam
diff --git a/multimedia/asdcplib/Makefile b/multimedia/asdcplib/Makefile
index 3ee944290c3f..42bbe8a5da9a 100644
--- a/multimedia/asdcplib/Makefile
+++ b/multimedia/asdcplib/Makefile
@@ -10,6 +10,8 @@ MAINTAINER= olgeni@FreeBSD.org
COMMENT= Open source implementation of SMPTE and the MXF Interop format
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libexpat.so:textproc/expat2
diff --git a/net/crtmpserver/Makefile b/net/crtmpserver/Makefile
index 37236738c09e..7014b2bd8fda 100644
--- a/net/crtmpserver/Makefile
+++ b/net/crtmpserver/Makefile
@@ -14,6 +14,8 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
USES= cmake lua ssl
CMAKE_SOURCE_PATH= ${WRKSRC}/builders/cmake
diff --git a/net/openafs/Makefile b/net/openafs/Makefile
index 766fbac4cd42..bde9cdfefeae 100644
--- a/net/openafs/Makefile
+++ b/net/openafs/Makefile
@@ -22,6 +22,8 @@ LICENSE_FILE= ${WRKSRC}/doc/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
ONLY_FOR_ARCHS= i386 amd64
AFS_DISTVERSION= 1.6.22
diff --git a/security/kr/Makefile b/security/kr/Makefile
index 46fada3d85ab..71997871c3b3 100644
--- a/security/kr/Makefile
+++ b/security/kr/Makefile
@@ -10,6 +10,8 @@ MAINTAINER= feld@FreeBSD.org
COMMENT= SSH and Git commit/tag signing using a key stored in Krypton
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
NOT_FOR_ARCHS= i386
NOT_FOR_ARCHS_REASON= Uses 64bit types
diff --git a/security/quantis/Makefile b/security/quantis/Makefile
index 3ed03bfc2106..807da9265066 100644
--- a/security/quantis/Makefile
+++ b/security/quantis/Makefile
@@ -19,6 +19,8 @@ BROKEN= does not build
BROKEN_aarch64= fails to build: Could not find JNI (missing: JAVA_AWT_LIBRARY JAVA_JVM_LIBRARY)
BROKEN_armv6= fails to build: Could not find JNI (missing: JAVA_AWT_LIBRARY JAVA_JVM_LIBRARY)
BROKEN_armv7= fails to build: Could not find JNI (missing: JAVA_AWT_LIBRARY JAVA_JVM_LIBRARY)
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
USES= cmake compiler:c++11-lang zip:infozip
diff --git a/sysutils/bbcp/Makefile b/sysutils/bbcp/Makefile
index c98ff3c53c86..d365b2516877 100644
--- a/sysutils/bbcp/Makefile
+++ b/sysutils/bbcp/Makefile
@@ -13,6 +13,8 @@ LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/src/COPYING.LESSER
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
USES= tar:xz
diff --git a/sysutils/boxbackup/Makefile b/sysutils/boxbackup/Makefile
index e0f3976cf831..1eba2df46cfc 100644
--- a/sysutils/boxbackup/Makefile
+++ b/sysutils/boxbackup/Makefile
@@ -16,6 +16,8 @@ LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE-DUAL.txt
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
USES= autoreconf perl5 ssl tar:tgz
GNU_CONFIGURE= yes
diff --git a/sysutils/grub2-efi/Makefile b/sysutils/grub2-efi/Makefile
index 14944bdf3804..7f080e0718d3 100644
--- a/sysutils/grub2-efi/Makefile
+++ b/sysutils/grub2-efi/Makefile
@@ -14,6 +14,10 @@ COMMENT= Multiboot EFI boot loader
LICENSE= GPLv3
+BROKEN= depends on broken grub2-pcbsd
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
+
RUN_DEPENDS= ${LOCALBASE}/bin/mformat:emulators/mtools \
${LOCALBASE}/bin/grub-mkrescue:sysutils/grub2-pcbsd
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex \
diff --git a/sysutils/grub2-pcbsd/Makefile b/sysutils/grub2-pcbsd/Makefile
index 563a46ee1ab8..bd0eaa6295b1 100644
--- a/sysutils/grub2-pcbsd/Makefile
+++ b/sysutils/grub2-pcbsd/Makefile
@@ -15,6 +15,8 @@ COMMENT= Multiboot boot loader
LICENSE= GPLv3
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex \
${LOCALBASE}/bin/bash:shells/bash \
diff --git a/sysutils/mdcp/Makefile b/sysutils/mdcp/Makefile
index 7a5c24a536df..d5324bf78510 100644
--- a/sysutils/mdcp/Makefile
+++ b/sysutils/mdcp/Makefile
@@ -10,6 +10,8 @@ MAINTAINER= wamonzyne@hotmail.com
COMMENT= Fastest utility for copy from a disk device for many
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
GNU_CONFIGURE= yes
USES= gmake
diff --git a/sysutils/openhpi/Makefile b/sysutils/openhpi/Makefile
index 3cd570719147..abde86b19a5f 100644
--- a/sysutils/openhpi/Makefile
+++ b/sysutils/openhpi/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libuuid.so:misc/e2fsprogs-libuuid \
libnetsnmp.so:net-mgmt/net-snmp \
diff --git a/sysutils/sbsigntool/Makefile b/sysutils/sbsigntool/Makefile
index 96149879cce2..8882d26c564b 100644
--- a/sysutils/sbsigntool/Makefile
+++ b/sysutils/sbsigntool/Makefile
@@ -14,6 +14,8 @@ COMMENT= Signing utility for UEFI secure boot
LICENSE= GPLv3
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
BUILD_DEPENDS= ${LOCALBASE}/lib/libgnuefi.a:devel/gnu-efi \
help2man:misc/help2man
diff --git a/textproc/scim-bridge/Makefile b/textproc/scim-bridge/Makefile
index 3a6407f29285..7024b04d1db4 100644
--- a/textproc/scim-bridge/Makefile
+++ b/textproc/scim-bridge/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/doc/LICENSE.GPL
LICENSE_FILE_LGPL21= ${WRKSRC}/doc/LICENSE.LGPL
BROKEN_FreeBSD= fails to compile with clang6 or later
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
LIB_DEPENDS= libscim-1.0.so:textproc/scim
diff --git a/textproc/sphinxsearch-devel/Makefile b/textproc/sphinxsearch-devel/Makefile
index 975b5ad7df00..95f0d8108f7a 100644
--- a/textproc/sphinxsearch-devel/Makefile
+++ b/textproc/sphinxsearch-devel/Makefile
@@ -22,6 +22,8 @@ COMMENT= Sphinx Full-Text Search Engine
LICENSE= GPLv2
BROKEN= fails to build
+DEPRECATED= Broken for more than 6 months
+EXPIRATION_DATE= 2019-05-08
# If expat is present on the system and configure finds it, it will
# unconditionally link the output binary against it. There's no way