aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2024-04-02 08:20:24 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2024-04-02 09:32:09 +0000
commit1eec19b9a6a89746b6beabd9501b0095a50483b0 (patch)
tree68f80d828496d8bb1e42c678c1016fc5d394e375
parent8c5b73b52ebb3f034cc7a11fe1eb0e13e87a84ff (diff)
downloadports-1eec19b9a6a89746b6beabd9501b0095a50483b0.tar.gz
ports-1eec19b9a6a89746b6beabd9501b0095a50483b0.zip
www/gitlab-ce: fix devel/rubygem-sprockets3 upgrade to 3.7.3
fixes a regression from af60e439bb936b93a597c3bb122600eadf96400e gitlab applies a patch to sprockets3 to apply a thread safe fix: https://github.com/rails/sprockets/pull/759 So modified the patch to work also with version 3.7.3 as regarding the changelog, this patch will not be merged back into version 3 of sprocket: https://github.com/rails/sprockets/pull/759#issuecomment-1252274619 It looks like gitlab project will maybe port to another module: https://gitlab.com/gitlab-org/gitlab/-/issues/373997#note_1360248557 https://gitlab.com/gitlab-org/gitlab/-/issues/373997#note_1785295197
-rw-r--r--www/gitlab-ce/Makefile2
-rw-r--r--www/gitlab-ce/files/patch-config_initializers_sprockets__patch.rb11
2 files changed, 12 insertions, 1 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index 6408bd775a3f..24f5db72c97a 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -1,7 +1,7 @@
PORTNAME= gitlab-ce
PORTVERSION= 16.10.1
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www devel
# include patch to fix database migration
diff --git a/www/gitlab-ce/files/patch-config_initializers_sprockets__patch.rb b/www/gitlab-ce/files/patch-config_initializers_sprockets__patch.rb
new file mode 100644
index 000000000000..fa1976f8892d
--- /dev/null
+++ b/www/gitlab-ce/files/patch-config_initializers_sprockets__patch.rb
@@ -0,0 +1,11 @@
+--- config/initializers/sprockets_patch.rb.orig 2024-04-02 08:17:37 UTC
++++ config/initializers/sprockets_patch.rb
+@@ -8,7 +8,7 @@
+
+ require 'sprockets/utils'
+
+-unless Gem::Version.new(Sprockets::VERSION) == Gem::Version.new('3.7.2')
++unless Gem::Version.new(Sprockets::VERSION) == Gem::Version.new('3.7.3')
+ raise 'New version of Sprockets detected. This patch can likely be removed.'
+ end
+