aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-13 09:29:59 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-13 09:31:50 +0000
commit1ef90d2476af510a18e4fd1c840e0abd73c0671a (patch)
tree0d86f5473f0e98fb6036c1390b1357fe6ab8626b
parentf86306995e95bb46ed825d91836ad6d3776044b4 (diff)
downloadports-1ef90d2476af510a18e4fd1c840e0abd73c0671a.tar.gz
ports-1ef90d2476af510a18e4fd1c840e0abd73c0671a.zip
net-im/toot: Update to 0.42.0
- Remove BROKEN - Update MASTER_SITES: use upstream release tarball (sdist) - Change MASTER_SITES to PYPI and GitHub - Update version requirement of RUN_DEPENDS - Convert to USE_PYTHON=pytest Changes: https://github.com/ihabunek/toot/releases
-rw-r--r--net-im/toot/Makefile44
-rw-r--r--net-im/toot/distinfo6
2 files changed, 18 insertions, 32 deletions
diff --git a/net-im/toot/Makefile b/net-im/toot/Makefile
index 89cc5ac8ea96..01645e5a28a5 100644
--- a/net-im/toot/Makefile
+++ b/net-im/toot/Makefile
@@ -1,5 +1,7 @@
PORTNAME= toot
-DISTVERSION= 0.41.1
+PORTVERSION= 0.42.0
+MASTER_SITES= PYPI \
+ https://github.com/ihabunek/toot/releases/download/${PORTVERSION}/
CATEGORIES= net-im python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,38 +12,22 @@ WWW= https://github.com/ihabunek/toot
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN= does not run with current devel/py-urwid (PR 274411)
-
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.5.0:www/py-beautifulsoup@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}click>=8.1:devel/py-click@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests>=2.13:www/py-requests@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}tomlkit>=0.10.0:textproc/py-tomlkit@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.5.0<5.0:www/py-beautifulsoup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=8.1<9:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.13<3.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tomlkit>=0.10.0<1.0:textproc/py-tomlkit@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wcwidth>=0.1.7:devel/py-wcwidth@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}urwid>=2.0.0:devel/py-urwid@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.5.0:www/py-beautifulsoup@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-cov>=2.4.0:devel/py-pytest-cov@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest>=3.0.0:devel/py-pytest@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}urwid>=2.0.0<3.0:devel/py-urwid@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flake8>=0:devel/py-flake8@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psycopg2>=0:databases/py-psycopg2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-xdist>=0:devel/py-pytest-xdist@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=0:devel/py-typing-extensions@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urwidgets>=0.1:devel/py-urwidgets@${PY_FLAVOR}
USES= python
-USE_GITHUB= yes
-GH_ACCOUNT= ihabunek
-USE_PYTHON= autoplist distutils
-
-TEST_TARGET= coverage test
+USE_PYTHON= autoplist distutils pytest
NO_ARCH= yes
-PORTDOCS= CHANGELOG.md README.rst
-
-OPTIONS_DEFINE= DOCS
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/CHANGELOG.md ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.rst ${STAGEDIR}${DOCSDIR}
-
-pre-test:
- @${REINPLACE_CMD} -e 's|py.test |py.test-${PYTHON_VER} |' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|pytest |pytest-${PYTHON_VER} |' ${WRKSRC}/Makefile
-
.include <bsd.port.mk>
diff --git a/net-im/toot/distinfo b/net-im/toot/distinfo
index f6b675e1afbd..f307ae7286f5 100644
--- a/net-im/toot/distinfo
+++ b/net-im/toot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1704466378
-SHA256 (ihabunek-toot-0.41.1_GH0.tar.gz) = 8d5f6aa5b156f9a3be01b9f6d3bffb103090f56456b434ea18962526b1e1370e
-SIZE (ihabunek-toot-0.41.1_GH0.tar.gz) = 914571
+TIMESTAMP = 1712886516
+SHA256 (toot-0.42.0.tar.gz) = 6f6c128f7111ff945de6f67386083d1426d086beda4f40b410b8f646409183ef
+SIZE (toot-0.42.0.tar.gz) = 1000822