aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-01-22 01:35:02 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-01-22 01:35:02 +0000
commit1f08544d942340ee59c8433e1dbb352c635c9178 (patch)
treecbe801caa38fddeb29e707230b11535d02faf5e5
parent394b4f98df5969855de64b326eac48381e0e2fc4 (diff)
downloadports-1f08544d942340ee59c8433e1dbb352c635c9178.tar.gz
ports-1f08544d942340ee59c8433e1dbb352c635c9178.zip
Disable H.264 encoder support unless WITH_H264 is defined
Notes
Notes: svn path=/head/; revision=127068
-rw-r--r--multimedia/vlc-devel/Makefile10
-rw-r--r--multimedia/vlc/Makefile10
2 files changed, 14 insertions, 6 deletions
diff --git a/multimedia/vlc-devel/Makefile b/multimedia/vlc-devel/Makefile
index b3c11f73f4d2..e153c9c06cbb 100644
--- a/multimedia/vlc-devel/Makefile
+++ b/multimedia/vlc-devel/Makefile
@@ -98,8 +98,8 @@
#
# Multimedia Knbos:
#
-# WITHOUT_H264
-# Disable H.264/AVC Video Support
+# WITH_H264
+# Enable H.264/AVC Video Support
#
# WITHOUT_LIBMATROSKA=yes
# Matroska Container Format Support
@@ -281,6 +281,10 @@ WITH_FRIBIDI= yes
WITH_GGI= yes
.endif
+.if exists(${LOCALBASE}/lib/libx264.a) && !defined(WITHOUT_H264)
+WITH_H264= yes
+.endif
+
.if exists(${LOCALBASE}/lib/libmp3lame.a) && !defined(WITHOUT_LAME)
WITH_LAME= yes
.endif
@@ -448,7 +452,7 @@ LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
CONFIGURE_ARGS+=--enable-aa
.endif
-.if !defined(WITHOUT_H264)
+.if defined(WITH_H264) && !defined(WITHOUT_H264)
CONFIGURE_ARGS+=--enable-x264
LIB_DEPENDS+= x264.0:${PORTSDIR}/multimedia/x264
.else
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index b3c11f73f4d2..e153c9c06cbb 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -98,8 +98,8 @@
#
# Multimedia Knbos:
#
-# WITHOUT_H264
-# Disable H.264/AVC Video Support
+# WITH_H264
+# Enable H.264/AVC Video Support
#
# WITHOUT_LIBMATROSKA=yes
# Matroska Container Format Support
@@ -281,6 +281,10 @@ WITH_FRIBIDI= yes
WITH_GGI= yes
.endif
+.if exists(${LOCALBASE}/lib/libx264.a) && !defined(WITHOUT_H264)
+WITH_H264= yes
+.endif
+
.if exists(${LOCALBASE}/lib/libmp3lame.a) && !defined(WITHOUT_LAME)
WITH_LAME= yes
.endif
@@ -448,7 +452,7 @@ LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
CONFIGURE_ARGS+=--enable-aa
.endif
-.if !defined(WITHOUT_H264)
+.if defined(WITH_H264) && !defined(WITHOUT_H264)
CONFIGURE_ARGS+=--enable-x264
LIB_DEPENDS+= x264.0:${PORTSDIR}/multimedia/x264
.else