aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-11-18 00:51:34 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-11-18 00:51:34 +0000
commit1f2a4fab1330c0d3c4cf3bf5188caea03b1cefbe (patch)
tree71adde622c1454a31223a790512fd8775bb22bcf
parent9437190c8c3b50fa20cd81463a49907a19c2d209 (diff)
downloadports-1f2a4fab1330c0d3c4cf3bf5188caea03b1cefbe.tar.gz
ports-1f2a4fab1330c0d3c4cf3bf5188caea03b1cefbe.zip
graphics/netpbm: Fix build with older netpbm versions installed
The build currently fails when older netpbm version are still installed in the build environment e.g. when upgrading from 10.35.98 to 10.80.00 the build fails with ppmtompeg.o: In function `main': ppmtompeg.c:(.text+0x9a5): undefined reference to `pm_strfree' ppmtompeg.o: In function `getUserFrameFile': ppmtompeg.c:(.text+0xcb1): undefined reference to `pm_asprintf' ppmtompeg.c:(.text+0xcfb): undefined reference to `pm_strfree' ppmtompeg.c:(.text+0xd04): undefined reference to `pm_strfree' - Use explicit paths when linking with libnetpbm - Remove UPDATING entry that previously recommended deinstalling netpbm first when using portmaster/portupgrade PR: 223724
Notes
Notes: svn path=/head/; revision=454404
-rw-r--r--UPDATING12
-rw-r--r--graphics/netpbm/Makefile4
-rw-r--r--graphics/netpbm/files/config.mk1
3 files changed, 4 insertions, 13 deletions
diff --git a/UPDATING b/UPDATING
index 0cef7be4208a..2c56741c89c1 100644
--- a/UPDATING
+++ b/UPDATING
@@ -149,18 +149,6 @@ you update your ports collection, before attempting any port upgrades.
The HPN option is currently disabled by default, and does not build,
in the package. This follows what happened in base as well.
- 20171006:
- AFFECTS: users of graphics/netpbm
- AUTHOR: tobik@FreeBSD.org
-
- If you use portmaster/portupgrade/make to build your ports, please
- uninstall the old netpbm version first before attempting to update to
- netpbm 10.80.00:
-
- pkg delete -f netpbm
-
- It is recommended that you rebuild all dependent ports as well.
-
20171004:
AFFECTS: users of security/krb5-appl
AUTHOR: cy@FreeBSD.org
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 0dd7d1382cae..c6550a28910e 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -87,7 +87,9 @@ post-patch:
.endfor
post-patch-STATIC-on:
- @${REINPLACE_CMD} 's|$$(LD)|$$(LD) -static|g' ${WRKSRC}/common.mk
+ @${REINPLACE_CMD} -e 's|$$(LD)|$$(LD) -static|g' \
+ -e 's@$$(NETPBMLIBFNAME)@libnetpbm.a@' \
+ ${WRKSRC}/common.mk
# Disable building svgtopam by default. It is the only program that
# requires libxml2 and it is not useful in this day and age according
diff --git a/graphics/netpbm/files/config.mk b/graphics/netpbm/files/config.mk
index 844b5156bccd..51ef5f2438f9 100644
--- a/graphics/netpbm/files/config.mk
+++ b/graphics/netpbm/files/config.mk
@@ -13,6 +13,7 @@ JBIGHDR_DIR = $(LOCALBASE)/include
JBIGLIB = -L$(LOCALBASE)/lib -ljbig
JPEGHDR_DIR = $(LOCALBASE)/include
JPEGLIB = -L$(LOCALBASE)/lib -ljpeg
+LINKER_CAN_DO_EXPLICIT_LIBRARY = Y
LINKERISCOMPILER = Y
NETPBMLIBSUFFIX = so
NETPBMLIBTYPE = unixshared