aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-26 00:09:03 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-26 00:09:51 +0000
commit1f66e6087a40418bf8e82eddb27facee9c53dd0a (patch)
tree40083dce6cf55ccd8af661cf97492b3b3d2358b3
parent3237ce1557467a3f89a3d1fa7a9308161665bf0c (diff)
downloadports-1f66e6087a40418bf8e82eddb27facee9c53dd0a.tar.gz
ports-1f66e6087a40418bf8e82eddb27facee9c53dd0a.zip
games/gnuchess: Fix build with llvm16
- Pet portclippy - Adopt port Sponsored by: The FreeBSD Foundation
-rw-r--r--games/gnuchess/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/games/gnuchess/Makefile b/games/gnuchess/Makefile
index 21eb4a1964ba..b474e3209ef1 100644
--- a/games/gnuchess/Makefile
+++ b/games/gnuchess/Makefile
@@ -5,24 +5,29 @@ MASTER_SITES= GNU/chess
# The DISTFILES here is explicitly needed because it can be extended later.
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Classic Gnu Chess
WWW= https://savannah.gnu.org/projects/chess
LICENSE= GPLv3+
+USES= cpe shebangfix
+CPE_VENDOR= gnu
+CPE_PRODUCT= chess
+
+SHEBANG_FILES= doc/quotes.rb
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= MKDIR_P="${MKDIR}"
+
INFO= gnuchess
-USES= cpe shebangfix
-SHEBANG_FILES= doc/quotes.rb
-CPE_PRODUCT= chess
-CPE_VENDOR= gnu
OPTIONS_DEFINE= OPENING_BOOK DOCS NLS
OPTIONS_DEFAULT= OPENING_BOOK
OPTIONS_SUB= yes
+
OPENING_BOOK_DESC= Install opening book (25 MB download)
+
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
@@ -33,6 +38,10 @@ DISTFILES+= book_1.02.pgn.gz
EXTRACT_ONLY+= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CPPFLAGS+= -Dregister=
+.endif
+
post-build:
.if ${PORT_OPTIONS:MOPENING_BOOK}
zcat ${DISTDIR}/book_1.02.pgn.gz > ${WRKSRC}/src/book.pgn