aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-31 00:20:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-31 00:20:02 +0000
commit1f8afcce0db23b9425534f029fdd0bcf1bd64bd4 (patch)
tree6903ed89491a68f61c206a3cbb4575b6699a4677
parentf63b0fc761df77c794c7a223d5694f67e0f1ced1 (diff)
downloadports-1f8afcce0db23b9425534f029fdd0bcf1bd64bd4.tar.gz
ports-1f8afcce0db23b9425534f029fdd0bcf1bd64bd4.zip
Text::Trim does what chomp does, but at both ends of the string.
Notes
Notes: svn path=/head/; revision=204726
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Trim/Makefile26
-rw-r--r--textproc/p5-Text-Trim/distinfo3
-rw-r--r--textproc/p5-Text-Trim/pkg-descr3
-rw-r--r--textproc/p5-Text-Trim/pkg-plist2
5 files changed, 35 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 795d419e8e54..58878f9156b5 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -597,6 +597,7 @@
SUBDIR += p5-Text-Textile
SUBDIR += p5-Text-Tmpl
SUBDIR += p5-Text-Trac
+ SUBDIR += p5-Text-Trim
SUBDIR += p5-Text-Unaccent
SUBDIR += p5-Text-VimColor
SUBDIR += p5-Text-WikiFormat
diff --git a/textproc/p5-Text-Trim/Makefile b/textproc/p5-Text-Trim/Makefile
new file mode 100644
index 000000000000..4b69266a5ab7
--- /dev/null
+++ b/textproc/p5-Text-Trim/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Text-Trim
+# Date created: 2007-29-12
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Trim
+PORTVERSION= 1.01
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Extract the structure of a quoted mail message
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+USE_PERL5= yes
+PERL_MODBUILD= Module::Build
+
+MAN3= Text::Trim.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Trim/distinfo b/textproc/p5-Text-Trim/distinfo
new file mode 100644
index 000000000000..8a6d8b9cfee8
--- /dev/null
+++ b/textproc/p5-Text-Trim/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-Trim-1.01.tar.gz) = 4893d17917835002e292399b186a77f1
+SHA256 (Text-Trim-1.01.tar.gz) = 442fd57a761f6cb21a464c62dfe6ce1b7baaab818c8768219112e58145c038ca
+SIZE (Text-Trim-1.01.tar.gz) = 4329
diff --git a/textproc/p5-Text-Trim/pkg-descr b/textproc/p5-Text-Trim/pkg-descr
new file mode 100644
index 000000000000..90d755300891
--- /dev/null
+++ b/textproc/p5-Text-Trim/pkg-descr
@@ -0,0 +1,3 @@
+Text::Trim does what chomp does, but at both ends of the string.
+
+WWW: http://search.cpan.org/dist/Text-Trim/
diff --git a/textproc/p5-Text-Trim/pkg-plist b/textproc/p5-Text-Trim/pkg-plist
new file mode 100644
index 000000000000..24f33801e314
--- /dev/null
+++ b/textproc/p5-Text-Trim/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Text/Trim.pm
+@dirrmtry %%SITE_PERL%%/Text