aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2023-08-09 22:37:51 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2023-08-09 22:37:51 +0000
commit1fa92942aff196b6c72cf9572d05b34dbefefcd4 (patch)
treec291d78fb107137f3f9d0d564cc3d67af5335ebf
parent57a2c4c7d1f0a02aa115501c8ee9c30c605cea7c (diff)
downloadports-1fa92942aff196b6c72cf9572d05b34dbefefcd4.tar.gz
ports-1fa92942aff196b6c72cf9572d05b34dbefefcd4.zip
security/boringssl: remove needless CMAKE_INSTALL_PREFIX (+)
The CMAKE_INSTALL_PREFIX is already defined in Mk/Uses/cmake.mk, so can be safely removed. Bump PORTREVISION. Reported by: fluffy Fixes: 57a2c4c7d1f0a02aa115501c8ee9c30c605cea7c
-rw-r--r--security/boringssl/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/security/boringssl/Makefile b/security/boringssl/Makefile
index 15084b61dced..1de8a3f97cd3 100644
--- a/security/boringssl/Makefile
+++ b/security/boringssl/Makefile
@@ -1,6 +1,6 @@
PORTNAME= boringssl
PORTVERSION= 0.0.0.0.2023.08.05.01
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES+= https://proxy.golang.org/:gomods
DISTFILES+= golang.org/x/crypto/@v/v0.10.0.zip:gomods \
@@ -31,8 +31,8 @@ USE_GITHUB= yes
GH_ACCOUNT= google
GH_TAGNAME= e28988e
CMAKE_ARGS+= -DBUILD_SHARED_LIBS=1 \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=${PREFIX}
+ -DCMAKE_BUILD_TYPE=Release
+
USE_LDCONFIG= yes
LDFLAGS+= -Wl,-rpath,${LOCALBASE}/lib
TEST_TARGET= run_tests