aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-04-06 12:01:29 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-04-06 12:01:29 +0000
commit21173a4561118abf9578cb0a7320651cef6ab27c (patch)
tree482459e5fad07c370ac3c1de9162327ec577fde6
parentab8a59366f5a75f0f28e09719c0dfdea6216fdb4 (diff)
downloadports-21173a4561118abf9578cb0a7320651cef6ab27c.tar.gz
ports-21173a4561118abf9578cb0a7320651cef6ab27c.zip
devel/godot: actually stop using builtin libpng
platform/x11/detect.py actually forces builtin libpng if builtin freetype or zlib is used. Use the system ones. This also fixes build on powerpc64le, since builtin libpng is not built with VSX. PR: 254703 Approved by: FreeBSD@ShaneWare.Biz (maintainer)
-rw-r--r--devel/godot/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/godot/Makefile b/devel/godot/Makefile
index 69fe4bf8a4c4..a1b34f32fb6b 100644
--- a/devel/godot/Makefile
+++ b/devel/godot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= godot
DISTVERSION= 3.2.3
+PORTREVISION= 1
DISTVERSIONSUFFIX= -stable
CATEGORIES= devel games
@@ -28,7 +29,8 @@ USE_GL= gl glew glu
USE_GITHUB= yes
GH_ACCOUNT= godotengine
-MAKE_ARGS+= platform=x11 builtin_libpng=False verbose=True
+MAKE_ARGS+= platform=x11 builtin_libpng=False \
+ builtin_freetype=False builtin_zlib=False verbose=True
MAKE_ARGS+= ${MAKE_ARGS_${CHOSEN_COMPILER_TYPE}}
MAKE_ARGS_clang= use_llvm=True use_lld=True
CXXFLAGS_i386= ${CXXFLAGS_i386_${CHOSEN_COMPILER_TYPE}}