aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2023-02-05 18:23:23 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2023-02-06 06:53:44 +0000
commit216fd47c91df77d77ccb5c1a714e619e0ae8020b (patch)
treef354c601bbcfa4f3c1a784ef47d701ae1a5f5844
parent0b6f13d2d0c0c79025f12f34854df1ae764fa4cf (diff)
downloadports-216fd47c91df77d77ccb5c1a714e619e0ae8020b.tar.gz
ports-216fd47c91df77d77ccb5c1a714e619e0ae8020b.zip
archivers/ancient: Add new port
ancient is a collection of decompression routines for old formats popular in the Amiga, Atari computers and some other systems from 80's and 90's as well as some that are currently used which were used in a some specific way in these old systems. For simple usage both a simple command line application as well as a simple API to use the decompressors are provided. The compression algorithm is automatically detected in most cases, however there are some corner cases where it is not entirely reliable due to weaknesses in the old format used.
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/ancient/Makefile26
-rw-r--r--archivers/ancient/distinfo3
-rw-r--r--archivers/ancient/files/ancient.141
-rw-r--r--archivers/ancient/pkg-descr7
-rw-r--r--archivers/ancient/pkg-plist7
6 files changed, 85 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index f80c7a291505..a9acb772a873 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -5,6 +5,7 @@
SUBDIR += R-cran-zip
SUBDIR += advancecomp
SUBDIR += amigadepacker
+ SUBDIR += ancient
SUBDIR += apache-commons-compress
SUBDIR += arc
SUBDIR += arj
diff --git a/archivers/ancient/Makefile b/archivers/ancient/Makefile
new file mode 100644
index 000000000000..b13d6d55db80
--- /dev/null
+++ b/archivers/ancient/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= ancient
+PORTVERSION= 2.0.0
+DISTVERSIONPREFIX= v
+CATEGORIES= archivers
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Decompression routines for ancient formats
+WWW= https://github.com/temisu/ancient
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= autoconf-archive>=0:devel/autoconf-archive
+
+USES= autoreconf gmake libtool pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= temisu
+GNU_CONFIGURE= yes
+
+INSTALL_TARGET= install-strip
+
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.mk>
diff --git a/archivers/ancient/distinfo b/archivers/ancient/distinfo
new file mode 100644
index 000000000000..b446009273eb
--- /dev/null
+++ b/archivers/ancient/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1675603963
+SHA256 (temisu-ancient-v2.0.0_GH0.tar.gz) = 9c6b31e4d968ec3adb25596a0b30405d1080d3de0546f1485ecb0ac2eca6261d
+SIZE (temisu-ancient-v2.0.0_GH0.tar.gz) = 98727
diff --git a/archivers/ancient/files/ancient.1 b/archivers/ancient/files/ancient.1
new file mode 100644
index 000000000000..c53abea3f26f
--- /dev/null
+++ b/archivers/ancient/files/ancient.1
@@ -0,0 +1,41 @@
+.TH ancient 1 "December 25 2020"
+.SH NAME
+ancient \- decompression routines for ancient formats
+.SH SYNOPSIS
+.B ancient
+.RI [ identify | verify | decompress | scan ] " inputfile" " optionaloutputfile"
+.br
+.SH DESCRIPTION
+This manual page documents briefly the
+.B ancient
+command.
+.PP
+\fBancient\fP is a collection of decompression routines for old formats popular
+in the Amiga, Atari computers and some other systems from 80's and 90's as well
+as some that are currently used which were used in a some specific way in these
+old systems.
+.br
+For simple usage both a simple command line application as well as a simple API
+to use the decompressors are provided. The compression algorithm is
+automatically detected in most cases, however there are some corner cases
+where it is not entirely reliable due to weaknesses in the old format used.
+.br
+.SH OPTIONS
+These programs DO NOT follow the usual GNU command line syntax.
+.TP
+.B identify packed_input_file
+Identifies compression used in a file.
+.TP
+.B verify packed_input_file unpacked_comparison_file
+Verifies decompression against known good unpacked file.
+.TP
+.B decompress packed_input_file output_file
+Decompresses single file
+.TP
+.B scan input_dir output_dir
+Scans input directory recursively and stores all found.
+Known compressed streams to separate files in output directory.
+.SH SEE ALSO
+.BR unxz (1),
+.BR unpigz (1).
+.br
diff --git a/archivers/ancient/pkg-descr b/archivers/ancient/pkg-descr
new file mode 100644
index 000000000000..244ac4cd48cb
--- /dev/null
+++ b/archivers/ancient/pkg-descr
@@ -0,0 +1,7 @@
+ancient is a collection of decompression routines for old formats popular in the
+Amiga, Atari computers and some other systems from 80's and 90's as well as some
+that are currently used which were used in a some specific way in these old
+systems. For simple usage both a simple command line application as well as a
+simple API to use the decompressors are provided. The compression algorithm is
+automatically detected in most cases, however there are some corner cases where
+it is not entirely reliable due to weaknesses in the old format used.
diff --git a/archivers/ancient/pkg-plist b/archivers/ancient/pkg-plist
new file mode 100644
index 000000000000..d342f2148bfb
--- /dev/null
+++ b/archivers/ancient/pkg-plist
@@ -0,0 +1,7 @@
+bin/ancient
+include/ancient/ancient.hpp
+lib/libancient.a
+lib/libancient.so
+lib/libancient.so.2
+lib/libancient.so.2.0.0
+libdata/pkgconfig/libancient.pc