aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-05 08:42:21 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-05 08:42:21 +0000
commit21708d5827ef1979b0eb03f77afa20afbe2eafec (patch)
tree931789b859c299f1a0d0166df72130a05a0c969a
parent405c06507219d4c67a3ec6439962240c82241b4a (diff)
downloadports-21708d5827ef1979b0eb03f77afa20afbe2eafec.tar.gz
ports-21708d5827ef1979b0eb03f77afa20afbe2eafec.zip
games/NBlood: fix build on powerpc
<artificial>:(.text+0x9cc): undefined reference to `__atomic_load_8' /usr/local/bin/ld: <artificial>:(.text+0xa58): undefined reference to `__atomic_compare_exchange_8' collect2: error: ld returned 1 exit status
-rw-r--r--games/NBlood/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/games/NBlood/Makefile b/games/NBlood/Makefile
index 97512d64e734..3b63d30b6fcf 100644
--- a/games/NBlood/Makefile
+++ b/games/NBlood/Makefile
@@ -20,6 +20,8 @@ LIB_DEPENDS= libvpx.so:multimedia/libvpx \
libFLAC.so:audio/flac \
libvorbis.so:audio/libvorbis
+LDFLAGS_powerpc=-latomic
+
USES= compiler:gcc-c++11-lib gl gmake pkgconfig sdl
USE_GITHUB= yes
GH_ACCOUNT= nukeykt