aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-13 13:05:22 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-13 13:12:15 +0000
commit219f1126369d4bac8838172b73d615b737498770 (patch)
tree6ae93854f5f1d2e8e4e348f6f2783cf84488c570
parent79be3a828152cd1be5f6ddacbaf17eff38bb79b5 (diff)
downloadports-219f1126369d4bac8838172b73d615b737498770.tar.gz
ports-219f1126369d4bac8838172b73d615b737498770.zip
devel/py-jaraco.stream: New port
Routines for handling streaming data, including a set of generators for loading gzip data on the fly. WWW: https://github.com/jaraco/jaraco.stream
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-jaraco.stream/Makefile27
-rw-r--r--devel/py-jaraco.stream/distinfo3
-rw-r--r--devel/py-jaraco.stream/pkg-descr2
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9fca971db658..1e07a2a709fa 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4831,6 +4831,7 @@
SUBDIR += py-jaraco.functools
SUBDIR += py-jaraco.itertools
SUBDIR += py-jaraco.logging
+ SUBDIR += py-jaraco.stream
SUBDIR += py-jaraco.text
SUBDIR += py-jaraco.timing
SUBDIR += py-jaraco.util
diff --git a/devel/py-jaraco.stream/Makefile b/devel/py-jaraco.stream/Makefile
new file mode 100644
index 000000000000..c7d370208372
--- /dev/null
+++ b/devel/py-jaraco.stream/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= jaraco.stream
+PORTVERSION= 3.0.3
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= Routines for handling streaming data
+WWW= https://github.com/jaraco/jaraco.stream
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.1:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-black>=0.3.7:devel/py-pytest-black@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-checkdocs>=2.4:devel/py-pytest-checkdocs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-enabler>=1.0.1:devel/py-pytest-enabler@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-mypy>=0:devel/py-pytest-mypy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517 pytest
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-jaraco.stream/distinfo b/devel/py-jaraco.stream/distinfo
new file mode 100644
index 000000000000..bc56a0675971
--- /dev/null
+++ b/devel/py-jaraco.stream/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1691930926
+SHA256 (jaraco.stream-3.0.3.tar.gz) = 3af4b0441090ee65bd6dde930d29f93f50c4a2fe6048e2a9d288285f5e4dc441
+SIZE (jaraco.stream-3.0.3.tar.gz) = 8877
diff --git a/devel/py-jaraco.stream/pkg-descr b/devel/py-jaraco.stream/pkg-descr
new file mode 100644
index 000000000000..5aa9e8384832
--- /dev/null
+++ b/devel/py-jaraco.stream/pkg-descr
@@ -0,0 +1,2 @@
+Routines for handling streaming data, including a set of generators for
+loading gzip data on the fly.