aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-07-14 14:20:00 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-07-14 14:20:00 +0000
commit21eed903da62a23d10e85fc34d3a15efe7ff5967 (patch)
treec54aa48c3c71b8ae7a302fe4ed7cf4b2960e6259
parent03f44da6f4ba8cb98199d1c346a353a1d8b1f787 (diff)
downloadports-21eed903da62a23d10e85fc34d3a15efe7ff5967.tar.gz
ports-21eed903da62a23d10e85fc34d3a15efe7ff5967.zip
1: Stagify.
2: use @sample, bump version. Approved by: portmgr@ (blanket)
Notes
Notes: svn path=/head/; revision=361780
-rw-r--r--irc/qwebirc/Makefile34
-rw-r--r--irc/qwebirc/pkg-descr2
-rw-r--r--irc/qwebirc/pkg-plist8
3 files changed, 21 insertions, 23 deletions
diff --git a/irc/qwebirc/Makefile b/irc/qwebirc/Makefile
index 905f344ced14..4c4a96b67c89 100644
--- a/irc/qwebirc/Makefile
+++ b/irc/qwebirc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qwebirc
PORTVERSION= 0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc www
MASTER_SITES= https://bitbucket.org/slug/qwebirc/get/
DISTNAME= stable
@@ -12,29 +12,25 @@ EXTRACT_SUFX= .gz
MAINTAINER= tabmow@freenode.net
COMMENT= Fast, easy to use, free, and open source web IRC client
-WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_BUILD= yes
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twistedCore \
+ ${PYTHON_SITELIBDIR}/twisted/web/__init__.py:${PORTSDIR}/www/py-twistedWeb \
+ ${PYTHON_SITELIBDIR}/twisted/mail/__init__.py:${PORTSDIR}/mail/py-twistedMail \
+ ${PYTHON_SITELIBDIR}/twisted/words/__init__.py:${PORTSDIR}/net-im/py-twistedWords \
+ ${PYTHON_SITELIBDIR}/twisted/names/__init__.py:${PORTSDIR}/dns/py-twistedNames \
+ ${PYTHON_SITELIBDIR}/twisted/conch/__init__.py:${PORTSDIR}/security/py-twistedConch
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
USE_PYTHON= yes
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twistedCore
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/twisted/web/__init__.py:${PORTSDIR}/www/py-twistedWeb
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/twisted/mail/__init__.py:${PORTSDIR}/mail/py-twistedMail
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/twisted/words/__init__.py:${PORTSDIR}/net-im/py-twistedWords
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/twisted/names/__init__.py:${PORTSDIR}/dns/py-twistedNames
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/twisted/conch/__init__.py:${PORTSDIR}/security/py-twistedConch
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
do-install:
- @${MKDIR} ${PREFIX}/www/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/www/${PORTNAME}
(cd ${WRKDIR}/${PORTNAME} && \
- ${COPYTREE_SHARE} \* ${PREFIX}/www/${PORTNAME} )
+ ${COPYTREE_SHARE} \* ${STAGEDIR}${PREFIX}/www/${PORTNAME} )
post-install:
- @if [ ! -f ${PREFIX}/www/${PORTNAME}/config.py ]; then \
- ${CP} -p ${PREFIX}/www/${PORTNAME}/config.py.example ${PREFIX}/www/${PORTNAME}/config.py ; \
- fi
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/www/${PORTNAME}
+ ${MV} ${STAGEDIR}${PREFIX}/www/${PORTNAME}/config.py.example \
+ ${STAGEDIR}${PREFIX}/www/${PORTNAME}/config.py.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/qwebirc/pkg-descr b/irc/qwebirc/pkg-descr
index 2d7639c78240..05b96b2d99d5 100644
--- a/irc/qwebirc/pkg-descr
+++ b/irc/qwebirc/pkg-descr
@@ -2,4 +2,4 @@ qwebirc is a fast, easy to use, free and open source IRC client
designed by and originally just for the QuakeNet IRC network.
It incorporates SSL and notifications via favicon/titlebar flashing.
-WWW: http://qwebirc.org
+WWW: http://qwebirc.org
diff --git a/irc/qwebirc/pkg-plist b/irc/qwebirc/pkg-plist
index 6d707653aae0..b0ec88941923 100644
--- a/irc/qwebirc/pkg-plist
+++ b/irc/qwebirc/pkg-plist
@@ -1,3 +1,5 @@
+@owner %%WWWOWN%%
+@group %%WWWGRP%%
%%WWWDIR%%/AUTHORS
%%WWWDIR%%/LICENSE
%%WWWDIR%%/bin/__init__.py
@@ -12,9 +14,7 @@
%%WWWDIR%%/bin/yuicompressor-2.3.5.jar
%%WWWDIR%%/clean.py
%%WWWDIR%%/compile.py
-@unexec if cmp -s %D/www/qwebirc/config.py.example %D/www/qwebirc/config.py; then rm -f %D/www/qwebirc/config.py; fi
-%%WWWDIR%%/config.py.example
-@exec if [ ! -f %D/www/qwebirc/config.py ] ; then cp -p %D/%F %B/config.py; fi
+@sample %%WWWDIR%%/config.py.sample
%%WWWDIR%%/css/colours.css
%%WWWDIR%%/css/dialogs.css
%%WWWDIR%%/css/mochaui.css
@@ -159,6 +159,8 @@
%%WWWDIR%%/static/sound/soundmanager2.swf
%%WWWDIR%%/static/sound/soundmanager2_flash9.swf
%%WWWDIR%%/twisted/plugins/webirc.py
+@group
+@owner
@dirrm %%WWWDIR%%/twisted/plugins
@dirrm %%WWWDIR%%/twisted
@dirrm %%WWWDIR%%/static/sound