aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-11 18:21:54 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-11 18:21:54 +0000
commit223c60c5d65d885c2155535b60933bf9039066aa (patch)
tree46e338b2f798e2bdb6a770eeb07770fc07fc1bde
parente7e6be23f17613f0ef9b1973f6997bc85ec4e438 (diff)
downloadports-223c60c5d65d885c2155535b60933bf9039066aa.tar.gz
ports-223c60c5d65d885c2155535b60933bf9039066aa.zip
Mk/Uses/python.mk: Cosmetic change
-rw-r--r--Mk/Uses/python.mk25
1 files changed, 21 insertions, 4 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 1665683f0827..57254be9b048 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -314,10 +314,26 @@ _PYTHON_BASECMD= ${LOCALBASE}/bin/python
_PYTHON_RELPORTDIR= lang/python
# List all valid USE_PYTHON features here
-_VALID_PYTHON_FEATURES= allflavors autoplist concurrent cython cython_run cython_test \
- distutils flavors noegginfo noflavors nose nose2 \
- optsuffix pep517 py3kplist pytest pytest4 pythonprefix \
- unittest unittest2
+_VALID_PYTHON_FEATURES= allflavors \
+ autoplist \
+ concurrent \
+ cython \
+ cython_run \
+ cython_test \
+ distutils \
+ flavors \
+ noegginfo \
+ noflavors \
+ nose \
+ nose2 \
+ optsuffix \
+ pep517 \
+ py3kplist \
+ pytest \
+ pytest4 \
+ pythonprefix \
+ unittest \
+ unittest2
_INVALID_PYTHON_FEATURES=
. for var in ${USE_PYTHON}
. if empty(_VALID_PYTHON_FEATURES:M${var})
@@ -581,6 +597,7 @@ _PYTHONPKGLIST= ${WRKDIR}/.PLIST.pymodtmp
# - it uses USE_PYTHON=distutils
#
+# cython* support
. if defined(_PYTHON_FEATURE_CYTHON)
BUILD_DEPENDS+= cython-${PYTHON_VER}:lang/cython@${PY_FLAVOR}
. endif