aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-11-19 08:12:06 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-11-19 08:12:06 +0000
commit22597d25a16c7bd409ff219f6638a21ecfb22049 (patch)
treedbe5541862a2c52f51cf288adcaa281ab177a9de
parentdf133878c16557c596665f4b781ec54a9dd669f2 (diff)
downloadports-22597d25a16c7bd409ff219f6638a21ecfb22049.tar.gz
ports-22597d25a16c7bd409ff219f6638a21ecfb22049.zip
devel/py-poetry-core: Fix 2c8e9f44ba77d569ec40cb5a275f8fa34a9f3bde
- Bump PORTREVISION for package change
-rw-r--r--devel/py-poetry-core/Makefile2
-rw-r--r--devel/py-poetry-core/files/setup.py3
2 files changed, 3 insertions, 2 deletions
diff --git a/devel/py-poetry-core/Makefile b/devel/py-poetry-core/Makefile
index 07944a71027e..7e8f860a9d28 100644
--- a/devel/py-poetry-core/Makefile
+++ b/devel/py-poetry-core/Makefile
@@ -1,6 +1,6 @@
PORTNAME= poetry-core
PORTVERSION= 1.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/devel/py-poetry-core/files/setup.py b/devel/py-poetry-core/files/setup.py
index 515ea1f8fe99..124b9635b7d0 100644
--- a/devel/py-poetry-core/files/setup.py
+++ b/devel/py-poetry-core/files/setup.py
@@ -21,6 +21,7 @@ packages = \
'poetry.core._vendor.pyparsing.diagram',
'poetry.core._vendor.pyrsistent',
'poetry.core._vendor.tomlkit',
+ 'poetry.core.constraints',
'poetry.core.constraints.generic',
'poetry.core.constraints.version',
'poetry.core.exceptions',
@@ -55,7 +56,7 @@ setup_kwargs = {
'name': 'poetry-core',
'version': '%%PORTVERSION%%',
'description': 'Poetry PEP 517 Build Backend',
- 'long_description': '# Poetry Core\n[![PyPI version](https://img.shields.io/pypi/v/poetry-core)](https://pypi.org/project/poetry-core/)\n[![Python Versions](https://img.shields.io/pypi/pyversions/poetry-core)](https://pypi.org/project/poetry-core/)\n[![License: MIT](https://img.shields.io/badge/License-MIT-yellow.svg)](https://opensource.org/licenses/MIT)\n[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)\n[![](https://github.com/python-poetry/poetry-core/workflows/Tests/badge.svg)](https://github.com/python-poetry/poetry-core/actions?query=workflow%3ATests)\n\nA [PEP 517](https://www.python.org/dev/peps/pep-0517/) build backend implementation developed for\n[Poetry](https://github.com/python-poetry/poetry). This project is intended to be a light weight, fully compliant,\nself-contained package allowing PEP 517 compatible build frontends to build Poetry managed projects.\n\n## Usage\nIn most cases, the usage of this package is transparent to the end-user as it is either made use by Poetry itself\nor a PEP 517 frontend (eg: `pip`).\n\nIn order to enable the use `poetry-core` as your build backend, the following snippet must be present in your\nproject\'s `pyproject.toml` file.\n\n```toml\n[build-system]\nrequires = ["poetry-core"]\nbuild-backend = "poetry.core.masonry.api"\n```\n\nOnce this is present, a PEP 517 frontend like `pip` can build and install your project from source without the need\nfor Poetry or any of it\'s dependencies.\n\n```shell\n# install to current environment\npip install /path/to/poetry/managed/project\n\n# build a wheel package\npip wheel /path/to/poetry/managed/project\n```\n\n## Why is this required?\nPrior to the release of version `1.1.0`, Poetry was a build as a project management tool that included a PEP 517\nbuild backend. This was inefficient and time consuming in majority cases a PEP 517 build was required. For example,\nboth `pip` and `tox` (with isolated builds) would install Poetry and all dependencies it required. Most of these\ndependencies are not required when the objective is to simply build either a source or binary distribution of your\nproject.\n\nIn order to improve the above situation, `poetry-core` was created. Shared functionality pertaining to PEP 517 build\nbackends, including reading lock file, `pyproject.toml` and building wheel/sdist, were implemented in this package. This\nmakes PEP 517 builds extremely fast for Poetry managed packages.\n',
+ 'long_description': '# Poetry Core\n[![PyPI version](https://img.shields.io/pypi/v/poetry-core)](https://pypi.org/project/poetry-core/)\n[![Python Versions](https://img.shields.io/pypi/pyversions/poetry-core)](https://pypi.org/project/poetry-core/)\n[![License: MIT](https://img.shields.io/badge/License-MIT-yellow.svg)](https://opensource.org/licenses/MIT)\n[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)\n[![](https://github.com/python-poetry/poetry-core/workflows/Tests/badge.svg)](https://github.com/python-poetry/poetry-core/actions?query=workflow%3ATests)\n\nA [PEP 517](https://www.python.org/dev/peps/pep-0517/) build backend implementation developed for\n[Poetry](https://github.com/python-poetry/poetry). This project is intended to be a light weight, fully compliant,\nself-contained package allowing PEP 517 compatible build frontends to build Poetry managed projects.\n\n## Usage\nIn most cases, the usage of this package is transparent to the end-user as it is either made use by Poetry itself\nor a PEP 517 frontend (eg: `pip`).\n\nIn order to enable the use `poetry-core` as your build backend, the following snippet must be present in your\nproject\'s `pyproject.toml` file.\n\n```toml\n[build-system]\nrequires = ["poetry-core"]\nbuild-backend = "poetry.core.masonry.api"\n```\n\nOnce this is present, a PEP 517 frontend like `pip` can build and install your project from source without the need\nfor Poetry or any of its dependencies.\n\n```shell\n# install to current environment\npip install /path/to/poetry/managed/project\n\n# build a wheel package\npip wheel /path/to/poetry/managed/project\n```\n\n## Why is this required?\nPrior to the release of version `1.1.0`, Poetry was a project management tool that included a PEP 517\nbuild backend. This was inefficient and time consuming when a PEP 517 build was required. For example,\nboth `pip` and `tox` (with isolated builds) would install Poetry and all dependencies it required. Most of these\ndependencies are not required when the objective is to simply build either a source or binary distribution of your\nproject.\n\nIn order to improve the above situation, `poetry-core` was created. Shared functionality pertaining to PEP 517 build\nbackends, including reading lock file, `pyproject.toml` and building wheel/sdist, were implemented in this package. This\nmakes PEP 517 builds extremely fast for Poetry managed packages.\n',
'author': 'Sébastien Eustace',
'author_email': 'sebastien@eustace.io',
'maintainer': 'None',