aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2022-02-09 14:49:45 +0000
committerMikael Urankar <mikael@FreeBSD.org>2022-02-09 16:19:35 +0000
commit22c0c4f2a6e599c4530dc47025f9f7153262f381 (patch)
tree675d1c2e094acb5a7f46fa570dc0bcea9e14ac87
parent55d4a9f74dca6706728b01622ddcf7d524e4250b (diff)
downloadports-22c0c4f2a6e599c4530dc47025f9f7153262f381.tar.gz
ports-22c0c4f2a6e599c4530dc47025f9f7153262f381.zip
audio/jack: Fix alignas() on non-packed architectures
Unbreak the build with Clang on architectures where JACK uses non-packed data structures, like arm64 or powerpc. The alignment errors are exposed there because: * The non-packed data structures require 8 byte alignment. * alignas() is not allowed to weaken alignment requirements to 4 bytes. * Clang enforces this according to standard, GCC ignores it. Use an additional alignas() specifier to let the compiler choose between minimum alignment (packed) and "natural" alignment (non-packed). This is both standard c++11 and compatible with older GCC, which does not propagate alignment requirements of packed substructures properly. PR: 261508 Submitted by: Florian Walpen <dev@submerge.ch>
-rw-r--r--audio/jack/Makefile3
-rw-r--r--audio/jack/distinfo4
2 files changed, 6 insertions, 1 deletions
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index 25a0b22e8c03..c0cfe9ebb489 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -3,6 +3,9 @@ DISTVERSIONPREFIX= v
DISTVERSION= 1.9.20
CATEGORIES= audio
+PATCH_SITES= https://github.com/jackaudio/jack2/commit/
+PATCHFILES+= 21b293dbc37d42446141a08922cdec0d2550c6a0.patch:-p1
+
MAINTAINER= dev@submerge.ch
COMMENT= Low latency audio server
diff --git a/audio/jack/distinfo b/audio/jack/distinfo
index b8c82243ecda..110a54242cd8 100644
--- a/audio/jack/distinfo
+++ b/audio/jack/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1642267444
+TIMESTAMP = 1644418071
SHA256 (jackaudio-jack2-v1.9.20_GH0.tar.gz) = 915ad2900992159bdb729b9fc4ea134b962ce32b2df0b384fee40a2c5808835d
SIZE (jackaudio-jack2-v1.9.20_GH0.tar.gz) = 1005000
+SHA256 (21b293dbc37d42446141a08922cdec0d2550c6a0.patch) = 19722d6f2e991006c6f1e470e7bc986ee3ca18ad0f9eb74b01332231c807554f
+SIZE (21b293dbc37d42446141a08922cdec0d2550c6a0.patch) = 3952