aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean Milanez Melo <jmelo@FreeBSD.org>2006-04-25 01:55:02 +0000
committerJean Milanez Melo <jmelo@FreeBSD.org>2006-04-25 01:55:02 +0000
commit22e951ba0f46694523a5fb9572f636b3880c47d2 (patch)
tree00b5d1b0ca4a38684cf0f8db3e47bc19114559ff
parent816aad728f8f03b664239948e797198e5b80ae51 (diff)
downloadports-22e951ba0f46694523a5fb9572f636b3880c47d2.tar.gz
ports-22e951ba0f46694523a5fb9572f636b3880c47d2.zip
- New port:
fswatch is a utility to guard changes in a file system. fswatch is composed of three simple programs: fswbuild, fswcmp, fswshow. fswbuild builds file system information database. fswcmp compairs two database files and returns what changes a in file system have been introduced. fswshow shows contents of database file. a file information database is platform independend. fswatch can collect the following information about files (and directories): inode, links, uid, gid, mode, size, flags, ctime, checksum (sha1) ; and can show which files were added, deleted or changed. PR: ports/95973 Submitted by: dominik karczmarski <dominik@karczmarski.com> (maintainer) Reworked by: jmelo Approved by: mnag (mentor)
Notes
Notes: svn path=/head/; revision=160406
-rw-r--r--security/Makefile1
-rw-r--r--security/fswatch/Makefile36
-rw-r--r--security/fswatch/distinfo3
-rw-r--r--security/fswatch/files/pkg-message.in12
-rw-r--r--security/fswatch/pkg-descr21
5 files changed, 73 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e8e7b02356c3..b0bcd405e137 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -122,6 +122,7 @@
SUBDIR += freebsd-update
SUBDIR += fressh
SUBDIR += fsh
+ SUBDIR += fswatch
SUBDIR += ftimes
SUBDIR += ftpmap
SUBDIR += fuzz
diff --git a/security/fswatch/Makefile b/security/fswatch/Makefile
new file mode 100644
index 000000000000..42084f494650
--- /dev/null
+++ b/security/fswatch/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: fswatch
+# Date created: 18 April 2006
+# Whom: dominik karczmarski <dominik@karczmarski.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fswatch
+DISTVERSION= 0.02beta5
+CATEGORIES= security sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= fswatch
+
+MAINTAINER= dominik@karczmarski.com
+COMMENT= File system checksum checker
+
+HAS_CONFIGURE= yes
+SUB_FILES= pkg-message
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/.b/beta/}/
+
+CONFIGURE_ARGS+= --prefix=${PREFIX} \
+ --enable-regex \
+ --enable-stflags
+
+PLIST_FILES= bin/fswbuild bin/fswcmp bin/fswshow \
+ bin/fswconf etc/fswatch.conf.sample
+
+MAN1= fswbuild.1 fswcmp.1 fswshow.1 fswconf.1
+MAN5= fswatch.conf.5
+MAN7= fswatch.7
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/security/fswatch/distinfo b/security/fswatch/distinfo
new file mode 100644
index 000000000000..5f47664f2e11
--- /dev/null
+++ b/security/fswatch/distinfo
@@ -0,0 +1,3 @@
+MD5 (fswatch-0.02beta5.tar.gz) = 3fa8208acaadf344a9be379a20638114
+SHA256 (fswatch-0.02beta5.tar.gz) = d042209234044655eb94a848bff65a33569c26f893d96ccde452661615b17ef5
+SIZE (fswatch-0.02beta5.tar.gz) = 102934
diff --git a/security/fswatch/files/pkg-message.in b/security/fswatch/files/pkg-message.in
new file mode 100644
index 000000000000..f4899dcd810b
--- /dev/null
+++ b/security/fswatch/files/pkg-message.in
@@ -0,0 +1,12 @@
+-----------------------------------------------------------------
+thank you for choosing fswatch. if you have any questions you can
+simply email me or post message to forum at project home page.
+
+default fswatch.conf checks directories:
+ /etc /bin /sbin /lib /libexec /usr/bin /usr/sbin /usr/lib
+ /usr/libexec /usr/libdata /usr/local/etc /usr/local/bin
+ /usr/local/sbin /usr/local/lib /usr/local/libexec
+ /usr/local/libdata
+
+see fswatch(7) .
+-----------------------------------------------------------------
diff --git a/security/fswatch/pkg-descr b/security/fswatch/pkg-descr
new file mode 100644
index 000000000000..24fb375dca46
--- /dev/null
+++ b/security/fswatch/pkg-descr
@@ -0,0 +1,21 @@
+fswatch:
+- is a utility to guard changes in a file system.
+
+- is composed of three simple programs: fswbuild, fswcmp, fswshow. fswbuild
+ builds a file system information database. fswcmp compairs two database files
+ and returns what changes a in file system have been introduced. fswshow shows
+ contents of database file. a file information database is platform
+ independend.
+
+- can collect the following information about files (and directories): inode,
+ links, uid, gid, mode, size, flags, ctime, checksum (sha1) ; and can show
+ which files were added, deleted or changed.
+
+- is one of many similar utilities. the main difference is the configuration.
+ you can define different settings for every directory in a directory tree.
+ moreover, it is very small and fast.
+
+WWW: http://fswatch.sourceforge.net
+
+- dominik karczmarski
+ dominik@karczmarski.com