aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2022-10-15 08:19:26 +0000
committerMatthias Andree <mandree@FreeBSD.org>2022-10-15 08:21:21 +0000
commit22ecf341139a2015b94b6e1a8da15239e5119732 (patch)
treea7700b027705c5057da6c4f6be881ad34e4a745d
parenteb53545bb55f788bc679fcdaf81adf4797b36c81 (diff)
downloadports-22ecf341139a2015b94b6e1a8da15239e5119732.tar.gz
ports-22ecf341139a2015b94b6e1a8da15239e5119732.zip
security/easy-rsa: update to v3.1.1
-rw-r--r--security/easy-rsa/Makefile6
-rw-r--r--security/easy-rsa/distinfo6
-rw-r--r--security/easy-rsa/files/patch-easyrsa41
3 files changed, 17 insertions, 36 deletions
diff --git a/security/easy-rsa/Makefile b/security/easy-rsa/Makefile
index 8a3ff8cf0c9d..52c2ec6782b2 100644
--- a/security/easy-rsa/Makefile
+++ b/security/easy-rsa/Makefile
@@ -1,8 +1,8 @@
PORTNAME= easy-rsa
-DISTVERSION= 3.1.0
-PORTREVISION= 3
+DISTVERSION= 3.1.1
CATEGORIES= security net-mgmt
-MASTER_SITES= https://github.com/OpenVPN/easy-rsa/releases/download/v${DISTVERSION}/
+MASTER_SITES= https://github.com/OpenVPN/easy-rsa/releases/download/v${DISTVERSION}/ \
+ LOCAL/mandree/
DISTNAME= EasyRSA-${DISTVERSION}
MAINTAINER= mandree@FreeBSD.org
diff --git a/security/easy-rsa/distinfo b/security/easy-rsa/distinfo
index 7d8559944507..196b1bb67416 100644
--- a/security/easy-rsa/distinfo
+++ b/security/easy-rsa/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1653138476
-SHA256 (EasyRSA-3.1.0.tgz) = 01b07ecb58dc003e47d4e74f9fc4da35ec6842e96cd003d66ed72a43df983659
-SIZE (EasyRSA-3.1.0.tgz) = 61255
+TIMESTAMP = 1665821482
+SHA256 (EasyRSA-3.1.1.tgz) = 779d425cacf1de56262b7a7ed6b90b36e614ce9273f08ad7b86992740cb3b2a5
+SIZE (EasyRSA-3.1.1.tgz) = 68434
diff --git a/security/easy-rsa/files/patch-easyrsa b/security/easy-rsa/files/patch-easyrsa
index f839ca4b6015..c0141db47a8d 100644
--- a/security/easy-rsa/files/patch-easyrsa
+++ b/security/easy-rsa/files/patch-easyrsa
@@ -1,32 +1,13 @@
-Isolate date -j -f ... + ... from locale.
-Filed upstream as Issue #591 <https://github.com/OpenVPN/easy-rsa/issues/591>
+workaround to fix https://github.com/OpenVPN/easy-rsa/issues/725
---- easyrsa.orig 2022-05-19 01:53:50 UTC
+--- easyrsa.orig 2022-10-13 11:37:48 UTC
+++ easyrsa
-@@ -2037,7 +2037,7 @@ renewable() {
- verify_ca_init
-
- in_dir="$EASYRSA_PKI"
-- MATCH=$(echo "$*" | sed -re 's/\s+/|/g')
-+ MATCH=$(echo "$*" | sed -re 's/[[:space:]]+/|/g')
- DATE=$(date --date \
- "+${EASYRSA_CERT_RENEW} days" \
- +"%y%m%d%H%M%S")
-@@ -2445,7 +2445,7 @@ display_san() {
-
- if echo "$EASYRSA_EXTRA_EXTS" | grep -q subjectAltName; then
- print "$(echo "$EASYRSA_EXTRA_EXTS" | grep subjectAltName |
-- sed 's/^\s*subjectAltName\s*=\s*//')"
-+ sed 's/^[[:space:]]*subjectAltName[[:space:]]*=[[:space:]]*//')"
- else
- san="$(
- x509v3san="X509v3 Subject Alternative Name:"
-@@ -3828,6 +3828,8 @@ VERSION_TEXT
-
- NL='
- '
-+
-+LC_TIME=C ; export LC_TIME ; unset LC_ALL
-
- # Be secure with a restrictive umask
- [ -z "$EASYRSA_NO_UMASK" ] && umask "${EASYRSA_UMASK:-077}"
+@@ -1317,7 +1317,7 @@ Missing X509-type 'COMMON'"
+
+ # Check for insert-marker in ssl config file
+ if ! grep -q '^#%CA_X509_TYPES_EXTRA_EXTS%' "$EASYRSA_SSL_CONF"; then
+- die "\
++ warn "\
+ The copy of openssl-easyrsa.cnf in use does not support X509-type 'ca'.
+ * $EASYRSA_SSL_CONF
+ Please update openssl-easyrsa.cnf to the latest official release."