aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-04-23 19:30:52 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-04-24 16:02:54 +0000
commit230c626fee35527dfaf32285c60b09a4e5922a7d (patch)
tree18e1cafff10e21bb26739adf07dfff58b813c295
parent4ef4b555f46b1bddd6600380dbcf0dacb013b95e (diff)
downloadports-230c626fee35527dfaf32285c60b09a4e5922a7d.tar.gz
ports-230c626fee35527dfaf32285c60b09a4e5922a7d.zip
textproc/groff: fix build with clang 16
Since clang 16 (and gcc 11) the default C++ standard is now gnu++17. Because textproc/groff's Makefile does not explicitly set its C++ standard, this leads to several errors: src/preproc/grn/hdb.cpp:38:15: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] int DBGetType(register char *s); ^~~~~~~~~ src/preproc/grn/hdb.cpp:64:3: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register ELT *temp; ^~~~~~~~~ src/preproc/grn/hdb.cpp:83:8: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] DBRead(register FILE *file) ^~~~~~~~~ src/preproc/grn/hdb.cpp:85:3: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register int i; ^~~~~~~~~ src/preproc/grn/hdb.cpp:86:3: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register int done; /* flag for input exhausted */ ^~~~~~~~~ src/preproc/grn/hdb.cpp:87:3: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register double nx; /* x holder so x is not set before orienting */ ^~~~~~~~~ src/preproc/grn/hdb.cpp:212:11: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] DBGetType(register char *s) ^~~~~~~~~ Add USE_CXXSTD=gnu++98 to avoid these errors. Approved by: bapt (maintainer) MFH: 2023Q2
-rw-r--r--textproc/groff/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/textproc/groff/Makefile b/textproc/groff/Makefile
index bb93769a15a6..ddefcaf8b7ec 100644
--- a/textproc/groff/Makefile
+++ b/textproc/groff/Makefile
@@ -17,6 +17,7 @@ RUN_DEPENDS:= psselect:print/psutils
MAKE_JOBS_UNSAFE= yes
USES= cpe gmake iconv:wchar_t perl5 makeinfo
+USE_CXXSTD= gnu++98
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-urw-fonts-dir=${LOCALBASE}/share/ghostscript/fonts/ \
--with-awk=/usr/bin/awk \