aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-29 19:32:37 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-29 22:53:39 +0000
commit23253ea43f819c9d3f5a32109a5086064908c04e (patch)
tree6414edf041f0960dddf394dcf696d2564804ee00
parent111bb60101e36d18e5bf14ed33ff8f53e5e5afa1 (diff)
downloadports-23253ea43f819c9d3f5a32109a5086064908c04e.tar.gz
ports-23253ea43f819c9d3f5a32109a5086064908c04e.zip
biology/emboss: Optionize mysql support
The port builds fine without mysql and as MySQL57 is reaching end of life so optionize MYSQL so that other flavors can be used and still there is an available pkg for this port. Approved by: portmgr (blanket)
-rw-r--r--biology/emboss/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/biology/emboss/Makefile b/biology/emboss/Makefile
index e5362ab34681..11b6b6c99fb0 100644
--- a/biology/emboss/Makefile
+++ b/biology/emboss/Makefile
@@ -1,6 +1,6 @@
PORTNAME= emboss
PORTVERSION= 6.6.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= biology
MASTER_SITES= ftp://emboss.open-bio.org/pub/EMBOSS/
DISTNAME= ${PORTNAME:tu}-${PORTVERSION}
@@ -17,8 +17,7 @@ BUILD_DEPENDS= clustalw:biology/clustalw \
LIB_DEPENDS= libgd.so:graphics/gd \
libpng.so:graphics/png
-USES= gmake libtool iconv mysql pgsql ssl
-IGNORE_WITH_MYSQL= 80
+USES= gmake libtool iconv localbase:ldflags pgsql ssl
USE_SUBMAKE= yes
CONFLICTS= qmail-ldap digest
@@ -29,16 +28,18 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
SUB_FILES= pkg-message emboss-shell
SUB_LIST= PREFIX=${PREFIX} DATADIR=${DATADIR}
-LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=${ICONV_CONFIGURE_ARG}
INSTALL_TARGET= install-strip
DOCSDIR= ${PREFIX}/share/${PORTNAME:tu}/doc
DATADIR= ${PREFIX}/share/${PORTNAME:tu}
-OPTIONS_DEFINE= DOCS X11
+OPTIONS_DEFINE= DOCS MYSQL X11
OPTIONS_DEFAULT= X11
+
DOCS_CONFIGURE_ON= --with-docroot=${DOCSDIR}
+MYSQL_USES= mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL=80
X11_USES= motif xorg
X11_USE= XORG=x11
X11_LIB_DEPENDS= libgd.so:graphics/gd \