aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-12-29 19:03:25 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-12-29 19:03:25 +0000
commit2328bfb8fe2f673218a3283f4491605e94116b41 (patch)
tree47483b0715961d6afad48ecae245dabdf3cc88b8
parent4e398edc2a6b9e139544e37c69e219c22fded087 (diff)
downloadports-2328bfb8fe2f673218a3283f4491605e94116b41.tar.gz
ports-2328bfb8fe2f673218a3283f4491605e94116b41.zip
- Move mail/py-spf to mail/py-pyspf
- Update MASTER_SITES: change from SF to CHEESESHOP - Update RUN_DEPENDS: always use dns/py-py3dns - Bump PORTREVISION for dependency change - Bump PORTREVISION for dependent ports
Notes
Notes: svn path=/head/; revision=404778
-rw-r--r--mail/Makefile2
-rw-r--r--mail/postfix-policyd-spf-python/Makefile3
-rw-r--r--mail/py-apolicy/Makefile4
-rw-r--r--mail/py-pyspf/Makefile (renamed from mail/py-spf/Makefile)21
-rw-r--r--mail/py-pyspf/distinfo2
-rw-r--r--mail/py-pyspf/pkg-descr (renamed from mail/py-spf/pkg-descr)0
-rw-r--r--mail/py-spf/distinfo2
-rw-r--r--mail/tumgreyspf/Makefile4
8 files changed, 17 insertions, 21 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 1832cfb9a6af..31810b84930c 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -511,8 +511,8 @@
SUBDIR += py-milter
SUBDIR += py-notmuch
SUBDIR += py-ppolicy
+ SUBDIR += py-pyspf
SUBDIR += py-spambayes
- SUBDIR += py-spf
SUBDIR += py-turbomail
SUBDIR += py-twistedMail
SUBDIR += py-zope.sendmail
diff --git a/mail/postfix-policyd-spf-python/Makefile b/mail/postfix-policyd-spf-python/Makefile
index e161e6ddf8f2..03c2772ee9d0 100644
--- a/mail/postfix-policyd-spf-python/Makefile
+++ b/mail/postfix-policyd-spf-python/Makefile
@@ -3,6 +3,7 @@
PORTNAME= postfix-policyd-spf-python
PORTVERSION= 1.3.2
+PORTREVISION= 1
CATEGORIES= mail python
MASTER_SITES= https://launchpad.net/pypolicyd-spf/${PORTVERSION:R}/${PORTVERSION}/+download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +16,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipaddr>0:${PORTSDIR}/devel/py-ipaddr \
- ${PYTHON_PKGNAMEPREFIX}spf>0:${PORTSDIR}/mail/py-spf \
+ ${PYTHON_PKGNAMEPREFIX}pyspf>0:${PORTSDIR}/mail/py-pyspf \
${PYTHON_PKGNAMEPREFIX}authres>0:${PORTSDIR}/mail/py-authres
USES= python
diff --git a/mail/py-apolicy/Makefile b/mail/py-apolicy/Makefile
index 2bf0eb8e03ed..63eebc8cb531 100644
--- a/mail/py-apolicy/Makefile
+++ b/mail/py-apolicy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apolicy
PORTVERSION= 0.73
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail python
MASTER_SITES= http://download.gna.org/apolicy/%SUBDIR%/ \
http://www.chifeng.name/dist/apolicy/%SUBDIR%/ \
@@ -13,7 +13,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER?= ports@FreeBSD.org
COMMENT= ACL system for Postfix, as a policy daemon
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/spf.py:${PORTSDIR}/mail/py-spf \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyspf>=0:${PORTSDIR}/mail/py-pyspf \
${PYTHON_SITELIBDIR}/IPy.py:${PORTSDIR}/net-mgmt/py-ipy
USES= python twisted
diff --git a/mail/py-spf/Makefile b/mail/py-pyspf/Makefile
index 8a384c87395a..afff7f8f7092 100644
--- a/mail/py-spf/Makefile
+++ b/mail/py-pyspf/Makefile
@@ -1,37 +1,32 @@
# Created by: Marcus Alves Grando <mnag@FreeBSD.org>
# $FreeBSD$
-PORTNAME= spf
+PORTNAME= pyspf
PORTVERSION= 2.0.12
-PORTREVISION= 2
+DISTVERSIONSUFFIX= t
+PORTREVISION= 3
CATEGORIES= mail python
-MASTER_SITES= SF/pymilter/py${PORTNAME}/py${PORTNAME}-${PORTVERSION}
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python implementation of the RFC 4408 SPF protocol
LICENSE= PSFL
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}py3dns>=0:${PORTSDIR}/dns/py-py3dns
+
NO_ARCH= yes
USE_PYTHON= autoplist concurrent distutils
USES= python shebangfix
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= bin/spf.py
SHEBANG_FILES= spf.py
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3000
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dns>=0:${PORTSDIR}/dns/py-dns
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}py3dns>=0:${PORTSDIR}/dns/py-py3dns
-.endif
-
post-install:
${CHMOD} ${BINMODE} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/spf.py
${LN} -s ${PYTHONPREFIX_SITELIBDIR}/spf.py ${STAGEDIR}${PREFIX}/bin/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/py-pyspf/distinfo b/mail/py-pyspf/distinfo
new file mode 100644
index 000000000000..40019b93eee8
--- /dev/null
+++ b/mail/py-pyspf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pyspf-2.0.12t.tar.gz) = 8aa21ba0e3aff8a4e8ad8f586c500a5d1f9c4c902c3f11bcc107465857cd41a2
+SIZE (pyspf-2.0.12t.tar.gz) = 67189
diff --git a/mail/py-spf/pkg-descr b/mail/py-pyspf/pkg-descr
index 8f437b1d05f5..8f437b1d05f5 100644
--- a/mail/py-spf/pkg-descr
+++ b/mail/py-pyspf/pkg-descr
diff --git a/mail/py-spf/distinfo b/mail/py-spf/distinfo
deleted file mode 100644
index afddda8fc049..000000000000
--- a/mail/py-spf/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (pyspf-2.0.12.tar.gz) = 8aa21ba0e3aff8a4e8ad8f586c500a5d1f9c4c902c3f11bcc107465857cd41a2
-SIZE (pyspf-2.0.12.tar.gz) = 67189
diff --git a/mail/tumgreyspf/Makefile b/mail/tumgreyspf/Makefile
index 5f4716ce350f..c828f2a750ac 100644
--- a/mail/tumgreyspf/Makefile
+++ b/mail/tumgreyspf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tumgreyspf
PORTVERSION= 1.38
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= ftp://ftp.tummy.com/pub/tummy/tumgreyspf/ \
ftp://ftp.tummy.com/pub/tummy/tumgreyspf/old-releases/ \
@@ -14,7 +14,7 @@ COMMENT= External policy checker for the postfix mail server
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/spf.py:${PORTSDIR}/mail/py-spf
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyspf>=0:${PORTSDIR}/mail/py-pyspf
OPTIONS_DEFINE= DOCS