aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 19:34:30 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 19:57:53 +0000
commit23b17b626c0b790c12cdef433c0b1253236fffee (patch)
tree16e8109987c051cdbfedf7f8b6832923fa808956
parentaeb0756246224ffe7dd3e391a1f78e50d7a1dc36 (diff)
downloadports-23b17b626c0b790c12cdef433c0b1253236fffee.tar.gz
ports-23b17b626c0b790c12cdef433c0b1253236fffee.zip
games/tuxracer: Fix build with llvm16
- Add missing DEPENDS - Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--games/tuxracer/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/games/tuxracer/Makefile b/games/tuxracer/Makefile
index e34287829624..fb116f808253 100644
--- a/games/tuxracer/Makefile
+++ b/games/tuxracer/Makefile
@@ -15,9 +15,10 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gl gmake sdl tk xorg
+USE_GL= gl glu
USE_SDL= mixer sdl
-USE_GL= gl
-USE_XORG= x11 xt xmu xi
+USE_XORG= ice sm x11 xext xi xmu xt
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl-inc="${TCL_INCLUDEDIR}" \
--with-tcl-libs="${LOCALBASE}/lib" \
@@ -25,8 +26,15 @@ CONFIGURE_ARGS= --with-tcl-inc="${TCL_INCLUDEDIR}" \
--with-gl-libs="${LOCALBASE}/lib" \
--with-gl-inc="${LOCALBASE}/include" \
--with-data-dir=${DATADIR}
+
CPPFLAGS+= -DGLX_GLXEXT_LEGACY
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
(cd ${WORKDATA} ${WRKDIR}/${PORTNAME}-data-${PORTVERSION} \