aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 05:59:24 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 05:59:24 +0000
commit23fdd676423eaf34255f37ca7ea8711cb76d5da4 (patch)
tree00f3c6d3d4fe6419c8a78fd11fed5df2540fec4a
parentef2fcf2f4ca09b645c93d0c50ec727711193d5fc (diff)
downloadports-23fdd67.tar.gz
ports-23fdd67.zip
devel/py-python-application: Move devel/py-application to devel/py-python-application
- Add NO_ARCH - Update WWW - Take maintainership - Bump PORTREVISION of dependent ports for dependency change
-rw-r--r--MOVED1
-rw-r--r--devel/Makefile2
-rw-r--r--devel/py-application/pkg-descr3
-rw-r--r--devel/py-python-application/Makefile (renamed from devel/py-application/Makefile)9
-rw-r--r--devel/py-python-application/distinfo (renamed from devel/py-application/distinfo)1
-rw-r--r--devel/py-python-application/pkg-descr3
-rw-r--r--devel/py-xcaplib/Makefile5
-rw-r--r--net/py-msrplib/Makefile5
8 files changed, 17 insertions, 12 deletions
diff --git a/MOVED b/MOVED
index a54e460be8bb..28fd938aa40f 100644
--- a/MOVED
+++ b/MOVED
@@ -16480,3 +16480,4 @@ www/py-django-rest-swagger|www/py-drf-yasg|2021-09-17|Has expired: Has expired:
www/py-django-taggit-serializer|www/py-django-taggit|2021-09-17|Has expired: Obsolete, please use www/py-django-taggit instead
www/efront||2021-09-17|Has expired: Unsupported by upstream
devel/pear-PHPDoc|devel/pear-PhpDocumentor|2021-09-19|This package is not maintained anymore and has been superseded. Use devel/pear-PhpDocumentor instead
+devel/py-application|devel/py-python-application|2021-09-19|Rename to match upstream naming
diff --git a/devel/Makefile b/devel/Makefile
index b179979628f5..7e32fced57c2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4108,7 +4108,6 @@
SUBDIR += py-apispec
SUBDIR += py-apns2
SUBDIR += py-appdirs
- SUBDIR += py-application
SUBDIR += py-applicationinsights
SUBDIR += py-apptools
SUBDIR += py-apscheduler
@@ -5029,6 +5028,7 @@
SUBDIR += py-pytest-xdist
SUBDIR += py-pytest-xprocess
SUBDIR += py-python-Levenshtein
+ SUBDIR += py-python-application
SUBDIR += py-python-bugzilla
SUBDIR += py-python-dbusmock
SUBDIR += py-python-distutils-extra
diff --git a/devel/py-application/pkg-descr b/devel/py-application/pkg-descr
deleted file mode 100644
index 8d79f0852b1f..000000000000
--- a/devel/py-application/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Basic building blocks for python applications
-
-WWW: https://pypi.org/project/python-application/
diff --git a/devel/py-application/Makefile b/devel/py-python-application/Makefile
index 8d8df139ad44..d0c4dcfe3ab0 100644
--- a/devel/py-application/Makefile
+++ b/devel/py-python-application/Makefile
@@ -1,17 +1,18 @@
# Created by: Eugene Grosbein <ports@grosbein.net>
-PORTNAME= application
+PORTNAME= python-application
PORTVERSION= 1.2.9
PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= python-${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Basic building blocks for python applications
USES= python:3.6+
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/devel/py-application/distinfo b/devel/py-python-application/distinfo
index 8490c66a7896..373b41fb63cd 100644
--- a/devel/py-application/distinfo
+++ b/devel/py-python-application/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1629364640
SHA256 (python-application-1.2.9.tar.gz) = 2bab78f0bae44e81295cdc90decf6aef39714b7bdf641b2926fb2f01229536d3
SIZE (python-application-1.2.9.tar.gz) = 40622
diff --git a/devel/py-python-application/pkg-descr b/devel/py-python-application/pkg-descr
new file mode 100644
index 000000000000..7b828cb3f57d
--- /dev/null
+++ b/devel/py-python-application/pkg-descr
@@ -0,0 +1,3 @@
+Basic building blocks for python applications
+
+WWW: https://github.com/AGProjects/python-application
diff --git a/devel/py-xcaplib/Makefile b/devel/py-xcaplib/Makefile
index e9e5b8c126b4..bccfa4857da9 100644
--- a/devel/py-xcaplib/Makefile
+++ b/devel/py-xcaplib/Makefile
@@ -2,6 +2,7 @@
PORTNAME= xcaplib
PORTVERSION= 1.2.2
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://download.ag-projects.com/XCAP/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,8 +13,8 @@ COMMENT= Python XCAP client library
LICENSE= LGPL20+
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}application>=1.1.5:devel/py-application@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-application>=1.1.5:devel/py-python-application@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR}
USES= python:3.6+
diff --git a/net/py-msrplib/Makefile b/net/py-msrplib/Makefile
index d4438ec08d49..0520472aa0a2 100644
--- a/net/py-msrplib/Makefile
+++ b/net/py-msrplib/Makefile
@@ -2,6 +2,7 @@
PORTNAME= msrplib
PORTVERSION= 0.20.0
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= http://download.ag-projects.com/MSRP/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,9 +13,9 @@ COMMENT= Python MSRP client library
LICENSE= LGPL21+
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}application>=1.2.8:devel/py-application@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}eventlib>=0:devel/py-eventlib@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}eventlib>=0:devel/py-eventlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}gnutls>=3.0.0:security/py-gnutls@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-application>=1.2.8:devel/py-python-application@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}zope.interface>=0:devel/py-zope.interface@${PY_FLAVOR}