aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-05-01 02:58:25 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-05-01 02:59:16 +0000
commit2415af0063906e57aa706b88705831820aa12558 (patch)
tree624ea61bd8b8e1378359b38d0f29f7be206b959a
parenteaebcc5ec4717113fa6b3371e98af60f7d3a62de (diff)
downloadports-2415af0063906e57aa706b88705831820aa12558.tar.gz
ports-2415af0063906e57aa706b88705831820aa12558.zip
editors/notepadnext: New port: Reimplementation of Notepad++
-rw-r--r--editors/Makefile1
-rw-r--r--editors/notepadnext/Makefile39
-rw-r--r--editors/notepadnext/distinfo13
-rw-r--r--editors/notepadnext/files/patch-src_NotepadNext_ScintillaNext.cpp11
-rw-r--r--editors/notepadnext/files/patch-src_ads_src_linux_FloatingWidgetTitleBar.cpp11
-rw-r--r--editors/notepadnext/pkg-descr3
6 files changed, 78 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 7d55ae920ab6..283e9163216c 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -207,6 +207,7 @@
SUBDIR += nedit
SUBDIR += neovim
SUBDIR += neovim-qt
+ SUBDIR += notepadnext
SUBDIR += nvi-m17n
SUBDIR += nvi2
SUBDIR += o
diff --git a/editors/notepadnext/Makefile b/editors/notepadnext/Makefile
new file mode 100644
index 000000000000..5d49a1dd5c90
--- /dev/null
+++ b/editors/notepadnext/Makefile
@@ -0,0 +1,39 @@
+PORTNAME= notepadnext
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.5.1
+CATEGORIES= editors
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Reimplementation of Notepad++
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libuchardet.so:textproc/uchardet
+
+USES= gl qmake qt:5 xorg
+USE_QT= core gui network printsupport widgets buildtools_build linguisttools_build
+USE_GL= gl
+USE_XORG= xcb
+
+USE_GITHUB= yes
+GH_ACCOUNT= dail8859
+GH_PROJECT= NotepadNext
+
+GH_TUPLE= alex-spataru:QSimpleUpdater:62e0ce7dde4c76e7533f2f0ee53f19ee1690c8dd:alex_spataru_QSimpleUpdater/src/QSimpleUpdater \
+ editorconfig:editorconfig-core-qt:52820d59769fcba6d0ed94f685406c0383fe1a30:editorconfig_editorconfig_core_qt/src/editorconfig-core-qt \
+ editorconfig:editorconfig-core-test:70840cfaf6a06766ab61e975b8a1fe3b891ee08e:editorconfig_editorconfig_core_test/src/editorconfig-core-qt/tests \
+ githubuser0xFFFF:Qt-Advanced-Docking-System:d5fefaa35fb53e299b7f39b0d8f541954c710d94:githubuser0xFFFF_Qt_Advanced_Docking_System/src/ads \
+ itay-grudev:SingleApplication:d0c43a51ad7d4f74ae5cff8d8cbf8aba0cf5e51c:itay_grudev_SingleApplication/src/singleapplication
+
+QMAKE_SOURCE_PATH= ${WRKSRC}/src/NotepadNext.pro
+
+CXXFLAGS+= -I${LOCALBASE}/include/uchardet
+LDFLAGS+= -luchardet
+
+PLIST_FILES= bin/NotepadNext
+
+do-install: # workaround for https://github.com/dail8859/NotepadNext/issues/123
+ ${INSTALL_PROGRAM} ${WRKSRC}/NotepadNext/NotepadNext ${STAGEDIR}${PREFIX}/bin/NotepadNext
+
+.include <bsd.port.mk>
diff --git a/editors/notepadnext/distinfo b/editors/notepadnext/distinfo
new file mode 100644
index 000000000000..7aa11e0532f9
--- /dev/null
+++ b/editors/notepadnext/distinfo
@@ -0,0 +1,13 @@
+TIMESTAMP = 1651366379
+SHA256 (dail8859-NotepadNext-v0.5.1_GH0.tar.gz) = 6033f82d41be516f04fabd31213ead35ca2a4ead5adb74501766c9464a3d9548
+SIZE (dail8859-NotepadNext-v0.5.1_GH0.tar.gz) = 4544658
+SHA256 (alex-spataru-QSimpleUpdater-62e0ce7dde4c76e7533f2f0ee53f19ee1690c8dd_GH0.tar.gz) = 1cc98b82e117f10d8eb563357a53c541e2b5e70a7b6845c4ae855b2a27edf448
+SIZE (alex-spataru-QSimpleUpdater-62e0ce7dde4c76e7533f2f0ee53f19ee1690c8dd_GH0.tar.gz) = 298412
+SHA256 (editorconfig-editorconfig-core-qt-52820d59769fcba6d0ed94f685406c0383fe1a30_GH0.tar.gz) = c28d5fded91231985f2b08729dd3f9ad5adbe6d117fbd9b00ab4c5314a761f6a
+SIZE (editorconfig-editorconfig-core-qt-52820d59769fcba6d0ed94f685406c0383fe1a30_GH0.tar.gz) = 6348
+SHA256 (editorconfig-editorconfig-core-test-70840cfaf6a06766ab61e975b8a1fe3b891ee08e_GH0.tar.gz) = 1692c09541fa0c4b0b166335c4cc0cb6a7b38bc65a6f5c0d4973c57768341c53
+SIZE (editorconfig-editorconfig-core-test-70840cfaf6a06766ab61e975b8a1fe3b891ee08e_GH0.tar.gz) = 13587
+SHA256 (githubuser0xFFFF-Qt-Advanced-Docking-System-d5fefaa35fb53e299b7f39b0d8f541954c710d94_GH0.tar.gz) = ddad83d4a349f5401e973fccd36e72d2d15fa140902d51a4accb39288c477413
+SIZE (githubuser0xFFFF-Qt-Advanced-Docking-System-d5fefaa35fb53e299b7f39b0d8f541954c710d94_GH0.tar.gz) = 10206316
+SHA256 (itay-grudev-SingleApplication-d0c43a51ad7d4f74ae5cff8d8cbf8aba0cf5e51c_GH0.tar.gz) = e49a35dd366a3a2ddc4b97f1d5fb5af9bed84a04a693645f61248c78ba370676
+SIZE (itay-grudev-SingleApplication-d0c43a51ad7d4f74ae5cff8d8cbf8aba0cf5e51c_GH0.tar.gz) = 21560
diff --git a/editors/notepadnext/files/patch-src_NotepadNext_ScintillaNext.cpp b/editors/notepadnext/files/patch-src_NotepadNext_ScintillaNext.cpp
new file mode 100644
index 000000000000..a1449e2ef07a
--- /dev/null
+++ b/editors/notepadnext/files/patch-src_NotepadNext_ScintillaNext.cpp
@@ -0,0 +1,11 @@
+--- src/NotepadNext/ScintillaNext.cpp.orig 2022-05-01 01:18:16 UTC
++++ src/NotepadNext/ScintillaNext.cpp
+@@ -17,7 +17,7 @@
+ */
+
+ #include "ScintillaNext.h"
+-#include "uchardet.h"
++#include <uchardet.h>
+ #include <cinttypes>
+
+ #include <QDir>
diff --git a/editors/notepadnext/files/patch-src_ads_src_linux_FloatingWidgetTitleBar.cpp b/editors/notepadnext/files/patch-src_ads_src_linux_FloatingWidgetTitleBar.cpp
new file mode 100644
index 000000000000..b62b3f7bfa86
--- /dev/null
+++ b/editors/notepadnext/files/patch-src_ads_src_linux_FloatingWidgetTitleBar.cpp
@@ -0,0 +1,11 @@
+--- src/ads/src/linux/FloatingWidgetTitleBar.cpp.orig 2022-05-01 01:03:58 UTC
++++ src/ads/src/linux/FloatingWidgetTitleBar.cpp
+@@ -194,7 +194,7 @@ void CFloatingWidgetTitleBar::mouseMoveEvent(QMouseEve
+ {
+ if(d->FloatingWidget->isMaximized())
+ {
+- d->FloatingWidget->showNormal(true);
++ d->FloatingWidget->showNormal();
+ }
+ d->FloatingWidget->moveFloating();
+ Super::mouseMoveEvent(ev);
diff --git a/editors/notepadnext/pkg-descr b/editors/notepadnext/pkg-descr
new file mode 100644
index 000000000000..d68d699ef54f
--- /dev/null
+++ b/editors/notepadnext/pkg-descr
@@ -0,0 +1,3 @@
+Notepad Next is a cross-platform reimplementation of Notepad++.
+
+WWW: https://github.com/dail8859/NotepadNext