aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-03-29 14:27:37 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-03-29 21:20:07 +0000
commit241c48ac4bac0afd02395208e47b206e6100eb1d (patch)
tree3c11e2de5b4e20fbbdc716a349322ff22c9c0cb6
parentd00d13d7ab37bc28e31e771b424a90ecaa9f06c4 (diff)
downloadports-241c48ac4bac0afd02395208e47b206e6100eb1d.tar.gz
ports-241c48ac4bac0afd02395208e47b206e6100eb1d.zip
devel/concurrencykit: Update to 0.7.2
Changelog: https://github.com/concurrencykit/ck/releases/tag/0.7.2 Reviewed by: bofh (maintainer)
-rw-r--r--devel/concurrencykit/Makefile40
-rw-r--r--devel/concurrencykit/distinfo8
-rw-r--r--devel/concurrencykit/pkg-plist7
3 files changed, 27 insertions, 28 deletions
diff --git a/devel/concurrencykit/Makefile b/devel/concurrencykit/Makefile
index 4eec9a023026..44500ea0bfa3 100644
--- a/devel/concurrencykit/Makefile
+++ b/devel/concurrencykit/Makefile
@@ -1,47 +1,43 @@
PORTNAME= concurrencykit
-PORTVERSION= 0.6.0
-PORTREVISION= 1
+DISTVERSION= 0.7.2
CATEGORIES= devel
-MASTER_SITES= http://concurrencykit.org/releases/ \
- http://repnop.org/releases/
-DISTNAME= ck-${PORTVERSION}
-
-PATCH_SITES= https://github.com/${PORTNAME}/ck/commit/
-PATCHFILES= 999d4612e873bb19867ad1d7043c9c18c7c4d3b9.patch:-p1
MAINTAINER= bofh@FreeBSD.org
COMMENT= Lock-free data structures for high performance concurrent systems
-WWW= http://concurrencykit.org
+WWW= https://github.com/concurrencykit/ck
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 powerpc powerpc64 powerpc64le
-OPTIONS_DEFINE= RTM VMAPACK
-OPTIONS_DEFAULT= VMAPACK
-
-RTM_DESC= Restricted Transactional Memory (x86_64 only)
-VMAPACK_DESC= Enable pointer packing
-
-RTM_CONFIGURE_ON= --enable-rtm
-VMAPACK_CONFIGURE_ON= --enable-pointer-packing
-
USES= pkgconfig
USE_LDCONFIG= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS+= --mandir=${PREFIX}/share/man
+USE_GITHUB= yes
+GH_PROJECT= ck
+HAS_CONFIGURE= yes
+
+PLIST_SUB= DISTVERSION=${DISTVERSION}
TEST_TARGET= check
-PLIST_SUB+= VERSION=${PORTVERSION}
+CONFIGURE_ARGS= --mandir=${PREFIX}/share/man
+
+OPTIONS_DEFINE= RTM VMAPACK
+OPTIONS_DEFAULT=VMAPACK
+
+RTM_DESC= Restricted Transactional Memory (x86_64 only)
+VMAPACK_DESC= Enable pointer packing
+
+RTM_CONFIGURE_ON= --enable-rtm
+VMAPACK_CONFIGURE_ON= --enable-pointer-packing
post-extract:
${REINPLACE_CMD} -e 's|PKGCONFIG_DATA=@LIBRARY@|PKGCONFIG_DATA=${PREFIX}/libdata/|g' \
${WRKSRC}/Makefile.in
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libck.so.${PORTVERSION}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libck.so.${DISTVERSION}
.include <bsd.port.mk>
diff --git a/devel/concurrencykit/distinfo b/devel/concurrencykit/distinfo
index 236c9dc73dea..e734b4e195df 100644
--- a/devel/concurrencykit/distinfo
+++ b/devel/concurrencykit/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1580160889
-SHA256 (ck-0.6.0.tar.gz) = d7e27dd0a679e45632951e672f8288228f32310dfed2d5855e9573a9cf0d62df
-SIZE (ck-0.6.0.tar.gz) = 217198
-SHA256 (999d4612e873bb19867ad1d7043c9c18c7c4d3b9.patch) = f59fb4d7cc959e48ac7cbe19f4e183c682bf316f946a732d27de5654bcc9e8b4
-SIZE (999d4612e873bb19867ad1d7043c9c18c7c4d3b9.patch) = 1693
+TIMESTAMP = 1711721350
+SHA256 (concurrencykit-ck-0.7.2_GH0.tar.gz) = 568ebe0bc1988a23843fce6426602e555b7840bf6714edcdf0ed530214977f1b
+SIZE (concurrencykit-ck-0.7.2_GH0.tar.gz) = 257817
diff --git a/devel/concurrencykit/pkg-plist b/devel/concurrencykit/pkg-plist
index 224127ac0f05..794a692a1a61 100644
--- a/devel/concurrencykit/pkg-plist
+++ b/devel/concurrencykit/pkg-plist
@@ -7,6 +7,7 @@ include/ck_bytelock.h
include/ck_cc.h
include/ck_cohort.h
include/ck_elide.h
+include/ck_ec.h
include/ck_epoch.h
include/ck_fifo.h
include/ck_hp_fifo.h
@@ -47,6 +48,10 @@ include/gcc/ppc/ck_f_pr.h
include/gcc/ppc/ck_pr.h
include/gcc/ppc64/ck_f_pr.h
include/gcc/ppc64/ck_pr.h
+include/gcc/riscv64/ck_f_pr.h
+include/gcc/riscv64/ck_pr.h
+include/gcc/s390x/ck_f_pr.h
+include/gcc/s390x/ck_pr.h
include/gcc/sparcv9/ck_f_pr.h
include/gcc/sparcv9/ck_pr.h
include/gcc/x86_64/ck_f_pr.h
@@ -64,7 +69,7 @@ include/spinlock/mcs.h
include/spinlock/ticket.h
lib/libck.a
lib/libck.so
-lib/libck.so.%%VERSION%%
+lib/libck.so.%%DISTVERSION%%
lib/libck.so.0
libdata/pkgconfig/ck.pc
share/man/man3/ck_array_buffer.3.gz