aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-03-11 15:00:50 +0000
committerStefan Eßer <se@FreeBSD.org>2022-03-11 15:00:50 +0000
commit243bc134121f464a3a7b39a85debc78ddf2e8274 (patch)
tree7deef5b579d7c52fb4a6854d56d08c4603ba0d52
parent982e968ef61a94e0de75d733e9036e5c60afca34 (diff)
downloadports-243bc134121f464a3a7b39a85debc78ddf2e8274.tar.gz
ports-243bc134121f464a3a7b39a85debc78ddf2e8274.zip
net/samba41[23]: set PYTHONHASHSEED during build
The build with CCACHE can be significantly sped up by passing PYTHONHASHSEED=1 in the environment to make the build reproducible with regard to the compiler commands issued. PR: 262092 Reported by: chris at chrullrich.net (Christian Ullrich)
-rw-r--r--net/samba412/Makefile1
-rw-r--r--net/samba413/Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/net/samba412/Makefile b/net/samba412/Makefile
index 69d400b31181..7357b9e53081 100644
--- a/net/samba412/Makefile
+++ b/net/samba412/Makefile
@@ -63,6 +63,7 @@ CONFIGURE_ARGS+= --mandir="${MANPREFIX}/man" \
--with-logfilebase="${SAMBA4_LOGDIR}"
# XXX: Flags
CONFIGURE_ENV+= PTHREAD_LDFLAGS="-lpthread"
+MAKE_ENV+= PYTHONHASHSEED=1
USES+= compiler:c++11-lang iconv localbase:ldflags \
perl5 pkgconfig shebangfix ssl waf gettext-runtime
diff --git a/net/samba413/Makefile b/net/samba413/Makefile
index f15ba16e514a..f4435e389f2e 100644
--- a/net/samba413/Makefile
+++ b/net/samba413/Makefile
@@ -66,6 +66,7 @@ CONFIGURE_ARGS+= --mandir="${MANPREFIX}/man" \
--with-logfilebase="${SAMBA4_LOGDIR}"
# XXX: Flags
CONFIGURE_ENV+= PTHREAD_LDFLAGS="-lpthread"
+MAKE_ENV+= PYTHONHASHSEED=1
USES+= compiler:c++11-lang iconv localbase:ldflags \
perl5 pkgconfig shebangfix waf gettext-runtime