aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-07-26 07:03:23 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-07-26 07:04:04 +0000
commit246333eca493bcd5568689f249dc16d2046d3900 (patch)
tree8ba6bd7b941bc0dc5df9f7bc58390b25a0995530
parent2ca9bcd573e3cae9538e22df3992d987726c537a (diff)
downloadports-246333eca493bcd5568689f249dc16d2046d3900.tar.gz
ports-246333eca493bcd5568689f249dc16d2046d3900.zip
biology/py-python-libsbml: Use CMAKE_BUILD_PARALLEL_LEVEL env var for parallelization
-rw-r--r--biology/py-python-libsbml/Makefile3
-rw-r--r--biology/py-python-libsbml/files/patch-setup.py22
2 files changed, 2 insertions, 23 deletions
diff --git a/biology/py-python-libsbml/Makefile b/biology/py-python-libsbml/Makefile
index d54f69ade095..73adc29c5285 100644
--- a/biology/py-python-libsbml/Makefile
+++ b/biology/py-python-libsbml/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= cmake:devel/cmake-core \
USES= python:3.8-3.9
USE_PYTHON= autoplist distutils # autoplist produces incomplete plist, missing files are in pkg-plist. Reported to the upstream author fbergman@caltech.edu on 2021-08-17
-MAKE_ENV= FREEBSD_MAKE_JOBS=${_MAKE_JOBS}
+
+MAKE_ENV= CMAKE_BUILD_PARALLEL_LEVEL=${MAKE_JOBS_NUMBER}
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/libsbml/_libsbml*.so
diff --git a/biology/py-python-libsbml/files/patch-setup.py b/biology/py-python-libsbml/files/patch-setup.py
deleted file mode 100644
index 17bdf70eb9ed..000000000000
--- a/biology/py-python-libsbml/files/patch-setup.py
+++ /dev/null
@@ -1,22 +0,0 @@
-- workaround for https://github.com/sbmlteam/python-libsbml/issues/36
-
---- setup.py.orig 2023-05-25 10:49:17 UTC
-+++ setup.py
-@@ -248,7 +248,7 @@ class CMakeBuild(build_ext):
- '-DWITH_LIBXML=OFF',
- ]
- )
-- self.spawn(['cmake', '--build', '.', '--target', 'install'] + build_args)
-+ self.spawn(['cmake', '--build', '.', '-j', os.getenv('FREEBSD_MAKE_JOBS'), '--target', 'install'] + build_args)
- os.chdir(cwd)
- DEP_DIR = dep_inst_dir
-
-@@ -297,7 +297,7 @@ class CMakeBuild(build_ext):
- os.chdir(build_temp)
- self.spawn(['cmake', SRC_DIR] + cmake_args)
- if not self.dry_run:
-- self.spawn(['cmake', '--build', '.', '--target', 'binding_python_lib'] + build_args)
-+ self.spawn(['cmake', '--build', '.', '-j', os.getenv('FREEBSD_MAKE_JOBS'), '--target', 'binding_python_lib'] + build_args)
-
- # at this point the build should be complete, and we have all the files
- # neeed in the temp build_folder