aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 07:02:20 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 07:02:20 +0000
commit249dd4b7de80bddef241339dff6b4d7993414a33 (patch)
tree9f071c3a2823924f628e1e7b207b0329965463e4
parentc962284f32f98ef573df92c477760d36be2ce96a (diff)
downloadports-249dd4b7de80bddef241339dff6b4d7993414a33.tar.gz
ports-249dd4b7de80bddef241339dff6b4d7993414a33.zip
textproc/discount: Fix build with Clang 16 and remove the workaround
-rw-r--r--textproc/discount/Makefile6
-rw-r--r--textproc/discount/files/patch-clang1611
2 files changed, 11 insertions, 6 deletions
diff --git a/textproc/discount/Makefile b/textproc/discount/Makefile
index a49535c576db..bec1db4494e5 100644
--- a/textproc/discount/Makefile
+++ b/textproc/discount/Makefile
@@ -38,12 +38,6 @@ EXTRA_CONFIGURE_ON= --with-dl=both --with-fenced-code --with-github-tags --with-
SAMPLES_INSTALL_TARGET= install.samples
TAB8_CONFIGURE_ON= --with-tabstops=8
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
-CFLAGS+= -Wno-error=incompatible-function-pointer-types
-.endif
-
post-install:
${INSTALL_DATA} ${WRKSRC}/libmarkdown.a ${STAGEDIR}${PREFIX}/lib/libmarkdown.a
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmarkdown.so
diff --git a/textproc/discount/files/patch-clang16 b/textproc/discount/files/patch-clang16
new file mode 100644
index 000000000000..c16d5f6fae9f
--- /dev/null
+++ b/textproc/discount/files/patch-clang16
@@ -0,0 +1,11 @@
+--- main.c.orig 2022-03-30 19:34:50 UTC
++++ main.c
+@@ -308,7 +308,7 @@ main(int argc, char **argv)
+ if ( squash )
+ mkd_e_anchor(doc, (mkd_callback_t) anchor_format);
+ if ( use_e_codefmt )
+- mkd_e_code_format(doc, external_codefmt);
++ mkd_e_code_format(doc, (mkd_callback_t) external_codefmt);
+
+ if ( use_e_codefmt || squash )
+ mkd_e_free(doc, free_it);