aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 13:03:54 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 13:37:14 +0000
commit24ed08e93699f78a88e630743ae13cbb1eba75ce (patch)
tree49cef1145c142cb9f185059738005a4368232a78
parentf56b4ba023a35a4267f25133aa172eaf7e86f93d (diff)
downloadports-24ed08e93699f78a88e630743ae13cbb1eba75ce.tar.gz
ports-24ed08e93699f78a88e630743ae13cbb1eba75ce.zip
security/py-oauthlib: Update to 3.2.0
-rw-r--r--security/py-oauthlib/Makefile38
-rw-r--r--security/py-oauthlib/distinfo6
-rw-r--r--security/py-oauthlib/pkg-descr8
3 files changed, 25 insertions, 27 deletions
diff --git a/security/py-oauthlib/Makefile b/security/py-oauthlib/Makefile
index 3e40a392348a..db4043c31e31 100644
--- a/security/py-oauthlib/Makefile
+++ b/security/py-oauthlib/Makefile
@@ -1,41 +1,37 @@
# Created by: Kubilay Kocak <koobs@FreeBSD.org>
PORTNAME= oauthlib
-PORTVERSION= 1.1.2
-PORTREVISION= 2
+PORTVERSION= 3.2.0
CATEGORIES= security net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
-COMMENT= RFC-compliant implementation of the OAuth request-signing logic
+COMMENT= Generic, spec-compliant, thorough implementation of the OAuth request-signing logic
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyjwt>=1.0.0:www/py-pyjwt@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}blinker>0:devel/py-blinker@${PY_FLAVOR}
-
-OPTIONS_DEFINE= RSA SIGNALS SIGNEDTOKEN
-OPTIONS_DEFAULT= RSA SIGNALS SIGNEDTOKEN
-
-RSA_DESC= Enable RSA Support
-SIGNALS_DESC= Enable signal support
-SIGNEDTOKEN_DESC= Support for Signed Token
-
-RSA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${PY_FLAVOR}
-SIGNALS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blinker>0:devel/py-blinker@${PY_FLAVOR}
-SIGNEDTOKEN_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyjwt>=1.0.0:www/py-pyjwt@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=4.0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>=2.6:devel/py-pytest-cov@${PY_FLAVOR}
USES= python:3.6+
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+OPTIONS_DEFINE= RSA SIGNALS SIGNEDTOKEN
+OPTIONS_DEFAULT=RSA SIGNALS SIGNEDTOKEN
+RSA_DESC= RSA support
+SIGNALS_DESC= Signal support
+SIGNEDTOKEN_DESC= Signed token support
+
+RSA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=3.0.0:security/py-cryptography@${PY_FLAVOR}
+SIGNALS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blinker>=1.4.0:devel/py-blinker@${PY_FLAVOR}
+SIGNEDTOKEN_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=3.0.0:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyjwt>=2.0.0<3:www/py-pyjwt@${PY_FLAVOR}
+
do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+ cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
.include <bsd.port.mk>
diff --git a/security/py-oauthlib/distinfo b/security/py-oauthlib/distinfo
index 55a03a9f3fc8..a21a5bb350f3 100644
--- a/security/py-oauthlib/distinfo
+++ b/security/py-oauthlib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1464883071
-SHA256 (oauthlib-1.1.2.tar.gz) = 0e83e91d9e77a396dc178eddba0c4abf75e465761804bfcdb20b977284bcb0bb
-SIZE (oauthlib-1.1.2.tar.gz) = 111706
+TIMESTAMP = 1647264668
+SHA256 (oauthlib-3.2.0.tar.gz) = 23a8208d75b902797ea29fd31fa80a15ed9dc2c6c16fe73f5d346f83f6fa27a2
+SIZE (oauthlib-3.2.0.tar.gz) = 163829
diff --git a/security/py-oauthlib/pkg-descr b/security/py-oauthlib/pkg-descr
index e3ab01556566..51fe905551b4 100644
--- a/security/py-oauthlib/pkg-descr
+++ b/security/py-oauthlib/pkg-descr
@@ -1,5 +1,7 @@
-OAuthLib is a generic Python module which implements the logic of OAuth without
-assuming a specific HTTP request object. Use it to graft OAuth support onto
-your favorite HTTP library.
+OAuthLib is a framework which implements the logic of OAuth1 or OAuth2 without
+assuming a specific HTTP request object or web framework. Use it to graft OAuth
+client support onto your favorite HTTP library, or provide support onto your
+favourite web framework. If you're a maintainer of such a library, write a thin
+veneer on top of OAuthLib and get OAuth support for very little effort.
WWW: https://github.com/oauthlib/oauthlib