aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-01-16 16:48:50 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-01-16 16:48:50 +0000
commit2503e680e1704b44b4a5650ed89774ea34fdf6c0 (patch)
tree8e389578fe070c475014983943bf353accb8296a
parent30b7768bea31a4013d998fdb325803a0fea71d47 (diff)
downloadports-2503e680e1704b44b4a5650ed89774ea34fdf6c0.tar.gz
ports-2503e680e1704b44b4a5650ed89774ea34fdf6c0.zip
- Don't use deprecated @dirrm in plist generation
- Use options helpers - There's no need to include bsd.port.pre.mk or bsd.port.options.mk Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=406240
-rw-r--r--sysutils/puppet4/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/sysutils/puppet4/Makefile b/sysutils/puppet4/Makefile
index f70c129f8898..b2f156bf3699 100644
--- a/sysutils/puppet4/Makefile
+++ b/sysutils/puppet4/Makefile
@@ -46,10 +46,6 @@ RFACTER_RUN_DEPENDS= rubygem-facter>=2.0:${PORTSDIR}/sysutils/rubygem-facter
CFACTER_BUILD_DEPENDS= facter>=3.0:${PORTSDIR}/sysutils/facter
CFACTER_RUN_DEPENDS= facter>=3.0:${PORTSDIR}/sysutils/facter
-.include <bsd.port.options.mk>
-
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e "s|/etc/puppetlabs/puppet|${ETCDIR}|" \
${WRKSRC}/install.rb \
@@ -99,14 +95,16 @@ post-install:
${SED} 's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${STAGEDIR}${RUBY_SITELIBDIR}/${PORTNAME} -type f | \
${SED} 's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${STAGEDIR}${RUBY_SITELIBDIR}/${PORTNAME} -type d | ${SORT} -r | \
- ${SED} 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
@${MKDIR} ${STAGEDIR}${WWWDIR}
${INSTALL_DATA} ${WRKSRC}/ext/rack/config.ru ${STAGEDIR}${WWWDIR}
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/ext/rack/example-passenger-vhost.conf ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>