aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-07-15 07:00:21 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-07-15 07:10:28 +0000
commit25237138341dc07b467664d4a83306338fc13ec0 (patch)
treea9e7ac32dd7cd3c014e5b90095cdf489498550ad
parenta81436761ac0c5f3048f096906837080b8ec7ae2 (diff)
downloadports-25237138341dc07b467664d4a83306338fc13ec0.tar.gz
ports-25237138341dc07b467664d4a83306338fc13ec0.zip
devel/zeal: Unbreak build with Qt 6
The port still fails at the moment because it picks Qt 5, but this will be fixed once we switch to kf6-extra-cmake-modules PR: 280070
-rw-r--r--devel/zeal/Makefile2
-rw-r--r--devel/zeal/files/patch-src_app_CMakeLists.txt8
2 files changed, 9 insertions, 1 deletions
diff --git a/devel/zeal/Makefile b/devel/zeal/Makefile
index 06a890d5fb61..7a2456a7a6e9 100644
--- a/devel/zeal/Makefile
+++ b/devel/zeal/Makefile
@@ -23,7 +23,7 @@ USE_GITHUB= yes
GH_ACCOUNT= zealdocs
USE_GL= opengl
USE_KDE= ecm
-USE_QT= base declarative positioning webchannel webengine
+USE_QT= base declarative positioning webchannel webengine tools:build
USE_XORG= ice sm x11 xcb xext
.include <bsd.port.mk>
diff --git a/devel/zeal/files/patch-src_app_CMakeLists.txt b/devel/zeal/files/patch-src_app_CMakeLists.txt
new file mode 100644
index 000000000000..0d4057fb3f7e
--- /dev/null
+++ b/devel/zeal/files/patch-src_app_CMakeLists.txt
@@ -0,0 +1,8 @@
+--- src/app/CMakeLists.txt.orig 2023-09-20 05:24:18 UTC
++++ src/app/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Widgets REQUIRED)
++find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Concurrent Network WebChannel WebEngineWidgets Widgets REQUIRED)
+ if (Qt${QT_VERSION_MAJOR}Widgets_VERSION VERSION_LESS QT_MINIMUM_VERSION)
+ message(FATAL_ERROR "Qt version >= ${QT_MINIMUM_VERSION} is required.")
+ endif()