aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2023-06-24 06:14:59 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2023-06-24 16:58:01 +0000
commit2523d477274a86fafc1e69adc0a69978d6cd099d (patch)
treec44b344ffb234854b13db896053fe0d2f006808d
parentad63312728a23d4e1722c78b3915a9fefc4c022e (diff)
downloadports-2523d477274a86fafc1e69adc0a69978d6cd099d.tar.gz
ports-2523d477274a86fafc1e69adc0a69978d6cd099d.zip
security/gost-engine: use new OSVERSION == 1400092
Remove temporary hack in favor of OSVERSION check for base OpenSSL version.
-rw-r--r--security/gost-engine/Makefile29
1 files changed, 13 insertions, 16 deletions
diff --git a/security/gost-engine/Makefile b/security/gost-engine/Makefile
index 4bbc16383612..fb19cdfc607f 100644
--- a/security/gost-engine/Makefile
+++ b/security/gost-engine/Makefile
@@ -25,10 +25,19 @@ USE_GITHUB= yes
GH_ACCOUNT= gost-engine
GH_PROJECT= engine
-BASE_OPENSSL_VSTR!= /usr/bin/openssl version
-BASE_OPENSSL_VER=${BASE_OPENSSL_VSTR:C/^OpenSSL //W:C/\..*//gW}
+ENGINESDIR?= ${PREFIX}/${EDIR}
+PLIST_SUB+= EDIR="${EDIR}" EDIRV="${EDIRV}"
+
+CMAKE_ARGS+= -DOPENSSL_ROOT_DIR=${OPENSSLBASE} \
+ -DOPENSSL_ENGINES_DIR=${ENGINESDIR}
+
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= DOCS
-.if ${FLAVOR:U} == openssl30 || ${BASE_OPENSSL_VER:U} == 3
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 || ${FLAVOR:U} == openssl30
GH_TAGNAME= 2b22503
GH_TUPLE+= provider-corner:libprov:e9f3e6a:libprov
GH_SUBDIR= libprov:libprov
@@ -36,7 +45,7 @@ DISTVERSION= g20230106
EDIR?= lib/engines-12
EDIRV?= @comment unused
DISTINFO_FILE= ${.CURDIR}/distinfo.openssl30
-.if ${BASE_OPENSSL_VER:U} != 3
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1400092
BROKEN_SSL+= base # openssl31
.endif
.else
@@ -47,18 +56,6 @@ EDIR?= lib/engines-1.1
EDIRV?= ${EDIR}
.endif
-ENGINESDIR?= ${PREFIX}/${EDIR}
-PLIST_SUB+= EDIR="${EDIR}" EDIRV="${EDIRV}"
-
-CMAKE_ARGS+= -DOPENSSL_ROOT_DIR=${OPENSSLBASE} \
- -DOPENSSL_ENGINES_DIR=${ENGINESDIR}
-
-SUB_FILES= pkg-message
-
-OPTIONS_DEFINE= DOCS
-
-.include <bsd.port.options.mk>
-
.if ${SSL_DEFAULT} == openssl30
FLAVOR= openssl30
.endif