aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Saietskii <vsasjason@gmail.com>2024-02-04 13:28:58 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2024-03-19 14:18:27 +0000
commit253998fe7a481ed01515242b5a1a37754f76321e (patch)
tree6181cdedd574a6f7d58729a9385169a9349eb983
parent834bd237e766c2d3334601d3b8d4ac788dbfd54a (diff)
downloadports-253998fe7a481ed01515242b5a1a37754f76321e.tar.gz
ports-253998fe7a481ed01515242b5a1a37754f76321e.zip
net-p2p/tremotesf: enable qt5 (default) & qt6 flavors
While here, bundle back cpp-httplib as tremotesf doesn't support 0.15.x (version we have in ports, which is also broken on 13). PR: 276822
-rw-r--r--net-p2p/tremotesf/Makefile29
-rw-r--r--net-p2p/tremotesf/distinfo4
2 files changed, 25 insertions, 8 deletions
diff --git a/net-p2p/tremotesf/Makefile b/net-p2p/tremotesf/Makefile
index f00a20d800f2..5783f0b61922 100644
--- a/net-p2p/tremotesf/Makefile
+++ b/net-p2p/tremotesf/Makefile
@@ -1,5 +1,6 @@
PORTNAME= tremotesf
DISTVERSION= 2.6.0
+PORTREVISION= 1
CATEGORIES= net-p2p
MAINTAINER= vsasjason@gmail.com
@@ -11,20 +12,34 @@ LICENSE_FILE= ${WRKSRC}/LICENSES/GPL-3.0-or-later.txt
BUILD_DEPENDS= cxxopts>0:devel/cxxopts
LIB_DEPENDS= libfmt.so:devel/libfmt \
libpsl.so:dns/libpsl
-TEST_DEPENDS= cpp-httplib>0:www/cpp-httplib
-USES= cmake:testing desktop-file-utils gettext-tools kde:5 pkgconfig \
- qt:5 xorg
+FLAVORS= qt5 qt6
+FLAVOR?= ${FLAVORS:[1]}
-USE_GITHUB= yes
-GH_ACCOUNT= equeim
-GH_PROJECT= tremotesf2
+qt5_CONFLICTS_INSTALL= ${PORTNAME}-qt6
+qt6_PKGNAMESUFFIX= -qt6
+qt6_CONFLICTS_INSTALL= ${PORTNAME}
-USE_KDE= widgetsaddons windowsystem
+USES= cmake:testing desktop-file-utils gettext-tools pkgconfig xorg
+.if ${FLAVOR} == qt5
+USES+= kde:5 qt:5
USE_QT= core dbus gui network widgets buildtools:build concurrent:build \
linguisttools:build qmake:build testlib:build
+.else
+USES+= gl kde:6 qt:6
+USE_GL= opengl
+USE_QT= base
+CMAKE_ON= TREMOTESF_QT6
+.endif
+USE_GITHUB= yes
+GH_ACCOUNT= equeim yhirose:httplib
+GH_PROJECT= tremotesf2 cpp-httplib:httplib
+GH_SUBDIR= src/3rdparty/cpp-httplib:httplib
+GH_TAGNAME= v0.14.3:httplib
+
+USE_KDE= widgetsaddons windowsystem
USE_XORG= x11
.include <bsd.port.mk>
diff --git a/net-p2p/tremotesf/distinfo b/net-p2p/tremotesf/distinfo
index 708b93b167c6..548f2744eab3 100644
--- a/net-p2p/tremotesf/distinfo
+++ b/net-p2p/tremotesf/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1704887270
+TIMESTAMP = 1707052134
SHA256 (equeim-tremotesf2-2.6.0_GH0.tar.gz) = 0be5fff67a542a02287088ba0a9d9019ab01d0eef4120243002e011cb65cd37e
SIZE (equeim-tremotesf2-2.6.0_GH0.tar.gz) = 758704
+SHA256 (yhirose-cpp-httplib-v0.14.3_GH0.tar.gz) = dcf6486d9030937636d8a4f820ca9531808fd7edb283893dddbaa05f99357e63
+SIZE (yhirose-cpp-httplib-v0.14.3_GH0.tar.gz) = 1149767