aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-11-05 12:22:49 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-11-05 12:22:49 +0000
commit254f0cf6c4cbdcfdc79ec284728f6aabd2e03014 (patch)
tree3c787278bdd107c5a65fb201a7b7fcf5c39ebf66
parente6ea6e6aba3f984713959581c83c081c3674b781 (diff)
downloadports-254f0cf6c4cbdcfdc79ec284728f6aabd2e03014.tar.gz
ports-254f0cf6c4cbdcfdc79ec284728f6aabd2e03014.zip
games/toppler:
- fix permission for binary and high score file - drop deprecated keywords from plist
Notes
Notes: svn path=/head/; revision=372186
-rw-r--r--games/toppler/Makefile7
-rw-r--r--games/toppler/files/patch-Makefile.in11
-rw-r--r--games/toppler/pkg-plist11
3 files changed, 13 insertions, 16 deletions
diff --git a/games/toppler/Makefile b/games/toppler/Makefile
index 24254efca2d3..51205ef5f6aa 100644
--- a/games/toppler/Makefile
+++ b/games/toppler/Makefile
@@ -3,7 +3,7 @@
PORTNAME= toppler
PORTVERSION= 1.1.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
@@ -22,4 +22,9 @@ LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS
+SCOREFILE= /var/games/toppler/toppler.hsc
+
+post-install:
+ ${MV} ${STAGEDIR}${SCOREFILE} ${STAGEDIR}${SCOREFILE}.sample
+
.include <bsd.port.mk>
diff --git a/games/toppler/files/patch-Makefile.in b/games/toppler/files/patch-Makefile.in
index c5fd1c802f7f..483a2cc60b63 100644
--- a/games/toppler/files/patch-Makefile.in
+++ b/games/toppler/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- ./Makefile.in.orig 2011-03-06 20:00:43.000000000 +0000
-+++ ./Makefile.in 2013-10-23 16:58:33.155503773 +0000
+--- Makefile.in.orig 2011-03-06 20:00:43 UTC
++++ Makefile.in
@@ -359,7 +359,7 @@
dist_pixmaps_DATA = $(PACKAGE).xpm
applications_DATA = $(PACKAGE).desktop
@@ -9,12 +9,9 @@
dist_pkgdata_DATA = \
toppler.dat toppler.ogg \
m1.ttm m2.ttm ball1.ttm ball2.ttm ball3.ttm abc.ttm pasi2.ttm david1.ttm
-@@ -1084,16 +1084,14 @@
-
- install-data-am: install-applicationsDATA install-dist_pixmapsDATA \
+@@ -1086,14 +1086,12 @@
install-dist_pkgdataDATA install-dist_pkgdocDATA \
-- install-dist_pkglocalstateDATA install-man
-+ install-man
+ install-dist_pkglocalstateDATA install-man
@$(NORMAL_INSTALL)
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
install-dvi: install-dvi-recursive
diff --git a/games/toppler/pkg-plist b/games/toppler/pkg-plist
index 6e1eadb50ead..8d1d116bcead 100644
--- a/games/toppler/pkg-plist
+++ b/games/toppler/pkg-plist
@@ -1,4 +1,4 @@
-bin/toppler
+@(,games,2555) bin/toppler
man/man6/toppler.6.gz
share/applications/toppler.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
@@ -23,10 +23,5 @@ share/pixmaps/toppler.xpm
%%DATADIR%%/pasi2.ttm
%%DATADIR%%/toppler.dat
%%DATADIR%%/toppler.ogg
-@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@exec mkdir -p /var/games/toppler
-@exec chgrp games /var/games/toppler
-@unexec if [ ! -s /var/games/toppler/toppler.hsc ] ; then rm -f /var/games/toppler/toppler.hsc; rmdir /var/games/toppler ; fi
-@exec touch /var/games/toppler/toppler.hsc
-@exec chmod 664 /var/games/toppler/toppler.hsc
+@sample(,games,664) /var/games/toppler/toppler.hsc.sample
+@dir(,games,775) /var/games/toppler